Questions tagged [install]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1
vote
1answer
17 views

Craft 3 install problem on windows 10

Anyone come across this problem with installing craft3 on windows with MAMP Pro. I have installed composer and this seems to be working fine. The php path I added directs composer to C:/MAMP/bin/php/...
1
vote
1answer
24 views

New Install, Permission Errors With /storage

I've configured Apache vHosts on a local box and installed a Craft 3 website onto it. This new instance will serve as my "staging" environment for an upcoming website. I've installed with composer ...
1
vote
1answer
69 views

Craft CMS 3 Installed but not working

I have a remote repository with a Craft install and am trying to pull it to a new environment. I run the composer install and Craft & other packages install seemingly correctly, added the .env ...
1
vote
1answer
19 views

Composer require looking to craft/plugins/[plugin] directory but throws runtime error?

I've got Craft 3.1.32 up and running on dev machines and we're ready to get it into our test/stage enviromnments, which are built through a GitLab CI/CD. While doing this, we noticed some plugins ...
0
votes
0answers
62 views

Installing Craft CMS 3 on hosting - Unsupported DB driver value

i am trying to instal Craft CMS 3 on hosting and everytime it is going to fall on: 2019-07-05 16:33:55 [-][-][-][error][craft\base\ApplicationTrait::getIsDbConnectionValid] There was a problem ...
0
votes
1answer
27 views

Fatal PHP error upon installation

I attempted to install the newest version of Craft and received this error in my logs: PHP Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\craft-cms\vendor\yiisoft\yii2\...
1
vote
1answer
34 views

Charset issue in Control Panel

I'm trying to install Craft v3 on a web server currently running Craft 2. As far as I am aware all the required PHP extensions (including iconv) are installed; PHP v7.1.x The front end works OK, but ...
2
votes
2answers
58 views

my vendor/craftcms/cms folder delete automatically after every update or install

I was on version 3.1.22. As usual, I wanted to install the update on Craft CMS 3.1.23. So I clicked Install and got this error: Status: Error But that was not all ... My complete vendor/craftcms/...
1
vote
1answer
106 views

Install Failed - Numerous Errors when running with pgsql

Getting Numerous errors when trying to test a staging environment with Craft 3.1. States Install Failed - Check Logs which I have and I'm seeing the following logs being given. I don't understand what'...
2
votes
0answers
112 views

Craft install failed on WAMP

I carefully read the installation manual, read PHP and apache error logs, but I still don't know why it's failed. (Solution - Maximum execution time of 120 seconds is not enough) - Windows 10 64 - ...
1
vote
1answer
56 views

Importing Craft CMS Locally

I've inherited an existing website created using CraftCMS and hosted on Fortrabbit. I'm fairly new to CraftCMS but anxious to get started on a couple of updates. The site currently exists on ...
1
vote
1answer
35 views

How can I “clear” an entire website

I'm selling the same website build in Craft to multiple clients and was wondering if it is possible to clear all user generated content of an install. So delete all the entries, categories, assets, ...
1
vote
1answer
359 views

Ran the Craft Updater from Control Panel the current install is no longer working

The previous install (3.0.34) was working fine until I ran the updater from the CP. The update failed with error (couldn't access web.config (IIS)) Now loading CP or front end displays the following ...
1
vote
1answer
66 views

Error on updating Craft install with Sprout vendor files

I was updating an Craft install on Mediatemple server yesterday. Im now getting the following error: Cannot use barrelstrength\sproutbase\app\import\base\FieldImporter as FieldImporter because the ...
1
vote
1answer
370 views

Craft 3: admin is showing “500 Internal Server Error” (apache) after fresh install

Just successfully installed a fresh copy of Craft CMS via web browser method under: http://kultursprung.org Frontend is visible but the admin is showing raw Apache error 500 after fresh install: http:...
0
votes
1answer
160 views

Install suggestions?

This happens on every install (see below suggestions) via Composer on a MAMP Pro stack, running PHP 7.1, Mysql 5.7 & Composer 1.7.2. Albeit suggestions, could this affect the performance or ...
4
votes
1answer
571 views

Craft install via composer: install to public_html?

When I do composer create-project craftcms/craft, it will create a web folder. My webroot is called public_html though. Can I change this somehow, or should I make a symlink? Or simply don't use ...
2
votes
1answer
60 views

No index.php file created during install using composer

This is on Centos 7.5 using a vmware local vm Installed Apache, MariaDB 10.2, PHP 7.1 (Remi) in that order Logged in as root, no sudo or su Installed composer 1.6.5 without issue cd /var/www/...
2
votes
1answer
81 views

Install instructions

I'm having difficulties following the install instructions found at https://docs.craftcms.com/v3/installation.html. I've ssh'd into my server, and I'm running composer to install Craft, as directed in ...
1
vote
2answers
179 views

Manually creating Security Key gives PHP error

I'm going on 5 days of banging my head on my desk here. I'm simply not getting how to install it on my production server. I have Craft working beautifully locally...but getting it to my server is a ...
0
votes
0answers
93 views

Install Craft 3 in public folder

Is it still possible to install all of Craft 3 in a public folder? Like you could with Craft 2. If it is, how do I do it?
1
vote
1answer
184 views

500 Error on AWS bitnami instance

I have a fresh LAMP instance based on a bitnami image on AWS. All server requirements are met for Craft 2, but I'm getting a 500 error when trying to hit the site: site.com is currently unable to ...
3
votes
1answer
391 views

help setting up web root to point to /web

I'm new to Craft 3 and I need help getting the web root to point to /web. I can't figure it out. If I use the url "mysite.com/web" everything works fine. Any help would be gratefully received.
1
vote
0answers
368 views

Craft 3 installation in git repository

I am looking for the best way of installing a fresh craft 3 project and making it a git repo. I tried the following: Option 1: first creating an empty new git repo clone the empty repo to my pc ...
0
votes
1answer
518 views

'Craft requires PHP 7.0 or later'

I took the manual install route, unzipped the latest Craft version, and edited the .env file with my database settings, but when I direct my browser to /craft/web/index.php I get a plain page with ...
1
vote
3answers
2k views

Installing Craft 3 - Internal server error

Using Ampps on Windows, I'm trying to install a fresh Craft 3.0 and I've followed the steps and everything seems to be working. Until the very last step, where Craft says "Oops something went wrong". ...
1
vote
2answers
598 views

Installing Craft 3 without composer

So i copied the craft files onto my server. Web directory went into my public folder. I type in my address, I get the Craft service unavailable page, good so far. I cant get to the installer. http://...
2
votes
4answers
3k views

Install Craft 3 on Web Server

I scoured the the web to the ends of earth and couldn't find any info on how to install Craft 3 on my VPS. The package I downloaded is unconventional in many ways. Any ideas how to get Craft running? ...
1
vote
0answers
61 views

Trying to restore a Craft instance for a customer who was abandoned

I am new to Craft and a client asked us to take over a site as the previous service provider abandoned them. For now just trying to get up and running on a Windows server in a test environment before ...
1
vote
2answers
668 views

Blank screen for /admin and public site with Craft 3

I've just installed Craft 3 RC with Composer. Everything went fine. I moved the contents of the web directory to the public_html folder. domain.com/admin and domain.com both give blank screens. ...
1
vote
2answers
599 views

How do I get past this MySQL error installing Craft 3 using CLI

I am using https://box.scotch.io/ (vagrant). I'm trying to install Craft 3 with the cli, but can't get past these errors: Connection refused No such file or directory One or the other error shows ...
1
vote
2answers
571 views

Problem setting security key when installing Craft 3

I'm new to Composer and am using a Mac along with MAMP as a local web server. I've installed Composer but it's referencing an old PHP 5 version that must be the default on my Mac. I was able to ...
1
vote
1answer
162 views

Pro trial not showing

Craft Personal 3.0.0-RC2 doesn't show the Pro Trial offer anymore? Is that correct? I did install a Pro License however this triggers the system to change the domain (from local dev to live) which is ...
1
vote
1answer
456 views

Installing Craft 3 RC on MAMP Pro - Pointing to the file directory

After a successful install I point the (MAMP PRO 4+) Document Root to the Craft /web folder, which allows the final setup process. (via www/admin) However pointing at the site root (www) triggers this ...
1
vote
2answers
1k views

Craft 3 via composer with Mamp Pro

Is it possible to get an idiots guide to this: Error on Craft 3 install I'm just not following the context of the answer/commands, a detailed step by step would be invaluable for fear of trying ...
1
vote
1answer
305 views

Installing Craft in a Sub Folder

I have created a Craft CMS site on a VPS Server running CentOS 7. I have a file setup on the public_html like this: - cms craft public app (this is running a Symfony Framework Web App and runs from ...
1
vote
1answer
97 views

Craft 2.6.2999 install error: Base table or view already exists: 1050 Table 'craft_entryversions' already exists'

I keep getting stranded at the "Oops" modal on install. This is on the third Craft site I've started. The other two Craft 2 sites stood up fine, an I've been developing them for nearly a year. I've ...
0
votes
1answer
300 views

Can't install - Oops at step three

I’m a would-be first-time Craft user. I’m trying to set up a first trial site but not having much success. I’ve been trying to install Craft CMS on my host provider’s server. I use SmartHosting/...
2
votes
1answer
202 views

Can I rename my craft/ folder?

I have one site on my server that's currently using Craft, and I'd like to setup a second one to use Craft as well. Can I rename the craft folder, and then set the $craftPath variable to point to it?
1
vote
1answer
197 views

Can't send emails

I've got an "escapeshellcmd() has been disabled for security reasons" warning whenever I try to send an email using Craft (user activation email), is there a way around it?
1
vote
0answers
111 views

White screen trying to install, log shows call to undefined function ctype_alpha()

I have looked through every resource I can find for this question and haven't had any luck. OS: Ubuntu 16.04 localhost successfully shows Ubuntu landing page localhost/info.php successfully shows ...
1
vote
1answer
798 views

Running into permission issues using Vagrant on Ubuntu

I am having issues running CraftCMS in a vagrant environment. For reference: I am using ubuntu 17.04 Vagrant version 1.9.5 ubuntu/xenial64 (virtualbox, 20170525.0.0) Relevant initial ...
3
votes
1answer
406 views

Having issues with Craft install on Laravel Valet.

I'm having some trouble getting Craft to install with Laravel Valet. All I'm getting on the .dev, .dev/admin, .dev/index.php/admin? is the 'service unavailable'. Not sure if it's just new to Craft or ...
1
vote
1answer
191 views

Issue with Vagrant/Homestead setup (server requirements message) [closed]

I'm trying to set up a local dev environment for Craft. I've been following this video So far, I've installed Composer, Vagrant, and Virtual Box. I have my Homestead.yaml file set up and going to ...
1
vote
0answers
565 views

Getting a 503 Error before Craft installs - [error] [exception.Craft\HttpException.503] Craft\HttpException

In the browser, I'm getting a page that says: Service Unavailable Our site is temporarily unavailable. Please try again later. In my craft.log, I'm getting a 503 error that says: *******************...
1
vote
2answers
375 views

Why is htaccess file not named “.htaccess” on fresh install?

I run into the same error on each project setup with CraftCMS. So did I this time… again… First of all: Yes, I seem to be a slow learner. And therefore I can't memorize to rename the htaccess file ...
1
vote
1answer
102 views

Help needed with 2 node setup

I am setting up 2 node cluster with GlusterFS for shared file system. I have mounted the shared mount on each of the nodes but when I try to access login page I get this /data/websites/websiteapp/...
1
vote
1answer
206 views

What do I use for the Path to the Craft folder?

I want to place my Craft folder above the root. But, this is for an add-on site that sits within the public_html folder of the main site. So, the index.php file sits here... ../public_html/add-...
0
votes
1answer
992 views

'Could not find your craft/ folder' error despite following installation instructions

Thanks in advance for any help - I'm starting to feel like a fool for coming up against errors so often. But here goes. I have confirmed with my hosting provider that Craft CMS is compatible. I have ...
0
votes
1answer
458 views

404 message after following Craft installation instructions

I'm installing Craft CMS on my domain which was formerly functional (previously used Wordpress). I removed all Wordpress files through FileZilla FTP and uploaded Craft files. I put the /Craft folder ...