Questions tagged [server]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
0 answers
30 views

Internal server error - Cannot serve directory

Randomly a couple of times a day my website throws an Internal Server Error that fixes itself within minutes. Checking the logs (have replaced my username with 'username') it looks like a server issue ...
user avatar
  • 11
0 votes
0 answers
45 views

Can someone help me solve for this error message: "Craft can't connect to the database with the credentials...."

Can someone help me solve for this error message: An exception has been thrown during the rendering of a template ("Craft can't connect to the database with the credentials in craft/config/db.php....
user avatar
2 votes
1 answer
29 views

Child (inner) Path of backend in Virtual Host is possible?

I have ISP Config host virtual website which is a system tool to host many websites. Document root path '/' is not writable. I have an /private, which is writable. I used alias @root as /private, and ...
user avatar
0 votes
0 answers
27 views

500 errors, fix them then lose plugins and site won't load

I've been going around in circles. Moved a site yesterday, all seemed OK. Went to install a plugin this evening, and got a fatal error (I had been getting the same error when transferring the site, ...
user avatar
0 votes
0 answers
34 views

Update following site import leads to fatal error

Today, I have moved a fully up-to-date installation to a new server, and three times now on a seemingly successful installation, after going to update to the latest version (the existing install is up ...
user avatar
1 vote
2 answers
308 views

What server settings would be responsible to debug "The process has been signaled with signal 9" errors?

We're running Craft in an AWS environment that is configured using CentOS 7, Apache 2.4.x, PHP 7.4.x, PHP-FPM and we've noticed many of our queued tasks fail (sometimes only 8-10 minutes into the ...
user avatar
1 vote
1 answer
136 views

MySQL error when sync database using Craft Script from Craft Nitro

I'm trying to sync the database from staging to local (Craft Nitro) using the craft-script as per the article. Here is the error message, Usage: mysqldump [OPTIONS] database [tables] OR mysqldump [...
user avatar
  • 139
0 votes
0 answers
49 views

SyncDB with Nitro Fail to sync database from local to staging

I'm trying to sync the database for my local Craft Nitro to the staging environment using SyncDB. Here is the error, [2021-06-04T15:49:51.623536+08:00] sync.NOTICE: Starting database sync [] [] [2021-...
user avatar
  • 139
1 vote
1 answer
83 views

Server down (timeout) when optimize bundle of image (Image Optimize Plugin)

I try to use the Image Optimize plugin to optimize the image with default Craft Transform. There are lots of images to be optimized at the same time, I keep having the issue of server down. Here is ...
user avatar
  • 139
0 votes
0 answers
59 views

A server error occurred on drag and drop of entries

I am getting 'A server error occurred' at the top of the screen when trying to drag and drop entries in a structure. It happens only on my live site, local site works fine. I have tried to change the ...
user avatar
1 vote
1 answer
76 views

Configure path craft uses for composer and php

Is it possible to configure the PATH to composer that craft is using? In a shared hosting (our server, lots of sites) php isn't available by default. It's provided via redhat software collections. ...
user avatar
  • 131
0 votes
0 answers
97 views

Internal Server Error when updating slug

I'm getting an internal server error when I try to update the my entry's slug on prod, but not on dev or locally. It's happening across entries, it doesn't seem to be specific to a certain entry. Any ...
user avatar
  • 1
0 votes
0 answers
110 views

Certificate problems when sending mail via smpt (tream_socket_enable_crypto(): SSL operation failed with code 1)

I know there were already a lot of these issues on this board, but none solved mine, unfortunately. Be assured that I searched quite a lot (for hours) but could not solve it. I hope I have not ...
user avatar
  • 461
1 vote
1 answer
320 views

500 Internal Server Error when accessing admin

I just get a server error when trying to access /admin, or any other URL. This is a completely new installation on a staging server. The 'Welcome' page shows OK. I'm guessing this is a .htaccess ...
user avatar
  • 700
1 vote
1 answer
135 views

500 Error after Dreamhost server upgrade

Dreamhost upgraded my VPS overnight and I immediately got a 500 error. The site currently works on another Dreamhost VPS (the original below) and an Arcustech server. After checking the error logs I'm ...
user avatar
  • 11
0 votes
0 answers
223 views

Multisite with unique domains not working with Forge config

I have a live install with a primary domain of https://marketing.vessul.co/ which works great. When I've added another site to this install and it's location is another folder such as /extra-site it ...
user avatar
1 vote
4 answers
828 views

Less complicated local development w/Craft 3, is it possible?

I do not really care for WordPress, but one thing that it has going for is a dead simple local development environment. In fact, it free software called "Local". It took all of five minutes to get ...
user avatar
  • 684
1 vote
1 answer
221 views

Why is Craft storing so much temporary files inside the server tmp folder?

For several websites (Craft CMS 2 & 3), servers ran out ot storage even if these websites were not storing a lot of assets. After looking for why, I ended up in the temporary (tmp/) folder of ...
user avatar
1 vote
1 answer
82 views

Directories and files being created by "root" user, inaccessible to CMS

I'm new to Craft and have been asked to support a live site that is running on it. I've run into a problem that seems to be due to files on the server being created by the wrong user. The vast ...
user avatar
  • 11
2 votes
1 answer
1k views

Undefined index: siteSettings when updating entry types

I'm receiving an Undefined index: siteSettings when trying to save changes to entry types (both new and existing). Of course, this is only occurring on a production server - local server with up-to-...
user avatar
2 votes
1 answer
236 views

How does the Craft CMS built-in web server works?

I just found this while using ./craft help in the Craft CMS command line utilities: - serve Runs the PHP built-in web server. serve/index (default) ...
user avatar
0 votes
0 answers
298 views

404 shows "Internal Server Error" only on staging environment

Might be a duplicate, but couldn't find this exact question here. I have a pretty basic 404.twig template that should be catching things, as described here: https://docs.craftcms.com/v3/routing.html ...
user avatar
  • 73
1 vote
1 answer
17 views

layout file changes get deleted overnight

I've had a problem for a few weeks whereby any changes to a layout.html file get deleted overnight on a server. As a sanity check I just want to make sure there isn't anyway this can be done by Craft? ...
user avatar
  • 700
1 vote
1 answer
198 views

Craft 3 Upload To Bluehost - Index.php outside root issue

I'm having issues uploading my craft3 site to Bluehost. I've uploaded all the files, ran composer install and it does actually work. However when I go to my domain it shows the raw files/folders and ...
user avatar
1 vote
2 answers
313 views

Updating Asset Indexes Fails with TemplatesController Not Found Error in Craft Logs

Client wants to be able to upload a 90MB .mp4 file to a local asset folder, that understandably throws a 'General error: 2006 MySQL server has gone away'. I uploaded the file directly to the server ...
user avatar
2 votes
2 answers
606 views

Craft CMS not working on server

I had my Craft CMS site working on my local hosting. I then moved it over to bluehost VPS. I moved the database and uploaded the files to the server. I've put the database user information in the .env ...
user avatar
1 vote
0 answers
339 views

An unknown error occurred message, only on live server

Please can anyone give me some pointers. Just logged into the backend on an older (but live) 3.0.26.1 project. CP is now flashing multiple 'an unknown error occurred' messages on every CP request. ...
user avatar
0 votes
0 answers
58 views

Windows permissions error

Anyone experienced with issues setting up Craft on Windows server - getting phperror logs within Craft stating: The directory is not writable by the Web process for cpresources I have got the hosts ...
user avatar
  • 1,711
2 votes
1 answer
827 views

Migrating Server - Craft isn't installed yet

I've set up a new Forge server and connected the repo to my site. I've also uploaded the database and copied over the db credentials to the dotenv file. However when I visit the site control panel ...
user avatar
  • 1,897
0 votes
0 answers
297 views

Large file upload, 500 server error

We've a Craft 3 site hosted with Digital Ocean (Serverpilot set-up) with the DNS routed through Cloudflare. The client has experienced issues uploading large ZIP files to (c140MB), returning a 413 ...
user avatar
  • 1,711
1 vote
1 answer
1k views

Internal Server Error for admin login and dashboard

I deployed a Craft 3 site and the site is fine, however when I try and go to /admin to login I get a Craft "Internal Server Error - Server Error" message and can't access the dashboard. Any ideas ...
user avatar
3 votes
2 answers
8k views

Craft 3: 500 Internal Server Error when trying to install on server

For the last 3 days i've been trying to install Craft CMS 3 on my server. I'm using 1&1 internet, have FTP uploaded all the files, changed the permissions for the folders and files to the right ...
user avatar
1 vote
1 answer
495 views

When saving an Entry, I receive a JSON response rather than returning to the Entry's edit page

Craft Version: 3.0.4 Web Server: Apache + Nginx proxy Recently I've been working on a couple of Craft 3 projects for deployment on my institution's web servers. In the past, I've successfully ...
user avatar
  • 137
3 votes
4 answers
1k views

Craft 3 - Recommended development environment for Windows?

I was wondering what people who are developing on Windows 10 are using as webserver environment in 2018? I have had ok results previously using ampps, but I'm having a lot of problems with Craft 3 as ...
user avatar
1 vote
1 answer
2k views

Excessive resource usage / virtual memory size

Our server is generating lots of emails that follow this template: subject: lfd on host.foo.com: Excessive resource usage: foo (24056 (Parent PID:16356)) body: Time: Wed Jan 31 11:31:20 ...
user avatar
  • 438
1 vote
1 answer
101 views

Making a base url without /public

I'm creating a site that works now at www.mysite.com/public/ I would love to get to drop the /public off the url so it is: www.mysite.com Does anyone know how to do this? Thank you!
user avatar
  • 33
0 votes
1 answer
245 views

Code shows instead of homepage

A website I built frequently throws up the following code instead of the homepage: <?php // Path to your craft/ folder $craftPath = '../craft'; // Do not edit below this line $path = rtrim($...
user avatar
  • 421
3 votes
1 answer
623 views

Problems setting up a local site

I am running into problems with virtual hosts while trying to run Craft locally. My setup was working perfectly and after a restart of my mac I get error messages and I don't understand why. I am ...
user avatar
1 vote
1 answer
85 views

Visitor drop off since moving over to Craft CMS

Hi I've been managing my clients Wordpress site for over 7 years now and redesigned it a few times. Recently, I convinced my client to move over to Craft CMS and 4 months ago we went live with a new ...
user avatar
1 vote
1 answer
177 views

Optimizing With Http2 In Mind

My main config is Apache/Centos 7/WHM/Redis/OPCache/PHP7.1/MariaDb/PHP-fpm/Http2 and have optimized my server to a great degree. It's a 32GB dedicated HexaCore. I have worked really diligent to get ...
user avatar
  • 373
2 votes
2 answers
156 views

compiled_templates folder using up inodes on Ubuntu 14.04 Server

My server has gone down twice in the last 3 weeks because of an excessive number of files being created in the compiled_templates folder. This causes all of the inodes on our server to be used up ...
user avatar
  • 121
2 votes
2 answers
4k views

Login - Bad Request: The CSRF token could not be verified

I have just deployed an existing site to a new server. As the DNS is not pointing there yet, I have simply edited my /etc/hosts file on my Mac to point to the IP address for testing. Whilst checking ...
user avatar
2 votes
3 answers
3k views

HTTP ERROR 500 after move to live

I moved a site from staging to live. Prior to moving, I logged in to the Craft admin and cleared the caches. I copied the db to the new one and moved the folders like so… from… home/subdomains/craft ...
user avatar
2 votes
1 answer
2k views

Internal Server error during install

I've done a few installs of Craft and never had a problem. I'm currently trying to do an install on a new server under a subdmomain and getting the following results… This results in 404 http://...
user avatar
2 votes
1 answer
220 views

Sub-pages not loading on Windows server

I just moved a site over to a Windows server, and my homepage loads fine, but sub pages are not loading. I just get an error message that the connection was reset. Adding index.php to the url doesn't ...
user avatar
  • 950
1 vote
1 answer
512 views

Updated the PHP on server. Getting this error: Please ensure that $craftPath is set correctly

I am running Amazon Ec2 instance and tried updating the PHP on the site using this guide: http://brianshim.com/webtricks/update-amazon-ami-php5-3-to-php5-4/ And now this is the error I am receiving: ...
user avatar
4 votes
2 answers
716 views

Self-hosting requirements/scaling

Is there any reason the mySQL, CraftCMS, and assets/images/content can't all live on the same server, assuming the server is appropriately sized and backed up? Are there any sizing/scaling guidelines?...
user avatar
  • 41
2 votes
1 answer
51 views

finding core dumps in public root

Am suddenly finding lots of core..xxx files dumped in the root of my site. In devMode cant see any issues. Assume this is serious issue and memory dump? Where to start? Logs have loads of stuff but ...
user avatar
  • 1,886
2 votes
1 answer
298 views

Setting up Craft on Linode Using Ubuntu

I'm setting up a Craft site on a Linode server has anyone had any experience with this? I'm struggling with which owner and user to set the var/www/html folder to with chown and what chmod settings to ...
user avatar
  • 2,023
2 votes
1 answer
264 views

Do servers in a multi-server Craft setup need to share a storage directory?

We have a multi-server Craft setup, for redundancy and scaling. We've been using an shared NFS drive to to host Craft's storage directory, by setting CRAFT_STORAGE_PATH to a mounted /craft-data/ ...
user avatar