0

I attempted to install the newest version of Craft and received this error in my logs:

PHP Fatal error:  Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\craft-cms\vendor\yiisoft\yii2\db\Command.php on line 1292

I'm unsure of the cause of this error, but the the lines around 1292 in the command.php file seem to be an exception handler for database transactions.

I don't achieve a different result after lengthening the execution time. I've tried setting very lenient firewalls and administrator rights. I've also tried uninstalling and reinstalling all of the files. I still receive the same error every time.

Any ideas to fix this issue? I haven't found another post about this issue online, so any help would be very much appreciated.

  • 1
    Are you trying to install Craft via command line? Or via the browser? – Lindsey D Jun 19 at 18:16
  • The PHP execution the browser uses is a different one than the PHP executable the console uses and therefore they have different php.ini files. Make sure you're editing the correct one when bumping the max_execution_time setting. – Brad Bell Jun 19 at 19:23
  • I installed via the command line. Thank you both for your responses. I was able to fix the issue by maximizing the execution time. – syntaxanalyst Jun 20 at 6:29
0

For anyone with the same issue- I was able to fix the issue by setting the execution time as infinite and then waiting for an hour.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.