1

Using Ampps on Windows, I'm trying to install a fresh Craft 3.0 and I've followed the steps and everything seems to be working. Until the very last step, where Craft says "Oops something went wrong". Checking the console log I see the ajax call gets a 500 internal server error as response.

I can see that the database is getting filled up with tables etc so it seems Craft has a working connection to the database. I also tried to set devmode to True in general.php. When doing that I get the following when trying to access mysite.local/admin

An Error occurred while handling another error:
yii\web\ServerErrorHttpException: The info table is missing its row in D:\Git\festningen\vendor\craftcms\cms\src\base\ApplicationTrait.php:494

Is it a permission error? I can access files and folders in the web directory, and htaccess file looks normal:

<IfModule mod_rewrite.c>
    RewriteEngine On

    # Send would-be 404 requests to Craft
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !^/(favicon\.ico|apple-touch-icon.*\.png)$ [NC]
    RewriteRule (.+) index.php?p=$1 [QSA,L]
</IfModule>

I've also tried setting permissions on the folders, giving the users group full permissions. With no luck.

Any idea?

2

I have had a similar issue when using MAMP on OSX. The "solution" was to switch MAMP to use Module mode (all hosts use the same PHP version) rather than FastCGI mode (where you can run different PHP versions per host).

I have no clue why, but switching it allows the installation to complete. I am then able to switch it back to Fast CGI mode and everything works (although the issue sometimes occurs when installing/updating plugins).

  • Hmm, I have no idea how to do that in AMPPS. I see there's an option for mod_cgi, but switching that to off didn't really do much – Kenny Bones Apr 17 '18 at 15:09
  • It was the max_execution_time being set too low.. Man I should have known – Kenny Bones Apr 17 '18 at 16:14
1

I managed to get it to work. Seems like it was the max_execution_time being set to 30 that was way too low...

1

My issue was the database settings. I needed to change my db to: Default Collation: utf8_unicode_ci.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.