1

This happens on every install (see below suggestions) via Composer on a MAMP Pro stack, running PHP 7.1, Mysql 5.7 & Composer 1.7.2.

Albeit suggestions, could this affect the performance or plugin compatibility of a base install?

server:lab user$ composer create-project craftcms/craft .
Installing craftcms/craft (1.0.36)
  - Installing craftcms/craft (1.0.36): Loading from cache
Created project in .
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 50 installs, 0 updates, 0 removals
  - Installing craftcms/plugin-installer (1.5.2): Loading from cache
  - Installing yiisoft/yii2-composer (2.0.7): Loading from cache
  - Installing symfony/polyfill-ctype (v1.9.0): Loading from cache
  - Installing symfony/polyfill-mbstring (v1.9.0): Loading from cache
  - Installing twig/twig (v2.5.0): Loading from cache
  - Installing enshrined/svg-sanitize (0.9.0): Loading from cache
  - Installing danielstjules/stringy (3.1.0): Loading from cache
  - Installing zendframework/zend-stdlib (3.2.1): Loading from cache
  - Installing zendframework/zend-escaper (2.6.0): Loading from cache
  - Installing doctrine/lexer (v1.0.1): Loading from cache
  - Installing egulias/email-validator (2.1.6): Loading from cache
  - Installing swiftmailer/swiftmailer (v6.1.3): Loading from cache
  - Installing yiisoft/yii2-swiftmailer (2.1.2): Loading from cache
  - Installing symfony/process (v3.3.6): Loading from cache
  - Installing yiisoft/yii2 (2.0.15.1): Loading from cache
  - Installing yiisoft/yii2-debug (2.0.14): Loading from cache
  - Installing yiisoft/yii2-bootstrap (2.0.8): Loading from cache
  - Installing zendframework/zend-feed (2.10.3): Loading from cache
  - Installing craftcms/cms (3.0.25): Loading from cache
  - Installing yiisoft/yii2-queue (2.1.0): Loading from cache
  - Installing true/punycode (v2.1.1): Loading from cache
  - Installing seld/cli-prompt (1.0.3): Loading from cache
  - Installing pixelandtonic/imagine (v0.7.1.3): Loading from cache
  - Installing mikehaertl/php-shellcommand (1.4.1): Loading from cache
  - Installing paragonie/random_compat (v2.0.17): Loading from cache
  - Installing guzzlehttp/promises (v1.3.1): Loading from cache
  - Installing psr/http-message (1.0.1): Loading from cache
  - Installing guzzlehttp/psr7 (1.4.2): Loading from cache
  - Installing guzzlehttp/guzzle (6.3.3): Loading from cache
  - Installing league/oauth2-client (2.3.0): Loading from cache
  - Installing league/flysystem (1.0.47): Loading from cache
  - Installing elvanto/litemoji (1.4.4): Loading from cache
  - Installing creocoder/yii2-nested-sets (0.9.0): Loading from cache
  - Installing craftcms/server-check (1.1.6): Loading from cache
  - Installing craftcms/oauth2-craftid (1.0.0.1): Loading from cache
  - Installing symfony/finder (v3.3.6): Loading from cache
  - Installing symfony/filesystem (v3.3.6): Loading from cache
  - Installing psr/log (1.0.2): Loading from cache
  - Installing symfony/debug (v3.3.6): Loading from cache
  - Installing symfony/console (v3.3.6): Loading from cache
  - Installing seld/phar-utils (1.0.1): Loading from cache
  - Installing seld/jsonlint (1.7.1): Loading from cache
  - Installing justinrainbow/json-schema (5.2.7): Loading from cache
  - Installing composer/spdx-licenses (1.4.0): Loading from cache
  - Installing composer/semver (1.4.2): Loading from cache
  - Installing composer/ca-bundle (1.1.2): Loading from cache
  - Installing composer/composer (1.6.3): Loading from cache
  - Installing cebe/markdown (1.1.2): Loading from cache
  - Installing ezyang/htmlpurifier (v4.10.0): Loading from cache
  - Installing vlucas/phpdotenv (v2.5.1): Loading from cache
zendframework/zend-feed suggests installing zendframework/zend-cache (Zend\Cache component, for optionally caching feeds between requests)
zendframework/zend-feed suggests installing zendframework/zend-db (Zend\Db component, for use with PubSubHubbub)
zendframework/zend-feed suggests installing zendframework/zend-http (Zend\Http for PubSubHubbub, and optionally for use with Zend\Feed\Reader)
zendframework/zend-feed suggests installing zendframework/zend-servicemanager (Zend\ServiceManager component, for easily extending ExtensionManager implementations)
zendframework/zend-feed suggests installing zendframework/zend-validator (Zend\Validator component, for validating email addresses used in Atom feeds and entries when using the Writer subcomponent)
craftcms/cms suggests installing ext-imagick (Adds support for more image processing formats and options.)
yiisoft/yii2-queue suggests installing yiisoft/yii2-redis (Need for Redis queue.)
yiisoft/yii2-queue suggests installing pda/pheanstalk (Need for Beanstalk queue.)
yiisoft/yii2-queue suggests installing php-amqplib/php-amqplib (Need for AMQP queue.)
yiisoft/yii2-queue suggests installing enqueue/amqp-lib (Need for AMQP interop queue.)
yiisoft/yii2-queue suggests installing ext-gearman (Need for Gearman queue.)
yiisoft/yii2-queue suggests installing aws/aws-sdk-php (Need for aws SQS.)
pixelandtonic/imagine suggests installing ext-imagick (to use the Imagick implementation)
pixelandtonic/imagine suggests installing ext-gmagick (to use the Gmagick implementation)
paragonie/random_compat suggests installing ext-libsodium (Provides a modern crypto API that can be used to generate random bytes.)
league/flysystem suggests installing league/flysystem-aws-s3-v2 (Allows you to use S3 storage with AWS SDK v2)
league/flysystem suggests installing league/flysystem-aws-s3-v3 (Allows you to use S3 storage with AWS SDK v3)
league/flysystem suggests installing league/flysystem-azure (Allows you to use Windows Azure Blob storage)
league/flysystem suggests installing league/flysystem-cached-adapter (Flysystem adapter decorator for metadata caching)
league/flysystem suggests installing league/flysystem-eventable-filesystem (Allows you to use EventableFilesystem)
league/flysystem suggests installing league/flysystem-rackspace (Allows you to use Rackspace Cloud Files)
league/flysystem suggests installing league/flysystem-sftp (Allows you to use SFTP server storage via phpseclib)
league/flysystem suggests installing league/flysystem-webdav (Allows you to use WebDAV storage)
league/flysystem suggests installing league/flysystem-ziparchive (Allows you to use ZipArchive adapter)
league/flysystem suggests installing spatie/flysystem-dropbox (Allows you to use Dropbox storage)
league/flysystem suggests installing srmklive/flysystem-dropbox-v2 (Allows you to use Dropbox storage for PHP 5 applications)
symfony/console suggests installing symfony/event-dispatcher ()
Writing lock file
Generating optimized autoload files
> @php -r "copy('.env.example', '.env');"
> @php -r "unlink('composer.json');"
> @php -r "unlink('LICENSE.md');"
> @php -r "unlink('README.md');"
> @php -r "rename('composer.json.default', 'composer.json');"
Generating optimized autoload files
> @php craft setup/welcome

   ______ .______          ___       _______ .___________.
  /      ||   _  \        /   \     |   ____||           |
 |  ,----'|  |_)  |      /  ^  \    |  |__   `---|  |----`
 |  |     |      /      /  /_\  \   |   __|      |  |
 |  `----.|  |\  \----./  _____  \  |  |         |  |
  \______|| _| `._____/__/     \__\ |__|         |__|

     A       N   E   W       I   N   S   T   A   L   L
               ______ .___  ___.      _______.
              /      ||   \/   |     /       |
             |  ,----'|  \  /  |    |   (----`
             |  |     |  |\/|  |     \   \
             |  `----.|  |  |  | .----)   |
              \______||__|  |__| |_______/



Generating a security key ... done (iD6CQCDo8OEpF36qGnPPcylYpCI9gGz6)

Welcome to Craft CMS! Run the following command if you want to setup Craft from your terminal:

    ~/Studio/clients/lab/craft setup
0

I'm guessing you mean the suggests installing part? If so, these are just optional packages that add optional features. I wouldn't sweat it, especially in local dev.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.