Questions tagged [docker]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2
votes
3answers
125 views

SSL certificate for Docker container in Nitro 2 has expired: what to do?

I created a Docker container 3 months ago. I’ve only just come back to it and find its SSL certificate has expired. I can find nothing on what is best to do. Is it best to reissue the certificate? If ...
0
votes
0answers
36 views

How do I add custom certificates to a docker nitro container?

My organization uses ZScaler as a proxy for our traffic. As a result, the command line in nitro is pretty worthless until I can get the cert into that container. Until then wget, curl, etc do not work....
1
vote
1answer
61 views

Trouble running craft with docker

I'm trying to set up craft to run with the docker images provided here. When I run docker-compose build, it gets through a few lines in the Dockerfile and then stops with an invalid reference error ...
2
votes
0answers
157 views

Craft in Docker throws '/app/web/cpresources doesn’t exist or isn’t writable by PHP'

I'm trying to deploy a Dockerized Craft CMS website. The basic setup is as follows: craft running in Docker nginx running on the server, using proxy_pass to point to docker container The setup ...
0
votes
0answers
164 views

Workflow for running Craft CMS with Docker in production?

I've been looking into running Craft CMS with Docker in production. One of the most helpful and comprehensive resources I've found so far is Matt Gray's blog series. While it goes into great depth, I'...
1
vote
2answers
548 views

Upgrading Craft CMS fails

I'm trying to upgrade from 3.3.15 -> 3.5.5 from control panel. I run it via docker so all I need is to update the composer.lock file to have the correct dependencies and everything should be fine ...
1
vote
1answer
123 views

Assets (in assets folder) failing to load locally [Craft 2]

I'm trying to get my Craft 2 site running locally again (it worked at one point but now does not). I have gotten all the db related issues (seemingly) done and dusted and the admin loads fine, but it ...
1
vote
1answer
295 views

ERROR: relation “info” does not exist

Be warned this is sort of Docker related question too. I try to build local development environment using Docker (nginx 1.16.1 + postgresql 12.1.0) running Craft 3.4.1. I've came up to a point where ...