Questions tagged [docker]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1
vote
1answer
31 views

Nitro / Docker: containers missing

Posting this as a problem and then answering it in case it helps someone else. The sequence of events: I had 3 sites running under Craft Nitro 2 and Docker 3.x I became aware that Docker had moved to ...
0
votes
0answers
31 views

Craft CMS starts throwing HTTP status 500 after a few hours of uptime

I'm working on a "hello world" Craft CMS deployment to AWS ECS. To build my Craft CMS Docker images I use the official base image craftcms/nginx:8.0. The first few hours after the deployment,...
2
votes
3answers
195 views

SSL certificate for Docker container in Nitro 2 has expired: what to do?

I created a Docker container 3 months ago. I’ve only just come back to it and find its SSL certificate has expired. I can find nothing on what is best to do. Is it best to reissue the certificate? If ...
0
votes
0answers
67 views

How do I add custom certificates to a docker nitro container?

My organization uses ZScaler as a proxy for our traffic. As a result, the command line in nitro is pretty worthless until I can get the cert into that container. Until then wget, curl, etc do not work....
1
vote
1answer
86 views

Trouble running craft with docker

I'm trying to set up craft to run with the docker images provided here. When I run docker-compose build, it gets through a few lines in the Dockerfile and then stops with an invalid reference error ...
2
votes
0answers
217 views

Craft in Docker throws '/app/web/cpresources doesn’t exist or isn’t writable by PHP'

I'm trying to deploy a Dockerized Craft CMS website. The basic setup is as follows: craft running in Docker nginx running on the server, using proxy_pass to point to docker container The setup ...
1
vote
2answers
663 views

Upgrading Craft CMS fails

I'm trying to upgrade from 3.3.15 -> 3.5.5 from control panel. I run it via docker so all I need is to update the composer.lock file to have the correct dependencies and everything should be fine ...
1
vote
1answer
163 views

Assets (in assets folder) failing to load locally [Craft 2]

I'm trying to get my Craft 2 site running locally again (it worked at one point but now does not). I have gotten all the db related issues (seemingly) done and dusted and the admin loads fine, but it ...
1
vote
1answer
341 views

ERROR: relation "info" does not exist

Be warned this is sort of Docker related question too. I try to build local development environment using Docker (nginx 1.16.1 + postgresql 12.1.0) running Craft 3.4.1. I've came up to a point where ...