3

I'm having difficulties following the install instructions found at https://docs.craftcms.com/v3/installation.html. I've ssh'd into my server, and I'm running composer to install Craft, as directed in step 1.

Because I've run Composer, the instructions say I can probably safely skip steps 2 and 3. Awesome.

Step 4: Create a database... now wait, when installing Craft via Composer, it gave me the option of running setup from the terminal - which I did. And during this, it asked for database driver, server or IP name, database name, etc. All stuff I needed to know way before I got to step 4.

Step 5. Setup a webserver. Guessing these instructions are specific for local installs? Perhaps this should be made clearer?

Step 6. Run the Setup Wizard. Again... didn't I do this in step one?

After running setup from Step 1, it finished with this:

> save the first user ... done
> save the email settings ... done
*** installed Craft successfully (time: 3.718s)

Looks to me as if everything is as should be. According to the instructions, I should be able to access my new Craft site from my web browser.

Screen Shot showing a listing of files and directories

Not so much.

I've been having a lot of issues getting Craft 3 to run (if you look at my post history, I've asked like 3 or 4 questions over the last few days related to installation). I don't think I'm that stupid (but I've been proven wrong before!), so I'm not sure why this has been so challenging to me.

Can anyone possibly explain where I'm going wrong?

3

If that's what you see when you go to the URL, then you probably don't have the server root set properly. It should point to the web/ directory, not the project root.

Some more helpful Craft setup info can be found here: Setting up a New Craft CMS 3 Project

Typically you do the install in local dev, and then have some kind of a deployment process to deploy it to your staging/production servers.

| improve this answer | |
  • As a side note, I opted to use FTP, as I'm not in position to pay for a deployment service. Nor, do I think I successfully learn one in my current frame of mine /s I'm hoping someone learns from my stupidity here... because my FTP client doesn't show hidden files, (e.g., .env), it didn't upload it. Once that file got uploaded, 90% of the site worked. Once I got the .htaccess file uploaded as well (even though Andrew says NOT TO USE .HTACCESS), everything else worked as well. – Shad Jul 24 '18 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.