0

I took the manual install route, unzipped the latest Craft version, and edited the .env file with my database settings, but when I direct my browser to /craft/web/index.php I get a plain page with

Craft requires PHP 7.0 or later.

I have Bluehost Shared Site and have tried setting my PHP version to 7, but that justs adds a PHP 7 handler to my .htaccess file. When I check the PHP version through the console it still says 5.6.

I have tried the composer route, and added --ignore-platform-reqs, but when I get to the ./craft setup step I get the exact same message.

I'm just not sure what to do from here.

Thanks

2

I'm afraid Craft 3 requires PHP 7. https://docs.craftcms.com/v3/requirements.html

Craft 2 will work with older PHP versions (5.3 to 7.1.x) so you could fall back to using that. https://docs.craftcms.com/v2/requirements.html

Other than that, I'd say you would need a different host in order to run Craft 3.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.