The Stack Overflow podcast is back! Listen to an interview with our new CEO.

Questions tagged [installation]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1
vote
1answer
25 views

Craft 3 install problem on windows 10

Anyone come across this problem with installing craft3 on windows with MAMP Pro. I have installed composer and this seems to be working fine. The php path I added directs composer to C:/MAMP/bin/php/...
1
vote
1answer
27 views

New Install, Permission Errors With /storage

I've configured Apache vHosts on a local box and installed a Craft 3 website onto it. This new instance will serve as my "staging" environment for an upcoming website. I've installed with composer ...
1
vote
1answer
23 views

Is it possible to run Craft CMS with putenv() function disabled?

I’m using shared hosting which supports several CMS like Wordpress, Jumla, etc. In phpinfo there is putenv in disable_functions. Craft CMS needs this function to load variables from .env file. I can ...
0
votes
0answers
54 views

Docker + Webpack for a Craft installation

I've tried to make an installation of Docker + [NyStudio's webpack][2]. I haven't been able to get it working. Neither webpack nor Docker is my specialties. I've uploaded this repo https://github.com/...
1
vote
1answer
82 views

Craft CMS 3 Installed but not working

I have a remote repository with a Craft install and am trying to pull it to a new environment. I run the composer install and Craft & other packages install seemingly correctly, added the .env ...
0
votes
0answers
89 views

Installing Craft CMS 3 on hosting - Unsupported DB driver value

i am trying to instal Craft CMS 3 on hosting and everytime it is going to fall on: 2019-07-05 16:33:55 [-][-][-][error][craft\base\ApplicationTrait::getIsDbConnectionValid] There was a problem ...
1
vote
2answers
253 views

Craft “Unsupported DB driver” error after resetting Windows

I'm using WinNMP for my local dev environment. I installed and configured everything successfully last week, and everything was running well. Unfortunately, I needed to reset my windows installation ...
2
votes
2answers
64 views

my vendor/craftcms/cms folder delete automatically after every update or install

I was on version 3.1.22. As usual, I wanted to install the update on Craft CMS 3.1.23. So I clicked Install and got this error: Status: Error But that was not all ... My complete vendor/craftcms/...
1
vote
1answer
39 views

Errors after Upgrading from 3.0.35 > 3.041

I ran the updater from the Admin (local install.) After a few minutes, the update failed. Now when I try to load the site: Warning: require(C:\Users\rickn\Documents\Craft\Projects\Untye/vendor/...
1
vote
1answer
118 views

Install Failed - Numerous Errors when running with pgsql

Getting Numerous errors when trying to test a staging environment with Craft 3.1. States Install Failed - Check Logs which I have and I'm seeing the following logs being given. I don't understand what'...
0
votes
1answer
237 views

Error when Attempting to Install Plugins

I keep getting this error whenever I try to install a plugin. Not sure how to troubleshoot / resolve this. Basically, I need the Contact Form and CKEditor plugins. Setup: I'm running AMPPS with PHP ...
1
vote
2answers
108 views

Unable to access site after importing DB

I am installing a repo locally, and everything runs smoothly and I am able to see the site and login to my admin. But when I import my DB then visit my site: I get the error message "Site unavailable"....
1
vote
1answer
185 views

This page isn’t working // I think it's my .env?

Been struggling for hours to solve this with no solution and I'm under a deadline for a client. Any help would be so amazing. Here's what happened: I set up the initial craft project with craft ...
1
vote
2answers
58 views

Craft install failed with error php7 not found, but server has php 7 installed

I'm trying to install a backup from production site which is running craft 3.0.26 to a UAT site. While installing, faced an error regarding PHP versions. Since both the sites are in the same server, ...
0
votes
0answers
31 views

Is there a callback for post Craft 3 CMS installation I can use?

I was hoping to have my module create a few fields, sections, and entries after the Craft 3 CMS has completed it's installation. Is there a callback I can listen to that triggers after the CMS is ...
1
vote
2answers
523 views

yii\web\ServerErrorHttpException Craft 3 install

I'm new with Craft CMS and receive this error when I try to install it -------------------ERROR----------------------------- An Error occurred while handling another error: yii\web\...
1
vote
1answer
152 views

Install Craft on VPS with centos 7 and vestacp

I downloading craft with Composer, but when i move on example.com/index.php?p=admin nothing happens. In the logs: PHP Warning: require_once(): open_basedir restriction in effect. File(/home/User/web/...
3
votes
3answers
2k views

HTTP 503 – Service Unavailable – craft\web\ServiceUnavailableHttpException [installation]

I tried installing Craft 3.0 using composer (php composer.phar create-project craftcms/craft PATH) And when I try to access the /web folder it's giving me the following error. I have tried removing ...
1
vote
1answer
52 views

HappyLager Demo Site Forcing 'https://' on XAMPP

When I try to load the demo site in my browser I get the following error: https://imgur.com/8jVvweN "Your connection is not secure" I have added the following to my hosts file: 127.0.0.7 ...
1
vote
1answer
122 views

Can't see any craft/app folder

It looks like the craft/app folder is no longer in the Craft download. I've been using v.3.0.9 from the site and through composer. Or am I missing something here? This is causing a bit of trouble ...
1
vote
1answer
371 views

Problem connecting to MySQL db on installing Craft 3

Having installed Craft 3 using Composer, I'm attempting to run the Craft setup. Everytime I try, I get the following error: Testing database credentials... failed: SQLSTATE[HY000] [1044] Access ...
3
votes
1answer
341 views

Automated Craft 3 installation

I am setting up a vagrant development environment and I was wondering if it is possible to somehow pass the installation configuration when running ./craft setup command to avoid any user interaction? ...
0
votes
3answers
241 views

Craft 3 not running on Ubuntu 18.04

I’ve set up a new Ubuntu 18.04 server, but can not get Craft 3 to run on it - despite it passing the Server test script with flying colours. I know the server setup is OK as PHPmyAdmin is running on ...
2
votes
2answers
383 views

Craft 3 upload path on webserver

My hoster has i public html folder where all websites are lying. Different Websites are separeted by subfolders. Should i upload all Craft3 installation files to this public html folder and point the ...
0
votes
1answer
506 views

Craft 3 installation issue on account creation

I try to install Craft 3 but I encounter an issue at the very beginning. I uploaded the CMS via FTP and completed manually the .env file. When I try to run the installation, I get stuck at the account ...
1
vote
1answer
276 views

How to set base URL on the installation of Craft CMS on server

I am a beginner. I just install it on a server and also on localhost. But facing the same problem. I set it http://www.example.com/ but I go to this URL it shows me the directory but when I go to http:...
1
vote
1answer
1k views

Successfully installed Craft 3 via Composer but can't access site or admin

I've been Googling around all day looking for answers to this, but I'm actually stuck. Ok, so basically I installed Craft 3 via Composer into a subdomain on my development server (apache). Everything ...
4
votes
1answer
2k views

Set up Craft 3 when the craft folder is above public_html on shared hosting

I'm trying to setup Craft 3 on a shared host. It succeeds when I place all files in the public directory and then go to /web. But if I move the craft files to the folder /private_html/craft and the ...
1
vote
1answer
580 views

Plugin Installation Error in Craft 3 / PHP Version

I tried to install "Field Manager" Plugin and get following error: symfony/console v3.4.4 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.2.1) overridden by "config.platform.php" version (7....
1
vote
0answers
63 views

Trying to restore a Craft instance for a customer who was abandoned

I am new to Craft and a client asked us to take over a site as the previous service provider abandoned them. For now just trying to get up and running on a Windows server in a test environment before ...
1
vote
1answer
84 views

Undefined property: Craft\WebApp::$urlManager in /var/www/craft/app/controllers/BaseController.php on line 37

So I'm trying to setup my first Craft installation on Digital Ocean. I'm bound to use Craft version 2.0.2535 since I'll be duplicating a site using this (so I cannot use Craft 3). I've spun up a new ...
1
vote
1answer
1k views

Development – deployment environment

I am new to Craft 3 and never set up a local environment with composer, bitbucket and gulp. So I dived into all these things to get my hands on Craft 3. At the moment I am using a shared hosting ...
2
votes
2answers
926 views

Error when updating 2 to 3: Bad Request Unable to verify your data submission

Followed all steps on Upgrading from Craft 2 I have my .env, db.php, general.php and index.php in place... can't find any reference of this issue. This happens after "To complete the update, some ...
5
votes
4answers
3k views

Craft 3 Command setup failing

I've installed Craft 3 through composer and I'm attempting to work through the setup process within terminal: MacBook-Pro:~ jamie$ ~/Documents/repos/__craft-3-beta/craft setup Which database driver ...
1
vote
2answers
1k views

Craft 3 via composer with Mamp Pro

Is it possible to get an idiots guide to this: Error on Craft 3 install I'm just not following the context of the answer/commands, a detailed step by step would be invaluable for fear of trying ...
7
votes
2answers
2k views

Craft CLI RC1 Connectivity Issues with MAMP Pro

I've been trying to run the new Craft CLI for the last couple of versions without any success. I figured maybe since we weren't at RC1 yet that it wasn't fully working. After seeing Ryan's video about ...
1
vote
1answer
78 views

Tried to duplicate site in local environment but loading blank

I'm trying to duplicate an existing Craft CMS site by moving it from an online server to a local installation using MAMP. I have copied the /craft folder and all files in the root of /public_html (...
1
vote
2answers
223 views

Trying to launch Craft CMS site on 1&1.co.uk and told I don't have permission. Any help why?

Does anyone know how to launch a Craft CMS site on 1&1.co.uk web hosting. I've uploaded my database, changed the siteUrl and uploaded the site with FTP but it's not working. I receive an error ...
2
votes
2answers
1k views

Error on Craft 3 install

When attempting to install Craft 3 in OSX El Cap, I'm getting the following errors: Script @php craft setup/welcome handling the post-create-project-cmd event returned with error code 255 /Craft3/...
2
votes
1answer
155 views

Craft CMS on Host Inmotion

Had absolutely no issue with an older version of their host on the installation and running a Craft CMS site. This one has been a bear Is there a step by step on best way to install The only real ...
0
votes
3answers
1k views

Site is “Temporarily Unavailable”

I get "Service Unavailable" when I go to my (hosted, not local) test site. It had been working just fine until I decided to swap databases today. I deleted the old database and replaced it with the ...
1
vote
2answers
497 views

{% block content %} is a no-go in template/subfolders

I’m on a mac running MAMP and my install is functional. Localhost will direct to and display files in “templates” but it wont fully cooperate with subfolders within templates, such as templates/news. ...
1
vote
1answer
909 views

PHP version issue when installing Craft 3 using Composer

Why do I get the error when I try to install Craft 3? composer create-project craftcms/craft Documents/Development/Project -s beta The error: [InvalidArgumentException] ...
2
votes
1answer
2k views

Internal Server error during install

I've done a few installs of Craft and never had a problem. I'm currently trying to do an install on a new server under a subdmomain and getting the following results… This results in 404 http://...
3
votes
1answer
411 views

Having issues with Craft install on Laravel Valet.

I'm having some trouble getting Craft to install with Laravel Valet. All I'm getting on the .dev, .dev/admin, .dev/index.php/admin? is the 'service unavailable'. Not sure if it's just new to Craft or ...
2
votes
1answer
123 views

Sub-pages not loading on Windows server

I just moved a site over to a Windows server, and my homepage loads fine, but sub pages are not loading. I just get an error message that the connection was reset. Adding index.php to the url doesn't ...
0
votes
1answer
206 views

Help with admin panel errors. Fresh install. Mysql version issue? [duplicate]

I get this on the admin panel: CDbException CDbCommand failed to execute the SQL statement: SQLSTATE[42000]: Syntax error or access violation: 1055 Expression #18 of SELECT list is not in GROUP BY ...
2
votes
0answers
87 views

Another 'Could not find your craft/ folder' on fresh install

Even though I repeatedly downloaded the current Craft release, created a new host with a new root folder and a new database, installing Craft runs into the error Could not find your craft/ folder etc ....
3
votes
1answer
324 views

Got an “Oops” Screen While in Installer, Exited to Try Again, and Now I Can't Get Back to Installer

Background info: trying to install Craft CMS on a Vm running on Xubuntu So, I was finally able to see the glorious monkey screen to signify that I'd made it to the installer successfully, when ...
0
votes
2answers
398 views

Can I use an IP address instead of a FQDN?

Thank you to anyone that can provide real assistance to my problem with Craft and installing it on a local server. Your help and assistance are truly appreciated!! :-) I need 100% confirmation that ...