Questions tagged [error-templates]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
39 views

Creating a new SINGLES page presents a PAGE CAN'T BE FOUND or TEMPLATE CAN'T BE FOUND

I'm hoping you can help resolve my issue or point me in the right direction. Sincere apologies if this question has been asked a million times, however I can't seem to find anything specific to this ...
OGW's user avatar
  • 13
2 votes
0 answers
83 views

Template randomly not found using DDEV

I am using DDEV and the following files tree structure: Where "_index.twig" is the single section type and where "_item.twig" is the channel section type. For all of them I want ...
mencantalamelva's user avatar
0 votes
0 answers
51 views

Cloudflare doesnt load my 404 error

I have a site whose dns runs thru cloudflare. My staging site shows our 404 error template fine but Cloudflare doesnt seem to process ti and just shows Crafts system template not found. Anyone come ...
joomkit's user avatar
  • 2,004
1 vote
1 answer
102 views

vhost.conf and general understanding

I am new to craft CMS and installed it in an Amazon EC2 instance via Composer. This worked. My vhost.conf looks like this <VirtualHost *:80> ServerName craft.example.com DocumentRoot /var/www/...
TristanVII's user avatar
2 votes
1 answer
700 views

Template not found: $PRIMARY_SITE_URL/$PRIMARY_SITE_URL/blog/this-is-my-blog

Very new to craft CMS, recently just installed XAMPP with php 7 and craft 3 and followed the getting started tutorial from Craft CMS. Then when I try to preview or open the page created from the ...
Steven Zhang's user avatar
0 votes
0 answers
89 views

Email template error

In the logs, I have this error: 2021-02-01 18:00:04 [-][-][-][error][craft\commerce\services\Emails::sendEmail] Email template parse error for email “Order Submitted”. Order: “123456”. Template error:...
hackerman's user avatar
0 votes
0 answers
32 views

How can I best troubleshoot a 404 error loading a template from a previous iteration of my site?

I had a Craft Site, which I'll refer to here as the old site. I replaced it with a new site on the same server. To do this I overwrote the old site's database and files. I kept the old site's public ...
Dannie's user avatar
  • 31
2 votes
1 answer
147 views

Error on functions in queue: "Session does not exist in a console request."

I get the following error on multiple order mails from Craft Commerce. The error points out to the lines where a macro is called: Email template parse error for email “New order”. Order: “e35f244”. ...
chlsydkysr's user avatar
1 vote
1 answer
255 views

Craft admin twig templates broken somehow

I am a front end designer building my site locally. This is the first time I've built in Craft and things have been coming along fine but now I'm getting the following error on every craft admin page ...
Jana's user avatar
  • 21
1 vote
1 answer
397 views

Can access admin page (now), but not any site pages...yii not found http execption

Have not accessed my local .test sites in a bit. I tried today. I am getting a series of errors. At first I could not access any page to include the admin page. I ran Composer update from the ...
Hellyar's user avatar
  • 911
1 vote
2 answers
445 views

Blog template not displaying posts

The blog post should display the posts created but when I got to the slug /blog it says 404 not found as well as the press news should be displayed here /press-news but same thing happens. If i ...
Alejo_Blue's user avatar
1 vote
1 answer
8k views

How can I test my 500 error page works

I had a problem with my cloud server and all my sites were generating 500 errors. The response page the visitor saw varied between Craft 2, Craft 3 and ExpressionEngine 2 sites. The Craft 3 ones ...
Paul Frost's user avatar
  • 1,048
2 votes
1 answer
943 views

Custom 503 template

I am preparing to upgrade a site from Craft 2 to 3, and would like to make a custom template to deal with the 503 Service Unavailable when the migrations need to be run. I have set devMode to false ...
Mike F's user avatar
  • 185
1 vote
4 answers
9k views

Template not found 404

Having a strange issue - devMode is set to false, if I go to /404, I get the custom 404 page, which is great. If I go to /something1234567890 (which is definitely not an entry's URL) I get the ...
Mike F's user avatar
  • 185
1 vote
2 answers
43 views

Wrong urls printed for small subset using getNext and getPrev

I have a related question regarding previous and next throwing a template error for some entries. This is similar, but different. A few entries in the same section depict the wrong previous and next ...
Hellyar's user avatar
  • 911
2 votes
1 answer
852 views

Suppress HttpException.404 for bad URLs

Requests for non-existent templates/pages (404s) result in an uncaught HttpException.404 being thrown, though the correct 404 template is displayed. Is there some way to suppress or handle this ...
Garrett's user avatar
  • 417
1 vote
1 answer
561 views

Why is Craft rendering a blank page instead of an error template?

I'm currently seeing this in the PHP error logs: Fatal error: Uncaught exception 'Craft\\HttpException' with message '' in /home/vagrant/htdocs/site/craft/app/controllers/TemplatesController.php:59\...
Gaz's user avatar
  • 201
4 votes
1 answer
637 views

How do you create dynamic error pages?

I want to have one template handle all of my error pages (instead of creating 404.html, 500.html, &c.).
Bryan Redeagle's user avatar
5 votes
1 answer
1k views

Generic catch-all error template

Is there a catch all error page template? I'd like to use http://http.cat for my statuses. (originally asked by Bryan Redeagle in Craft Slack)
Michael Rog's user avatar
  • 3,400
1 vote
1 answer
168 views

Setting tab 'error' class for tab with error

When creating an editor interface within my plugin, I am using the following snippet to create a set of tabs inside a tab pane: {% include "_includes/tabs" with { tabA: { label: 'Tab A'|t, url: '#...
Tim Everts's user avatar
0 votes
0 answers
116 views

How to use getTemplateName() from within a plugin?

I wondered if we could embellish from this answer? I'm developing a plugin where at some point it needs to detect if the user is currently on one of the error pages (400, 403, 404, 500, or 503). I'...
Mark Notton's user avatar
  • 2,315
2 votes
1 answer
374 views

ElementAPI -> Find entry template name

I'm using many "entry type" templates as described here: http://buildwithcraft.com/help/entry-type-templates. I'm using ElementAPI to render full entries as HTML embedded into JSON. I'm using this ...
Ammon Haggerty's user avatar
1 vote
1 answer
905 views

Why would Craft produce a template loader error (TemplateLoaderException) when rendering its default error pages?

I'm getting a Template Loader Exception when I hit a 404 on my site: Craft\TemplateLoaderException Unable to find the template “error”. (/craft/app/etc/templating/twigextensions/TemplateLoader.php:...
Michael Rog's user avatar
  • 3,400
0 votes
2 answers
2k views

Getting image url error code: Impossible to access an attribute ("url") on a null variable

My site just suddenly broke down on a certain page with the following error code, (see screenshot). It is occuring for every image on this page and really confusing me. Any quick suggestions?
Matteo's user avatar
  • 151
0 votes
1 answer
250 views

Error while trying to use dynamic routing to pass variables to the template and using them

So i'm trying to pass the variables from a dynamic route to a template and then to use those variables to filter trough entries. the catch is that the same template is used to display an "organic"(by ...
Samuel E.'s user avatar
  • 239
2 votes
2 answers
308 views

Redirect 'expired' or deleted entries

I have a job board running on Craft. We're "auto expiring" the posts from listing pages based on the post date. However, I want to redirect the actual entry page to either a 'this job has expired' ...
Steven Grant's user avatar
  • 1,855
1 vote
1 answer
170 views

How to split the user login error message between username and password?

Hoping this is possible. I want to split the username and password error message to return it separately depending whether it is username or password that is incorrect and not just a the generic (...
Lettie's user avatar
  • 2,033
1 vote
1 answer
3k views

Problem loading css files in some templates

I´m having problems loading css files in some templates. Hi have this to load css files: {% includeCssFile "assets/html/css/reset.css" %} {% includeCssFile "assets/html/css/general.css" %} {% ...
Sebachenko's user avatar
0 votes
1 answer
651 views

Include results in "Object of class Craft\ElementCriteriaModel could not be converted to string"

I have a template with just this code: {% include 'amenities/_types/amenities' %} This results in a template error: Object of class Craft\ElementCriteriaModel could not be converted to string ...
Jonathan Melville's user avatar
3 votes
1 answer
2k views

Returning errors into templates

When working with a custom form that posts to a plugin function - what's the best way to return errors that would be displayed like the forgot password code example below {% if errors is defined %...
Adam McCombs's user avatar
  • 1,695
1 vote
1 answer
1k views

404.html template causing twig_error_syntax

I created a generic 404.html template to replace the default Craft page. I'm getting the following error when forcing a 404 in browser. Any idea what the issue is? Twig_Error_Syntax The filter "...
frshjb373's user avatar
  • 287
5 votes
1 answer
2k views

How to return errors from a model back to the template?

I'm working on validation with Craft. I have a custom plugin that allows public submission. However, I want to make sure I can pass errors back to the template. The key is trying to make my code as "...
Jason McCallister's user avatar
4 votes
1 answer
806 views

User Registration Form error message customisation

Where can I edit the error messages for the user registration form e.g for {% if account is defined %} {{ _self.errorList(account.getErrors('email')) }} {% endif %} I want to change this ...
Simon Clayson's user avatar
1 vote
1 answer
672 views

Property "Craft\WebApp.assetUpload" is not defined

I came across error Property "Craft\WebApp.assetUpload" is not defined, when registering users from front end. Is this a bug or missing config param? I have used the example on craft website: https://...
Silvanus Matiku's user avatar
7 votes
3 answers
2k views

Render generic message/error template from plugin

Basically, I'm trying to emulate show_error from EE/CI: http://ellislab.com/codeigniter/user-guide/general/errors.html I want to just use the generic Craft error template (/craft/app/templates/error....
Tim Kelty's user avatar
  • 3,071
11 votes
3 answers
5k views

What's the best way to set up a content-manageable 404 page?

I'd like to make my 404 page editable through Craft, but when I create a single for it, a URI is required. Is there a way to make a single with no URI, or is the best route to setup globals for ...
Jeremy Gimbel's user avatar