1

I got given a Craft CMS project build with composer and npm. Pointed valet to the correct folder, installed all the dependencies and started the app with npm run watch.

http://localhost:3000 just gives me an "Internal Server Error" though...

Craft CMS Internal Server Error

There is nothing in the logs apart from sth inside storage/logs/web.log which does not sound like a showstopper:

2020-12-07 06:59:06 [-][-][-][error][yii\base\ErrorException:8192] yii\base\ErrorException: Method ReflectionParameter::isArray() is deprecated in /vendor/yiisoft/yii2/web/Controller.php:133 Stack trace:

Error 500 bugs are really hard to track down, any hints would be appreciated!

1

Based on the error message and this: https://php.watch/versions/8.0/deprecated-reflectionparameter-methods, it sounds like you're running PHP 8, which Craft isn't compatible with, yet.

The soon-to-be-released Craft 3.6 adds PHP 8 compatibility, so you'll want to downgrade to PHP 7.4 until that's out.

1
  • thank you so much for the hint with the PHP versions, downgrading to PHP 7.4 was the solution :) – nerdess Dec 8 '20 at 7:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.