1

I ran the updater from the Admin (local install.) After a few minutes, the update failed.

Now when I try to load the site:

Warning: require(C:\Users\rickn\Documents\Craft\Projects\Untye/vendor/craftcms/cms/bootstrap/web.php): failed to open stream: No such file or directory in C:\Users\rickn\Documents\Craft\Projects\Untye\wwwroot\index.php on line 20

Fatal error: require(): Failed opening required 'C:\Users\rickn\Documents\Craft\Projects\Untye/vendor/craftcms/cms/bootstrap/web.php' (include_path='.;C:\php\pear') in C:\Users\rickn\Documents\Craft\Projects\Untye\wwwroot\index.php on line 20

There is no "vendor/craftcms/cms" folder

Is there a way to manually update an existing install? I don't see that option in v3 update instructions.

1
  • you can check the file permissions once and update using composer again. – inrsaurabh Apr 11 '19 at 13:34
1

The easiest way is to make sure you have Composer installed.

Then you can go to your project's root and run composer update to pull in a fresh set of dependencies.

1
  • Thank you! Had to downgrade Twig after running the updates to "2.6.2", but that got me up and going. – Rick May 19 '19 at 1:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.