Questions tagged [404]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2
votes
1answer
20 views

How to route 404 errors for multi-site Craft?

Craft looks for /templates/404 by default. What do you do if you have multiple sites?
0
votes
0answers
13 views

404 shows “Internal Server Error” only on staging environment

Might be a duplicate, but couldn't find this exact question here. I have a pretty basic 404.twig template that should be catching things, as described here: https://docs.craftcms.com/v3/routing.html ...
1
vote
2answers
62 views

Control Panel or admin dashboard not found

I have installed craftcms 3 on my localhost. It got installed and the following screen appeared: If I click on Control Panel I see the following screen
1
vote
1answer
26 views

.htaccess file not rewriting url

Hi I'm having major problems trying to get my .htaccess file to rewriteRule or redirect one url to another. I've used .htaccess before on other cms installs and always work but for the life of me I ...
2
votes
1answer
54 views

Some (but not all) controller action routes return 404 on staging server

I've created a module for a project that has several actions, all of which are called through AJAX. Each is a post request that sends over any required params plus the CSRF token using the method ...
1
vote
1answer
533 views

Craft CMS 3 admin panel returns 404 with SSL

I'm using MAMP Pro for local development and was gong to set up my site with SSL this time around. I got a self-signed cert for local dev and I can go to my development site over https:// without any ...
0
votes
1answer
105 views

RSS throwing 404 error

I used this example to create an RSS feed in Craft, saved it as “feed.rss”, uploaded it into the “craft/templates” directory. When I go to www.my-website.com/rss, I get a 404. What am I missing here?...
1
vote
3answers
2k views

Template not found 404

Having a strange issue - devMode is set to false, if I go to /404, I get the custom 404 page, which is great. If I go to /something1234567890 (which is definitely not an entry's URL) I get the ...
2
votes
1answer
686 views

Craft 3 Controller giving 404

Updating a plugin to Craft 3 (also changed its name). I know this is probably something very simple, like capitalization, but can anyone point out what's wrong? Firefox console shows a 404 for http://...
1
vote
1answer
374 views

Craft 2 -> 3 Update /admin 404

I'm attempting to update a craft 2 site to craft 3. Following these instructions, I used composer to install Craft: https://docs.craftcms.com/v3/upgrade.html#if-you-want-your-directory-structure-to-...
2
votes
1answer
806 views

How to show homepage for 404 errors

Instead of a standard 404 error page, I want to send 404s to the homepage and can't seem to get this working right. If I add {% redirect '/' %} in my 404.html template, that works except it gives a ...
0
votes
1answer
60 views

Craft 2: Locale throwing 404 in frontend

I have my two locales set up as described in the official documentation. I am able to translate my pages and fields in the CP as supposed to and have two versions ready in the backend, both with a ...
1
vote
2answers
120 views

404 error if folder in public_html has same name as folder in craft/templates

I am currently transfering a live website to Craft CMS. I am trying to keep all URLs of pages and images exactly the same as the live version, because of all the pages and images cached in Google. ...
5
votes
2answers
1k views

Craft 3 404 and 503 pages in devMode

Is there any way to get Craft 3 to display 404.html and 503.html for the 404 and 503 pages while in devMode, as it did in Craft 2, rather than returning the entire Yii 2 error stack? Sometimes, we ...
1
vote
1answer
64 views

TemplatesController error related to webfont!

I'm getting a very strange 404 error on my live site: Craft\HttpException: template = fonts/BlissBold-webfont.ttf in /path/to/mydomain/craft/app/controllers/TemplatesController.php:72 I've ...
2
votes
2answers
3k views

Craft not loading custom 404 template for errors

Whenever I hit a non-existent page on a dev site, I only get Craft's native 404 page, not the one I have at /craft/templates/404.html. The site has no routes. Any ideas why this might be?
0
votes
0answers
85 views

If an entry doesn't exist in a locale and returns a 404, how can I check if the entry exists in a different locale?

I'm trying to create a mechanism for informing users that a particular entry is not available in the selected language, and providing a link to read the article in an alternative language. Therefore, ...
1
vote
1answer
90 views

Deleting oldest 404 redirects task stalling

I have a site which has 100's of pending "Deleting oldest 404 redirects" tasks and they keep stalling so the list isn't clearing. The client has added lots of custom rules to the .htaccess which I ...
1
vote
1answer
644 views

Ajax call to action 404

I've a trigger on my frontend that requires an action. I've started from the businessLogic template but I'm getting a 404 and can't find why. My function public function actionExampleAjax() { ...
1
vote
1answer
251 views

See 404 error cause by some weird URI in index.php

I have Craft 2.6.2986 in an AWS EC2 environment. My site looks fine, but in my craft.log, I see a lot of 404 errors. We don't have phpmyadmin2011 or phpmyadmin2012 page. Does anyone know how they get ...
2
votes
1answer
91 views

Security test generated large compiled_templates directory, site outage

We just moved an installation of one of our sites to a new server. Previously, it was on a machine where the versions of Ubuntu / PHP prevented us from upgrading the Craft core version from 2.3.x to 2....
1
vote
1answer
260 views

Empty page instead of 404 error when url contains channel slug

I have a website where my client can create entries in a couple of different channels. Lets take a "news" channel. The url would be: "example.com/news/nameofpage" Whenever a wrong url is entered ...
1
vote
2answers
105 views

Can't get rid of 404 error

I set up my first Craft site on my shared hosting and I can't get it to work for the life of me. Whatever I do, I run into a 404 error. .htaccess is there and named correctly, craft folder is one ...
1
vote
1answer
1k views

Craft 404 for admin dashboard

OK, I have encountered the following issue: Issue: Admin page gets a Craft 404 page error; home page loads fine though. Home page: 192.168.10.95 Admin page: http://192.168.10.95/public/index.php/...
1
vote
3answers
4k views

Can't access admin panel

It's the first time I'm using Wamp for local hosting my Craft website. I've changed my Windows and Wamp apache host file for accessing my domainname instead of localhost. (ronvanderwerf.loc instead of ...
0
votes
1answer
659 views

404 Error showing for Asset Images

In the backend, I could upload an image. I see it loads fine in the backend admin CP. But it goes to a 404 error on the front end. File System Path: /home/devserv1/colorcomputergames.com/assets/...
1
vote
1answer
284 views

404 issues and redirect/.htaccess

When I type mydomain.dev/blahwrongurl - for some reason .htaccess doesn't redirect to the 404.html file, but just write the blahwrong url out on the page and nothing else? I get the feeling that I ...
0
votes
1answer
478 views

404 message after following Craft installation instructions

I'm installing Craft CMS on my domain which was formerly functional (previously used Wordpress). I removed all Wordpress files through FileZilla FTP and uploaded Craft files. I put the /Craft folder ...
2
votes
1answer
946 views

Redirecting “if entry is not defined” returns 404 instead

All the documentation, and answers here say this should work... But it returns the 404 instead of redirecting and I can't figure out why? Section: Structure = help Entry URL Format: Top-Level ...
1
vote
2answers
708 views

Uploaded image not appearing

I'm having an issue where a user is uploading images but they're not showing up correctly. The photo is listed in /admin/assets and shows the correct file size, kind, dimensions, etc but I'm getting a ...
0
votes
2answers
399 views

404 problems, staging only

I've got a bizarre issue that is only happening on staging. Locally all urls work correctly. on staging http://domain.com/archives and http://domain.com/photography/entry_slug both return a 404 page ...
1
vote
1answer
60 views

Environmental variable coming back as literal braces

I have my general config file set up as follows: return array( 'localhost' => array( 'devMode' => true, 'environmentVariables' => array( 'baseUrl' => 'http://localhost:8888/path/...
1
vote
1answer
202 views

404 in HTTP Header on working site

I have a Craft site which seems to function properly but I see a 404 in the header http status code. I’ve located the following in the error logs: 2016/07/28 15:22:30 [error] [exception.Craft\...
1
vote
1answer
612 views

400 error on Craft 3 installation

When I try to install Craft CMS 3 by going to /admin the site redirects me to /index.php?p=admin/install where the Begin button shows. Clicking next send me to the screen to create an admin user. ...
4
votes
1answer
401 views

Migrating Craft site to another server — throws 404 for all pages but homepage

I've been asked to migrate a Craft site from one server to another. The new server setup is the same as the server I'm migrating from. I moved all the files in the webroot directory over to the new ...
1
vote
2answers
338 views

404 error on Craft homepage

I'm having some trouble on a fresh install of Craft. I've uploaded all the files to my server and moved index.php (etc) out of the public folder and into the root directory. I've also changed index....
0
votes
1answer
55 views

Renaming news section leads to 404

I'm pretty new to Craft, just installed my first one. I've checked the docs, but I couldn't find any useful hints anymore and I think it should work. I'm trying to rename the default news section to ...
0
votes
1answer
16 views

I am unable to render new entries on the browser (demo version)

I just started using craft and am still exploring the Happy Lager demo version. I can create new sections, fields and entries. However, when I try to render the entry on my browser by clicking on the ...
2
votes
3answers
642 views

Unable to manage robots.txt in Craft

I would like my robots.txt file to be generated by Craft. Things that I have tried that don't work: a craft/templates/robots.txt template a craft/templates/robots.txt.twig template a route for robots....
1
vote
2answers
813 views

404 when viewing assets

I'm having some trouble getting started with Craft. I'm attempting to upload some image assets for the first time. I've set up an asset source. I've tried using both a relative and an absolute path ...
3
votes
3answers
4k views

Assets (images) return a 404 on the front-end

I have the following issue which I can't seem to wrap my head around. All images assets uploaded to Craft return a 404 not found on the front-end. Everything works fine in the admin CP though (...
1
vote
1answer
162 views

Successful login with 'requireLogin' redirects to 404.shtml

I have recently migrated an intranet to its production environment, and the requireLogin is misbehaving: I'd go to intranet.example.com/ Log in with my details Craft will redirect me to intranet....
5
votes
2answers
1k views

Element API plugin - Return message when no results are found

Per this code example, it's clear that the API is expecting to return results based on an existing element... 'transformer' => function(EntryModel $entry) { ... } And when the criteria finds ...
1
vote
1answer
608 views

Dynamic route returning 404 error

I've set up some dynamic routes to work with categories, so for example the route is set up to load a specific template if the work category appears in the URI, thus: news-events/image-gallery/...
2
votes
1answer
763 views

Changing the default admin path

I am trying to reset the default path to the dashboard from admin to something else. I have this in config/general.php: return array( 'cpTrigger' => 'new-url', 'omitScriptNameInUrls' => ...
1
vote
2answers
88 views

Plugin does not exist on 404 page?

Before I go into detail and share my error logs and plugin details, I'll ask the simple question first: When testing my 404 page, no plugin functionality works. Is this intentional? Just for ...
1
vote
1answer
129 views

Redirecting certain 404s to a page, handling all others as normal

I'm having trouble setting things up to redirect some old news articles a certain way, while still serving existing articles: If a page exists at /news/my-article then it should be served as normal....
2
votes
1answer
774 views

Controller Action 404

Ok once again I'm having an issue with a plugin controller. It was working once upon a time but stopped sometime in the past year. I have stripped the plugin down to bare, so there is no reason it ...
5
votes
3answers
905 views

Multi-locale pages 404 on subdirectories

I'm developing and running a Craft site locally through Laravel Homestead and am having issues with pages 404'ing in a multi-locale setup. I've followed this guide closely: https://craftcms.com/docs/...
1
vote
1answer
40 views

Form validation plugin result in 404

I'm new to craft development, and I'm on the verge of success in the creation of my plugin, but I have a strange problem. It's supposed to save a record based on user input data. The problem is that ...