0

I try to install Craft 3 but I encounter an issue at the very beginning. I uploaded the CMS via FTP and completed manually the .env file. When I try to run the installation, I get stuck at the account creation (the second step…) I want to create my account but the next button is doing nothing. I get an error 400 "Bad Request // Unable to verify your data submission." When I send the form to create the admin account (POST to http://mywebsite.com/web/index.php?p=admin/actions/install/validate-account).

The server meet the requirements of Craft CMS (runned the server check and was ok). The DB connection is fine.

I tried to delete and reupload all the CMS but nothing changed.

Therefore, I'm unable to install Craft :| I saw some topics of the same issue but they're all unanswered.

Thanks a lot !

Here are the corresponding logs :

            2018-04-13 06:05:42 [2a02:a03f:3c1f:a00:6826:543f:275d:d8d5][-][-][error][yii\web\HttpException:400] yii\web\BadRequestHttpException: Unable to verify your data submission. in /home/MyWebsite/www/vendor/yiisoft/yii2/web/Controller.php:166
            Stack trace:
            #0 /home/MyWebsite/www/vendor/craftcms/cms/src/web/Controller.php(53): yii\web\Controller->beforeAction(Object(yii\base\InlineAction))
            #1 /home/MyWebsite/www/vendor/yiisoft/yii2/base/Controller.php(155): craft\web\Controller->beforeAction(Object(yii\base\InlineAction))
            #2 /home/MyWebsite/www/vendor/craftcms/cms/src/web/Controller.php(74): yii\base\Controller->runAction('validate-accoun...', Array)
            #3 /home/MyWebsite/www/vendor/yiisoft/yii2/base/Module.php(528): craft\web\Controller->runAction('validate-accoun...', Array)
            #4 /home/MyWebsite/www/vendor/craftcms/cms/src/web/Application.php(238): yii\base\Module->runAction('install/validat...', Array)
            #5 /home/MyWebsite/www/vendor/craftcms/cms/src/web/Application.php(446): craft\web\Application->runAction('install/validat...', Array)
            #6 /home/MyWebsite/www/vendor/craftcms/cms/src/web/Application.php(410): craft\web\Application->_processActionRequest(Object(craft\web\Request))
            #7 /home/MyWebsite/www/vendor/craftcms/cms/src/web/Application.php(147): craft\web\Application->_processInstallRequest(Object(craft\web\Request))
            #8 /home/MyWebsite/www/vendor/yiisoft/yii2/base/Application.php(386): craft\web\Application->handleRequest(Object(craft\web\Request))
            #9 /home/MyWebsite/www/web/index.php(21): yii\base\Application->run()
            #10 {main}
  • Can you find the 400 Bad Request entry in your craft/storage/logs folder and share the full stack trace leading up to it? – Brad Bell Apr 12 '18 at 5:19
  • Hi Brad and thank you for your answer, I edited my post to add the logs ! – Holino Apr 13 '18 at 13:15
  • Have seen that happen when you try to install over http and the site is configured to use https (and visa-versa). And if you're using Chrome it can be overly aggressive with it's caching if you make a switch (even in incognito mode). Have had to clear all of Chrome's caches before it would change sometimes. – Brad Bell Apr 14 '18 at 23:40
0

Hello and thanks Brad !

I was actually using Firefox. When I tried to install Craft 3 via Chrome (which has never gone to the website before) the issue was solved and I could access to the next page. Should be a cache issue !

Thank you !

Olivier.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.