Questions tagged [updates]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
40 views

Getting a mega error in updating from 3.1

Firstly, I understand it's silly to leave a project go this out of date, but it was out of my hands. Secondly, there are many abandoned plugins in here, but I'm keen to the project updated then adjust ...
user avatar
  • 1,032
1 vote
1 answer
31 views

composer.json showing different version to database

Have a site which is on version 3.6.16 I was running the upgrade to the latest versions and it crashed. I have restored the database and componser.json and composer.lock files and ran composer install ...
user avatar
  • 1,769
0 votes
0 answers
20 views

Deployment path using Craft Nitro

I've started to use Craft nitro to update already live websites locally, but I am having a bit of a hard time working out how to push the updated site files and database back to the live site. I'm ...
user avatar
  • 275
0 votes
0 answers
33 views

Errors on updating the CMS

I am working on my first Craft CMS website. The website owner notified me this weekend, his website is out of the Google index. Found there is this bug https://github.com/craftcms/cms/issues/9621 Can'...
user avatar
  • 1
0 votes
0 answers
35 views

Craft CMS update failed - Connection refused

I'm gettting the following error while trying to update within the control panel. Fehler: curl error 7 while downloading https://composer.craftcms.com/packages.json: Failed to connect to composer....
user avatar
  • 1
1 vote
1 answer
90 views

Exception 'yii\base\UnknownMethodException'

After updating to 3.7.19 I ran the command as instructed in the changelog: php craft utils/repair/section-structure <sectionHandle> But it returned the following: Exception 'yii\base\...
user avatar
0 votes
0 answers
29 views

Composer cannot update because access to /etc/pki/tls/certs/ca-bundle.crt not allowed

Earlier updates for Craft always worked for me, but when I tried to install a plugin or update Craft this morning I got the following error: Composer was unable to install the update "Error: ...
user avatar
  • 1
1 vote
1 answer
96 views

Updating to 3.7.19 query

The update notes say: After updating, run the following command for each Structure section, to prune unneeded >structure data for drafts and revisions. php craft utils/repair/section-structure I ...
user avatar
1 vote
0 answers
187 views

Migration fails during update to 3.7.7

I'm updating a Craft installation from 3.5.17.1 to 3.7.7 and it's failing when applying migrations. I'm trying to do the update via CLI on MAMP. Here is the relevant part of the error: *** applying ...
user avatar
  • 960
1 vote
1 answer
262 views

Updating to 3.7 issue (applying m210602_111300_project_config_names_in_config)

Probably my fault — I’m generally OK with this stuff until something goes wrong — but… I updated a local install (MAMP PRO) to Craft 3.7 by clicking that lovely 'update' button. And it worked fine, ...
user avatar
  • 176
1 vote
1 answer
99 views

Update from 3.5.19 to 3.6.15 Failed

Tried doing an update to 3.6.x from 3.5.19 from the terminal and got this horrifying message: `` Performing one update: - craft 3.5.19 => 3.6.15 Backup the database? (yes|no) [yes]:yes Backing up ...
user avatar
  • 1,311
3 votes
1 answer
197 views

Update from 3.3.4.1 to 3.6.11.2 advice

What is the best way to do this? I also have a number of plugins that all need updating from the same time period. I don't think any of the breaking changes affect anything I've done, but I wonder/...
user avatar
2 votes
1 answer
43 views

Plugin record no dateUpdated and uid

I'm building a small analytics plugin and as such, I don't need the dateUpdated and uid columns in my records, but I dind't find any way of disabling them. Currently I have tried: Not setting them in ...
user avatar
  • 35
1 vote
1 answer
175 views

Commerce new order error : mail::getRenderLanguage() must be of the type string

I just pushed an update to the latest version of craft cms and craft commerce and ran into an error that is blocking new orders from finalizing. Everything works on the local site. On the live site, ...
user avatar
  • 31
1 vote
1 answer
4k views

"Error: Unknown package has no name defined" when updating Craft 3

I'm getting "Error: Unknown package has no name defined" when updating a site from 3.0.41.1 to 3.5.15.1 I had read a reinstall of composer had fixed this for someone else, but hasn't for me. ...
user avatar
  • 107
1 vote
1 answer
46 views

dev- branch plugin forks being prompted for update

I'm currently using a fork of a plugin for my site, and using a "dev-[branch-name]" version specification in the composer "require" block, with a "vcs" repository ...
user avatar
  • 61
1 vote
1 answer
58 views

Update 3.5.15.1 - Fixed a bug where the Updates utility wasn’t showing “Update” buttons

The update button is missing, and the fix is available, but impossible to initiate from the CP. Before I embark on a manual update, I wondered if there was a URL that I could use to trigger the ...
user avatar
  • 1,538
10 votes
7 answers
30k views

"Unknown package has no name defined" composer error on upgrade

Upgrading from Craft 3.4.20 running Composer 1.10.17 on PHP 7.2. Running ./craft update all returns the following error: error: Unknown package has no name defined. [followed by JSON object related to ...
user avatar
  • 286
1 vote
1 answer
367 views

Dependency Conflict Updating to Craft 3.5

I'm trying to update to Craft 3.5 from 3.4.3 but running into this error message: Composer output: Package "craftcms/vue-asset" listed for update is not installed. Ignoring. Loading composer ...
user avatar
2 votes
2 answers
1k views

Craft 3.5.1 CLI Update Error: Failed to instantiate component or class "yii\shell\Bootstrap"

when I try to update Craft via CLI to 3.5.1. I get the following error: Failed to instantiate component or class "yii\shell\Bootstrap in /vendor/yiisoft/yii2/di/Container.php:449 Stack trace: #0 ...
user avatar
  • 205
1 vote
2 answers
118 views

Craft 2 to Craft update - timeout when updating database

I am trying to update a site from Craft 2 to Craft 3. I first set up a new server, installed Craft 3, copied over config settings from the original site, and moved over a copy the original database. I ...
user avatar
  • 1,311
1 vote
1 answer
25 views

What does update actually do?

Upon updating CraftCMS via CP > Utilities or Terminal, does this update only the vendor folder? Or does it also change structure in the DB and other files outside the vendor?
user avatar
1 vote
1 answer
151 views

Updating old setup (3.0.41.1) to 3.1.0 various errors every time

I'm unfortunately dealing with a very old system that hasn't been updated in a long time. I've been able to update it up to 3.0.41.1 but once I attempt to go any further I get tons of different errors....
user avatar
  • 1,369
1 vote
1 answer
408 views

AWS EC2, Load Balancer and Updating Craft

I have a pretty large Craft site that needs to be load balanced with multiple ec2 instances and one RDS mysql instance. Everything is working great, except for I noticed that if I get to the admin ...
user avatar
1 vote
3 answers
387 views

Updating Craft to 3.3.19 gives 503 error only for logged-out users

Working on an outdated client project and updated craft on staging from 3.0.30.1 to 3.3.19 I'm getting 503 errors (site temporarily unavailable) when trying to visit any page on the site -- but only ...
user avatar
  • 73
2 votes
2 answers
4k views

ext-zip trouble

Issue: craftcms/cms 3.3.9 requires ext-zip * -> the requested PHP extension zip is missing from your system. Details: I am running on MAMP Pro 5.3. Currently using PHP 7.3.3 (but previous versions ...
user avatar
2 votes
0 answers
34 views

How to protect elements that are being edited during project-config/sync?

Some situations: An editor is editing an entry in the CP while an admin runs project-config/sync. A user starts a front end form to create a new entry before project-config/sync is run, but submits ...
user avatar
1 vote
1 answer
336 views

How to update Craft CMS/plugins without downtime?

On our production server, we have strict SLAs concerning when our site can be down. I've noticed that when I update Craft CMS 3 (using "./craft update all" on the server), the site will go down for ...
user avatar
  • 11
3 votes
1 answer
323 views

How to determine source of Elements save event

We need to send notification emails when entries of a particular type are created, updated, or enabled/disabled. The entrypoint for this happens in a module's init() method: Event::on(Elements::class,...
user avatar
  • 448
2 votes
1 answer
209 views

Updating large database from Craft 2 > 3 via command line

I'm migrating a large Craft + Commerce site up to Craft 3. I've completed all the initial steps and get as far as the "To complete the update, some changes must be made to your database. Finish up" ...
user avatar
1 vote
1 answer
100 views

Database migrations on environments - in which env do I apply updates to Craft and Plugins?

When developing a Craft 3 site on a multi-environment setup, where would I apply the Craft and Plugin updates? Should I apply them locally and then commit and replace the database in the dev env, or ...
user avatar
  • 617
1 vote
1 answer
42 views

Internal Server Error - getDateFormatter() on null

When doing a manual update from 2.6.3012 to 2.7.8, I get the following error: Internal Server Error Call to a member function getDateFormatter() on null I get the following error when enabling ...
user avatar
  • 121
2 votes
2 answers
278 views

my vendor/craftcms/cms folder delete automatically after every update or install

I was on version 3.1.22. As usual, I wanted to install the update on Craft CMS 3.1.23. So I clicked Install and got this error: Status: Error But that was not all ... My complete vendor/craftcms/...
user avatar
  • 61
3 votes
3 answers
1k views

cannot update Craft CMS - composer errors

I'm upgrading a site to 3.0.41.1 (not ready to go to 3.1) and when I do I get the following error. How do I resolve this? composer update craftcms/cms Loading composer repositories with package ...
user avatar
  • 1,907
1 vote
1 answer
186 views

Craft CP showing plugin updates, but already updated

This morning there were new updates for Craft CMS, Contact Form and Simplemap on a Craft Pro site I host. I updated everything through the Craft CP. After the update, the CP still shows available ...
user avatar
  • 125
6 votes
7 answers
3k views

Invalid plugin: No plugin exists with the handle - Craft 3

I had an issue with my site running Craft 3.1.15 where I wasn't able to update the site to the most recent 3.1.16, and also wasn't able to install any plugins. Every plugin I tried would throw this ...
user avatar
  • 407
1 vote
1 answer
45 views

Plugin not updating in the plugin store from changelog updates

I have a custom plugin registered with id.craftcms.com. The plugin store currently sees it at as 2.0.0, but I have since updated the plugin to 2.0.1 (and subsequently tried to force a silent 2.0.2 ...
user avatar
1 vote
1 answer
104 views

Error when updating from 3.1.11 to 3.1.15

After I run an update, I get this error: '⚠' is not a numeric value. I've tried to run the updates multiple times with the same result. I was also able to update plugins with no issues. yii\base\...
user avatar
  • 13
1 vote
0 answers
264 views

Every time I perform updates on Craft 3, I get errors

What is going on in Craft 3, seems like Composer has caused more problems than good. Every time I have had to update a dev/staging environment I run into issues and have to go and manually update the ...
user avatar
  • 781
1 vote
1 answer
79 views

Updates on live server without using Control Panel

I'll freely admit to being a bit of a newb when it comes to SSH but wanting to start utilizing it more for my Craft3 sites. Maybe this is an irrelevant question but is it possible to update craft on ...
user avatar
5 votes
2 answers
4k views

"Craft isn't installed yet" error after updating to Craft 3.1

I just updated to Craft 3.1 and logged into the admin to make the required updates to the database and this all worked fine. However, when I use the new ./craft update CLI feature, it responds with "...
user avatar
  • 1,032
4 votes
2 answers
2k views

Can't update to 3.1.x

I'm in a multi config env, local, staging & production. I sync my databases down to local then usually update locally, then push to staging and check again before going live. The recent 3.1 ...
user avatar
  • 1,888
1 vote
1 answer
816 views

HTTP 500 Error after trying to update to Craft 3.1.1

I just tried to update Craft to 3.1.1 from within the CP. The install failed and I got an Internal Server 500 error. I now can't load either the front or backend of the site, I get a 500 error in both ...
user avatar
  • 21
0 votes
0 answers
49 views

CP doesn't recognize update from 2.7.3 to 2.7.4

I have a site running Craft 2.7.3. My update flow is to make sure that my development branch is up to date (with no outstanding commits) and that my local db is up to date with production. I then ...
user avatar
  • 448
1 vote
1 answer
72 views

Offline update then upload files to server

What's the best way to update Craft offline and then upload the files to the server? Reason I'm asking is because my updates often fail because of too low PHP memory and I don't have control over the ...
user avatar
1 vote
2 answers
624 views

Update Craft CMS, now I get HTTP ERROR 500

I have a site that's been running Craft 3 and has been running smoothly for several months now. I was going to update a post today, and noticed that there were updates to Craft 3 that needed to ...
user avatar
  • 409
1 vote
2 answers
523 views

Getting fatal error when installing new plugin by hitting memory_limit

I am trying to locally install Craft Typed Link Field from the plugin store and I'm getting this PHP error. I have already upped my memory_limit to 256M within my php.ini file, yet this is claiming ...
user avatar
  • 1,032
1 vote
2 answers
1k views

Craft 3 CMS Update Error

I try to update my craft3 cms system. Ошибка: An error occurred Вывод: Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an ...
user avatar
0 votes
1 answer
1k views

Unable to Update Craft CMS & Plugins [duplicate]

When trying to update CraftCMS I'm getting the following errors: Error: An error occurred Output: Loading composer repositories with package information Updating dependencies Your requirements could ...
user avatar
  • 1,218
1 vote
1 answer
569 views

Can't update past 3.0.15

Here's what I'm getting: Error: An error occurred Output: Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set ...
user avatar
  • 1,369