enter image description here

I'm new with Craft CMS and receive this error when I try to install it


An Error occurred while handling another error: yii\web\ServerErrorHttpException: The info table is missing its row in C:\xampp\htdocs\craft\vendor\craftcms\cms\src\base\ApplicationTrait.php:512

  • Welcome to Craft! Are you trying to access /admin/install when you get this error?
    – CraftQuest
    Aug 23, 2018 at 14:08
  • I get the same error every time i try to backup the DB from the dev to my local env, from the panel. I work on Windows 10, my coworkers are on IOS and they do not seem to have this particular issue. It's not happening on one specific setup, but all of our Craft 3 projects. The craft_info table is, in fact, empty, thus the error. If i export it from phpmyadmin, it's all good! No other error has been logged, but The info table is missing its row... Dec 19, 2018 at 15:55
  • be careful with version 5.7 as it works with 5.6. Jun 15, 2021 at 12:47
  • Could you give some more explanation about what you're referring to when you mention these versions? Jun 16, 2021 at 19:20

3 Answers 3


The info table is missing its row...

The craft_info table in the database should only ever have one row in it. In a fresh Craft installation, then installer should populate the row with the relevant information.

If you're getting that error message, then that table is missing its one row, which would indicate that some other error happened during installation.

If it's a Craft generated error, then that underlying message would be in your craft/storage/logs files. If it's a web server generated error, that error would be in your web server's error logs.


I ran across this same error and it seemed if I had minimal permissions setup for the database user then I would get this error. I changed the permissions for the database user to be a DBA and it worked. I didn't want to have the craft user setup with permissions at the DBA level but when the craft script is running ADD CONSTRAINT or adding foreign key it makes sense.


I just ran into this updating a site from to 3.4.x. There was one row in the info table, but it had an ID of 2. I changed the ID to 1 and it started working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.