Questions tagged [error-message]

Information about an error displayed when an unexpected condition (error) occurs.

Filter by
Sorted by
Tagged with
0 votes
1 answer
23 views

Plugin install/remove causes fatal error on local

After updating to Craft Pro 3.7.44 my local MAMP site now throws a server error when adding/removing a plugin within the Craft CMS UI. Editing the composer.json file manually and running composer ...
user avatar
1 vote
0 answers
36 views

Internal server error - Cannot serve directory

Randomly a couple of times a day my website throws an Internal Server Error that fixes itself within minutes. Checking the logs (have replaced my username with 'username') it looks like a server issue ...
user avatar
  • 11
1 vote
1 answer
91 views

Exception 'yii\base\UnknownMethodException'

After updating to 3.7.19 I ran the command as instructed in the changelog: php craft utils/repair/section-structure <sectionHandle> But it returned the following: Exception 'yii\base\...
user avatar
1 vote
1 answer
37 views

What's the attribute of a Matrix field to add error message

I try to validate some fields before saving the entry, if the field is invalid, prevent the entry from saving and return the error message, I'm doing it via Element::EVENT_BEFORE_SAVE event. It works ...
user avatar
  • 27
1 vote
1 answer
34 views

Class 'Craft\File' not found during installation

I'm installing Craft 2 locally and am getting this error message when I expect the installation screen. I've checked the write permissions, and the directory has them (inheritable permissions). ...
user avatar
  • 368
2 votes
1 answer
44 views

Trouble configuring access to craft site

So I installed Craft and everything via homebrew on a Mac and created a new project (using nitro) in ~/Documents/www/craft. I then used Abyss Server to configure a sub-domain on my dyndns address to ...
user avatar
0 votes
0 answers
56 views

Category’s group (1) is not enabled for site (1). when moving site?

I've moved my site over, importing from the previous one using the project folder. When trying to do a feedme import I'm getting the following error with Categories: Category’s group (1) is not ...
user avatar
  • 1,218
0 votes
0 answers
19 views

'Not authorized to access this resource' when logged in user clicks download link

A user has received this message 'Not authorized to access this resource' when logged in and attempting to download a file by a link. The file was a .zip. I've tested this, but could not replicate the ...
user avatar
  • 700
0 votes
0 answers
206 views

Contact form returning "Error 400: Bad Request: Request missing required param" -- how can I best narrow down the issue?

I'm sort of stumped in troubleshooting the following problem that I'm having with the Contact Form. Below I'll list the code, some of the attributes of the code that may be causing this issue, and the ...
user avatar
  • 11
1 vote
1 answer
37 views

After transferring local to server, Twig Runtime Error: Impossible to invoke a method all() on an array

I transferred site from MAMP to Arcustech server and the Admin panel works fine, I even updated to 3.6.6, but the front-facing site throws an error: Twig Runtime Error: Impossible to invoke a method ...
user avatar
0 votes
0 answers
51 views

Browser limited 400 error when logging in

At random times local sites don't allow me to login to admin with certain browsers. Currently I cannot login to a site using Chrome, but can using Firefox. I have had sites that won't login with ...
user avatar
  • 107
0 votes
0 answers
43 views

How do you Paginate if Looping through element queries directly is deprecated?

I want to create a basic product listing page based on categories. I created a template that dynamically shows all items based on the category that is passed to it based on the help I received here. ...
user avatar
1 vote
1 answer
114 views

Issue on new craft (craftcms3) setups: vendor Twig can't read system variable

After installing craft through composer, setting up the database and running craft setup, I have a craft application ready to go. When I go to settings/general, I always get a crash with following ...
user avatar
  • 113
1 vote
1 answer
175 views

Commerce new order error : mail::getRenderLanguage() must be of the type string

I just pushed an update to the latest version of craft cms and craft commerce and ran into an error that is blocking new orders from finalizing. Everything works on the local site. On the live site, ...
user avatar
  • 31
0 votes
0 answers
762 views

Internal Server Error (Server Error)

My home page and some inner pages work fine but some page is not working and when i click on it then its showing me " Internal Server Error Server Error" Please help me to sort out this ...
user avatar
  • 1
1 vote
1 answer
144 views

PHP error when trying to access dates in Sprout Reports

Basic Sprout Report here, settings page: {{ forms.dateTimeField({ label: "Start Date"|t, instructions: "The start date of the date range you wish to display in your report."|t, ...
user avatar
  • 596
1 vote
1 answer
88 views

returning HTML in $event->sender->addErrors doesn't work

I have a plugin which is checking if there is a duplicate entry before save. I'm trying to give the user back an anchor to the entry which exists so my client can switch without searching for it in a ...
user avatar
  • 160
0 votes
0 answers
131 views

Error when setting field length on global

I have set up several globals to store the URLs of a company’s social media accounts. Each one is a plain text field, and each one is limited to 254 characters. This works fine with three of them, but ...
user avatar
  • 176
1 vote
1 answer
341 views

500 Internal Server Error when accessing admin

I just get a server error when trying to access /admin, or any other URL. This is a completely new installation on a staging server. The 'Welcome' page shows OK. I'm guessing this is a .htaccess ...
user avatar
  • 700
1 vote
1 answer
29 views

Trying to create a new field returns "General Error: 1030 Got error 1 from storage engine"

I recently updated the site to 3.5.5, so not sure if this has anything to do with it. It's been a while since the last field we created, so can not say for sure if this is correlated. Database on this ...
user avatar
  • 21
0 votes
0 answers
54 views

Craft CMS image src error

Good morning, I have inherited a Craft CMS site from a previous developer, and am running into issues when looking to add images to the site. Following instructions I grabbed the copy of the SQL ...
user avatar
1 vote
1 answer
165 views

Missing field validation on user account edit

I've been implementing a user account page with Craft Commerce and copied over the template found here: https://docs.craftcms.com/v3/dev/examples/user-profile-form.html#simple-profile The issue is ...
user avatar
  • 113
2 votes
2 answers
40 views

{{ category.title }} error with category groups

I feel like I'm missing something totally obvious here, but how do I output a category name for a category that is part of a category group on a single entry layout? The name of the category group is '...
user avatar
  • 53
0 votes
0 answers
181 views

Error after Updating Craft

After submitting the last Craft Update over the CP i got the following error: Warning: require(/home/xxx/xxx/xxx/vendor/craftcms/cms/bootstrap/console.php): failed to open stream: No such file or ...
user avatar
  • 213
1 vote
2 answers
113 views

Problems transferring updates back to live server

For quite a long time i've updated and amended Craft by taking a copy of the files and database (.zip) from the live server, making the updates/changes/amendments locally and then transferring ...
user avatar
  • 1,173
1 vote
1 answer
153 views

Matrix Error - "Field Limit is too big for your chosen Column Type"

I have a matrix field which is used a my main Body content field. The site has just been updated to the latest version of Craft and I tried to add a block to the matrix field but when i try to save it ...
user avatar
  • 1,769
1 vote
2 answers
2k views

Setting unknown property: craft\models\Update::packageName

I am taking over a Craft website for a client. It is currently working fine on the hosting environment. I have pulled the website down locally from the hosting environment - the exact same files and ...
user avatar
  • 1,769
3 votes
1 answer
347 views

How to duplicate entries and loop them without getting a Twig or deprecation error?

I'm trying to duplicate entries inside a macro, which will displays duplicated items inside a carousel. It's not possible to merge Element Queries. Even if it's possible to merge IDs, merging an ...
user avatar
1 vote
1 answer
203 views

Craft admin twig templates broken somehow

I am a front end designer building my site locally. This is the first time I've built in Craft and things have been coming along fine but now I'm getting the following error on every craft admin page ...
user avatar
  • 21
1 vote
1 answer
1k views

Error sending email: Process could not be started [The system cannot find the path specified. craft cms

I'm testing my email and I'm seeing the following error in the web logs: "Error sending email: Process could not be started [The system cannot find the path specified. craft cms" Does anyone know ...
user avatar
  • 21
1 vote
1 answer
436 views

Bad Request: Post Request Required when saving hyperlink in specific redactor field

I'm having a strange issue here. I have a site running Craft 3.3.7. I have an entry with a matrix field with several redactor fields in it. In one of those redactor fields, I have a paragraph of text. ...
user avatar
1 vote
2 answers
2k views

HTTP 503 – Service Unavailable error

I've cloned a Craft 3 repo that was created by another developer and I'm trying to get it running on my local server but I get HTTP 503 – Service Unavailable – craft\web\...
user avatar
  • 509
0 votes
0 answers
110 views

Craft CMS Content has Disappeared?

My content within all of my pages has disappeared. The website is only displaying the header and footer on each page. When I try to restore the internal page to it's previous version to get the ...
user avatar
  • 1
1 vote
1 answer
547 views

Internal Server Error when adding new Fields

I was adding new fields to my Craft 3 install using the field manager plugin. Suddenly I am seeing a Internal Server Error when trying to access the admin area. The front end looks fine. Anyone know ...
user avatar
  • 1,107
1 vote
1 answer
383 views

Deprecation Errors - How to Fix?

We are in development of our new site in Craft 3 and we are getting some deprecation errors. This is keeping us from using Craft Commerce for our ordering page. Any suggestions on how to fix this? ...
user avatar
1 vote
1 answer
82 views

Can't access "settings"

I can access "settings" in the control panel. Getting these errors: Please help. yii\base\ErrorException: Undefined property: DOMElement::$tagName in /home/I/ingvildholmno/vendor/enshrined/svg-...
user avatar
1 vote
1 answer
299 views

Can access admin page (now), but not any site pages...yii not found http execption

Have not accessed my local .test sites in a bit. I tried today. I am getting a series of errors. At first I could not access any page to include the admin page. I ran Composer update from the ...
user avatar
  • 891
1 vote
1 answer
357 views

devMode false, Internal Server Error

Wanted to test 404 error page on our beta site. Set devMode to "false" in general.php. When I do this and try to view inner pages on the website, we receive an "internal server error". All inner pages ...
user avatar
  • 61
1 vote
2 answers
926 views

Craft on WSL permissions error

For anyone installing install Craft on WSL (Windows Services for Linux)... WSL has enough traction with developers that I decided to take the dive, but I'm having trouble getting permissions straight ...
user avatar
  • 137
1 vote
1 answer
507 views

Class 'Craft' not found

I am new to PHP and trying to call reCaptcha API in CraftCMS. I have the following variable: $captcha = Craft::$app->getRequest()->getParam('g-recaptcha-response'); But I get the following ...
user avatar
  • 11
1 vote
1 answer
287 views

SSL now CP unknown errors

I have a Craft 3 site that's been running on a production server. Recently we switched over to https but this has caused issues in the CP (multiple 'An unknown error occurred' red flags, can't view ...
user avatar
1 vote
0 answers
343 views

An unknown error occurred message, only on live server

Please can anyone give me some pointers. Just logged into the backend on an older (but live) 3.0.26.1 project. CP is now flashing multiple 'an unknown error occurred' messages on every CP request. ...
user avatar
2 votes
1 answer
837 views

Migrating Server - Craft isn't installed yet

I've set up a new Forge server and connected the repo to my site. I've also uploaded the database and copied over the db credentials to the dotenv file. However when I visit the site control panel ...
user avatar
  • 1,907
1 vote
1 answer
61 views

Error creating new volume

When creating a new volume (same process as the other 3 volume I currently have and which are fine, I'm running into the following error). Any help would be appreciated.
user avatar
1 vote
1 answer
249 views

Unique URI error

I am getting the following error when trying to save a structured entry: Could not generate a unique URI based on the URI format. Title of entry is: Hells Gate Mud Bath & Spa Slug: hells-gate-...
user avatar
  • 171
1 vote
1 answer
746 views

TypeError: Argument 1 passed to craft\services\Fields::getGroupById() must be of the type integer, null given

When I go to control panel > Settings > Fields, I get a page that throws TypeError: Argument 1 passed to craft\services\Fields::getGroupById() must be of the type integer, null given This is ...
user avatar
1 vote
3 answers
2k views

Unable to run console commands (Craft 3, MAMP)

This was asked and solved previously, but for Craft 2, see Error Connecting To (MAMP Pro) Database in Console Command. Unable to make it work here. In short, running console commands like ./craft abc ...
user avatar
1 vote
2 answers
80 views

Upload failed. The error message was: "SQLSTATE[23000]: Integrity constant violation:

I'm getting this strange error when I'm trying to upload an .jpg in the assets. Env: Localhost Craft version 3.1.8 MAMP: - PHP(7.2.7) - MySQL: 5.7.21 Upload failed. The error message was: "...
user avatar
1 vote
1 answer
199 views

Assets are not loading anymore (maybe an update)

I just noticed that I can't see my files if I go into the assets section. An Error blinks up and says "An unknown error occurred". In the front-end, I see every file and I can upload files to an asset ...
user avatar
  • 53
4 votes
2 answers
2k views

"Craft CMS does not support backtracking to this version. Please upload Craft CMS 0 or later."

I have a problem related this and this question. I began updating a long time ago (2017?) and got the error "Craft CMS does not support backtracking to this version. Please upload Craft CMS 0 or later"...
user avatar
  • 171

1
2 3 4 5