Questions tagged [error-message]

Information about an error displayed when an unexpected condition (error) occurs.

Filter by
Sorted by
Tagged with
2 votes
1 answer
34 views

New Laptop - Developing Existing Project Locally

I've got a craft cms 4 website that I've been developing locally on my old PC and I've also got hosted with Servd Host. I've just got a new mac and I'm trying to get my project running locally on it ...
George Bleasdale's user avatar
1 vote
1 answer
29 views

Composer error when adding imager-x plugin

Error: "https://composer.craftcms.com/p2/aws/aws-sdk-php.json" does not contain valid JSON Parse error on line 1: ...pball\/6690347bc833"https:\/\/api.github ----------------------^ ...
JYdigital's user avatar
2 votes
1 answer
64 views

Invalid broken image path

I’ve converted an old site with 15+ years of posts over to Craft from WP. There were a lot of missing images, I’ve handled this with the broken image path setting in the config/general.php. However, I’...
mitrol's user avatar
  • 252
0 votes
0 answers
16 views

Survey Question - Not Seeing Success Message

I am creating a survey for a client but when testing the survey, I am having trouble getting the Success Message or Error Message when complete ("Thank you for taking the survey" or "...
adrienne's user avatar
1 vote
2 answers
45 views

Postgres DB Schema not referenced when accessing web url but craft cmd works fine?

I'm having a strange issue when accessing a craft instance via the web yet the craft cmd works fine. When resolving the URL it's throwing a 503 and the logs are showing an issue with fetching data ...
Rich D.'s user avatar
  • 45
0 votes
0 answers
41 views

"Craft Isn’t Installed Yet" Error - Asset Indexes

I have a Craft 4 site — all working fine. If I go to Utilities > Asset Indexes > Update Asset Indexes, I get the following error: "Craft isn’t installed yet." Clearly, this is not the ...
mitrol's user avatar
  • 252
0 votes
1 answer
100 views

"Unable to verify your data submission" error when logging into Craft Control Panel

After a recent Craft/plugin upgrade, I could not log into the Craft control panel. After submitting the login form, I received the error "Unable to verify your data submission". I cleared my ...
Anna_MediaGirl's user avatar
1 vote
1 answer
120 views

Commerce: Calling unknown method error on Edit Address screen

I'm using Commerce 3.4.16, Craft 3.7.51. I'm able to enter an address as part of checkout, and I can see that address in the CP, but when I go to the edit address screen on the front end, I get this ...
artmem's user avatar
  • 1,012
1 vote
1 answer
373 views

Failed to instantiate component or class "yii2tech\ar\softdelete\SoftDeleteBehavior"

Anyone knows what caused this error and how to fix it? It appears when I edit a field or a section and try to save it. Next yii\di\NotInstantiableException: Failed to instantiate component or class &...
aren's user avatar
  • 69
1 vote
1 answer
118 views

Plugin install/remove causes fatal error on local

After updating to Craft Pro 3.7.44 my local MAMP site now throws a server error when adding/removing a plugin within the Craft CMS UI. Editing the composer.json file manually and running composer ...
Mike Niland's user avatar
1 vote
0 answers
52 views

Internal server error - Cannot serve directory

Randomly a couple of times a day my website throws an Internal Server Error that fixes itself within minutes. Checking the logs (have replaced my username with 'username') it looks like a server issue ...
otb's user avatar
  • 11
1 vote
1 answer
294 views

Exception 'yii\base\UnknownMethodException'

After updating to 3.7.19 I ran the command as instructed in the changelog: php craft utils/repair/section-structure <sectionHandle> But it returned the following: Exception 'yii\base\...
Paul Frost's user avatar
  • 1,038
1 vote
1 answer
134 views

What's the attribute of a Matrix field to add error message

I try to validate some fields before saving the entry, if the field is invalid, prevent the entry from saving and return the error message, I'm doing it via Element::EVENT_BEFORE_SAVE event. It works ...
Thomas's user avatar
  • 69
1 vote
1 answer
78 views

Class 'Craft\File' not found during installation

I'm installing Craft 2 locally and am getting this error message when I expect the installation screen. I've checked the write permissions, and the directory has them (inheritable permissions). ...
buck1112's user avatar
  • 390
2 votes
1 answer
53 views

Trouble configuring access to craft site

So I installed Craft and everything via homebrew on a Mac and created a new project (using nitro) in ~/Documents/www/craft. I then used Abyss Server to configure a sub-domain on my dyndns address to ...
user12475's user avatar
0 votes
0 answers
21 views

'Not authorized to access this resource' when logged in user clicks download link

A user has received this message 'Not authorized to access this resource' when logged in and attempting to download a file by a link. The file was a .zip. I've tested this, but could not replicate the ...
Andrew's user avatar
  • 740
1 vote
0 answers
677 views

Contact form returning "Error 400: Bad Request: Request missing required param" -- how can I best narrow down the issue?

I'm sort of stumped in troubleshooting the following problem that I'm having with the Contact Form. Below I'll list the code, some of the attributes of the code that may be causing this issue, and the ...
Dylan's user avatar
  • 21
1 vote
1 answer
56 views

After transferring local to server, Twig Runtime Error: Impossible to invoke a method all() on an array

I transferred site from MAMP to Arcustech server and the Admin panel works fine, I even updated to 3.6.6, but the front-facing site throws an error: Twig Runtime Error: Impossible to invoke a method ...
doctorgloom's user avatar
0 votes
0 answers
77 views

Browser limited 400 error when logging in

At random times local sites don't allow me to login to admin with certain browsers. Currently I cannot login to a site using Chrome, but can using Firefox. I have had sites that won't login with ...
Jaytrix's user avatar
  • 167
0 votes
0 answers
51 views

How do you Paginate if Looping through element queries directly is deprecated?

I want to create a basic product listing page based on categories. I created a template that dynamically shows all items based on the category that is passed to it based on the help I received here. ...
doctorgloom's user avatar
1 vote
1 answer
176 views

Issue on new craft (craftcms3) setups: vendor Twig can't read system variable

After installing craft through composer, setting up the database and running craft setup, I have a craft application ready to go. When I go to settings/general, I always get a crash with following ...
Recipe's user avatar
  • 113
1 vote
1 answer
252 views

Commerce new order error : mail::getRenderLanguage() must be of the type string

I just pushed an update to the latest version of craft cms and craft commerce and ran into an error that is blocking new orders from finalizing. Everything works on the local site. On the live site, ...
Jack's user avatar
  • 31
0 votes
0 answers
3k views

Internal Server Error (Server Error)

My home page and some inner pages work fine but some page is not working and when i click on it then its showing me " Internal Server Error Server Error" Please help me to sort out this ...
Param's user avatar
  • 1
1 vote
1 answer
186 views

PHP error when trying to access dates in Sprout Reports

Basic Sprout Report here, settings page: {{ forms.dateTimeField({ label: "Start Date"|t, instructions: "The start date of the date range you wish to display in your report."|t, ...
4midori's user avatar
  • 606
1 vote
1 answer
129 views

returning HTML in $event->sender->addErrors doesn't work

I have a plugin which is checking if there is a duplicate entry before save. I'm trying to give the user back an anchor to the entry which exists so my client can switch without searching for it in a ...
Kevon's user avatar
  • 160
0 votes
0 answers
192 views

Error when setting field length on global

I have set up several globals to store the URLs of a company’s social media accounts. Each one is a plain text field, and each one is limited to 254 characters. This works fine with three of them, but ...
mitrol's user avatar
  • 252
1 vote
1 answer
425 views

500 Internal Server Error when accessing admin

I just get a server error when trying to access /admin, or any other URL. This is a completely new installation on a staging server. The 'Welcome' page shows OK. I'm guessing this is a .htaccess ...
Andrew's user avatar
  • 740
1 vote
1 answer
31 views

Trying to create a new field returns "General Error: 1030 Got error 1 from storage engine"

I recently updated the site to 3.5.5, so not sure if this has anything to do with it. It's been a while since the last field we created, so can not say for sure if this is correlated. Database on this ...
flannel's user avatar
  • 21
0 votes
0 answers
98 views

Craft CMS image src error

Good morning, I have inherited a Craft CMS site from a previous developer, and am running into issues when looking to add images to the site. Following instructions I grabbed the copy of the SQL ...
Thomas Martin's user avatar
1 vote
1 answer
239 views

Missing field validation on user account edit

I've been implementing a user account page with Craft Commerce and copied over the template found here: https://docs.craftcms.com/v3/dev/examples/user-profile-form.html#simple-profile The issue is ...
Sk446's user avatar
  • 113
2 votes
2 answers
44 views

{{ category.title }} error with category groups

I feel like I'm missing something totally obvious here, but how do I output a category name for a category that is part of a category group on a single entry layout? The name of the category group is '...
Maggie's user avatar
  • 53
0 votes
0 answers
278 views

Error after Updating Craft

After submitting the last Craft Update over the CP i got the following error: Warning: require(/home/xxx/xxx/xxx/vendor/craftcms/cms/bootstrap/console.php): failed to open stream: No such file or ...
TomS's user avatar
  • 213
1 vote
2 answers
135 views

Problems transferring updates back to live server

For quite a long time i've updated and amended Craft by taking a copy of the files and database (.zip) from the live server, making the updates/changes/amendments locally and then transferring ...
Martin's user avatar
  • 1,203
1 vote
1 answer
198 views

Matrix Error - "Field Limit is too big for your chosen Column Type"

I have a matrix field which is used a my main Body content field. The site has just been updated to the latest version of Craft and I tried to add a block to the matrix field but when i try to save it ...
mmc501's user avatar
  • 1,779
1 vote
2 answers
2k views

Setting unknown property: craft\models\Update::packageName

I am taking over a Craft website for a client. It is currently working fine on the hosting environment. I have pulled the website down locally from the hosting environment - the exact same files and ...
mmc501's user avatar
  • 1,779
3 votes
1 answer
636 views

How to duplicate entries and loop them without getting a Twig or deprecation error?

I'm trying to duplicate entries inside a macro, which will displays duplicated items inside a carousel. It's not possible to merge Element Queries. Even if it's possible to merge IDs, merging an ...
Romain Poirier's user avatar
1 vote
1 answer
246 views

Craft admin twig templates broken somehow

I am a front end designer building my site locally. This is the first time I've built in Craft and things have been coming along fine but now I'm getting the following error on every craft admin page ...
Jana's user avatar
  • 21
1 vote
1 answer
2k views

Error sending email: Process could not be started [The system cannot find the path specified. craft cms

I'm testing my email and I'm seeing the following error in the web logs: "Error sending email: Process could not be started [The system cannot find the path specified. craft cms" Does anyone know ...
jerry's user avatar
  • 21
1 vote
1 answer
549 views

Bad Request: Post Request Required when saving hyperlink in specific redactor field

I'm having a strange issue here. I have a site running Craft 3.3.7. I have an entry with a matrix field with several redactor fields in it. In one of those redactor fields, I have a paragraph of text. ...
Josh Parylak's user avatar
1 vote
2 answers
3k views

HTTP 503 – Service Unavailable error

I've cloned a Craft 3 repo that was created by another developer and I'm trying to get it running on my local server but I get HTTP 503 – Service Unavailable – craft\web\...
Tyssen's user avatar
  • 609
0 votes
0 answers
140 views

Craft CMS Content has Disappeared?

My content within all of my pages has disappeared. The website is only displaying the header and footer on each page. When I try to restore the internal page to it's previous version to get the ...
Angie's user avatar
  • 1
1 vote
1 answer
628 views

Internal Server Error when adding new Fields

I was adding new fields to my Craft 3 install using the field manager plugin. Suddenly I am seeing a Internal Server Error when trying to access the admin area. The front end looks fine. Anyone know ...
Dan Lee's user avatar
  • 1,107
1 vote
1 answer
471 views

Deprecation Errors - How to Fix?

We are in development of our new site in Craft 3 and we are getting some deprecation errors. This is keeping us from using Craft Commerce for our ordering page. Any suggestions on how to fix this? ...
Sam Sumpter's user avatar
1 vote
1 answer
130 views

Can't access "settings"

I can access "settings" in the control panel. Getting these errors: Please help. yii\base\ErrorException: Undefined property: DOMElement::$tagName in /home/I/ingvildholmno/vendor/enshrined/svg-...
Paul Peters's user avatar
1 vote
1 answer
384 views

Can access admin page (now), but not any site pages...yii not found http execption

Have not accessed my local .test sites in a bit. I tried today. I am getting a series of errors. At first I could not access any page to include the admin page. I ran Composer update from the ...
Hellyar's user avatar
  • 911
1 vote
1 answer
488 views

devMode false, Internal Server Error

Wanted to test 404 error page on our beta site. Set devMode to "false" in general.php. When I do this and try to view inner pages on the website, we receive an "internal server error". All inner pages ...
BrianMc's user avatar
  • 71
1 vote
2 answers
1k views

Craft on WSL permissions error

For anyone installing install Craft on WSL (Windows Services for Linux)... WSL has enough traction with developers that I decided to take the dive, but I'm having trouble getting permissions straight ...
Jim's user avatar
  • 139
1 vote
1 answer
721 views

Class 'Craft' not found

I am new to PHP and trying to call reCaptcha API in CraftCMS. I have the following variable: $captcha = Craft::$app->getRequest()->getParam('g-recaptcha-response'); But I get the following ...
Amir's user avatar
  • 111
1 vote
1 answer
314 views

SSL now CP unknown errors

I have a Craft 3 site that's been running on a production server. Recently we switched over to https but this has caused issues in the CP (multiple 'An unknown error occurred' red flags, can't view ...
Dr_Codswallop's user avatar
1 vote
0 answers
380 views

An unknown error occurred message, only on live server

Please can anyone give me some pointers. Just logged into the backend on an older (but live) 3.0.26.1 project. CP is now flashing multiple 'an unknown error occurred' messages on every CP request. ...
Dr_Codswallop's user avatar

1
2 3 4 5