1

The previous install (3.0.34) was working fine until I ran the updater from the CP. The update failed with error (couldn't access web.config (IIS))

Now loading CP or front end displays the following error: Warning: require(C:...Craft\Projects\Untye/vendor/craftcms/cms/bootstrap/web.php): failed to open stream: No such file or directory in C:\Users\rickn\Documents\Craft\Projects\Untye\web\index.php on line 20

Fatal error: require(): Failed opening required 'C:...\Craft\Projects\Untye/vendor/craftcms/cms/bootstrap/web.php' (include_path='.;C:\php\pear') in C:...Craft\Projects\Untye\web\index.php on line 20

Is there a way to finish the install manually and keep the previous work and data?

{ "require": { "craftcms/cms": "3.0.35", "vlucas/phpdotenv": "^2.4.0", "craftcms/redactor": "^2.1", "craftcms/mailgun": "^1.3", "craftcms/contact-form": "^2.2", "indigoviking/liquid-letters": "^1.2", "lukeyouell/craft-contactformtemplates": "1.0.1", "doublesecretagency/craft-bootstrap": "4.1.1.2", "fatfish/navigation": "1.0.7", "superbig/craft3-templateselect": "^2.0", "craftcms/ckeditor": "1.0.0-beta.2", "verbb/navigation": "^1.0", "enupal/slider": "1.2.2", "studioespresso/craft-dumper": "^1.3", "topshelfcraft/wordsmith": "^3.0", "craftcms/craft": "^1.0" }, "autoload": { "psr-4": { "modules\": "modules/" } }, "config": { "optimize-autoloader": true, "platform": { "php": "7.0" } }, "scripts": { "post-root-package-install": [ "@php -r \"file_exists('.env') || copy('.env.example', '.env');\"" ] } }

  • If you have ssh access, try running composer update. – Indigo Viking Dec 12 '18 at 23:22
  • Thanks. Then I get - The requested package craftcms/cms (locked at 3.0.34, required as 3.0.35) is satisfiable by craftcms/cms[3.0.34] but these conflict with your requirements or minimum-stability. – Rick Dec 12 '18 at 23:32
  • Update your composer.json line that says 3.0.34 to 3.0.45 – Indigo Viking Dec 12 '18 at 23:34
  • Still getting the original error in the question However this time composer returned Warning: Ambiguous class resolution, "modules\Module" was found in both "$baseDir . '/modules/Module.php" and "C:/...vendor/craftcms/craft/modules\Module.php", the first will be used. – Rick Dec 12 '18 at 23:52
1

Try running composer update Via the command line while in ssh

Or download the latest Craft files and replace your files. Mainly vendor/craftcms it looks like.

Edit:

Update composer.json to this and try running composer update again.

{
  "require": {
    "craftcms/cms": "^3.0.35",
    "vlucas/phpdotenv": "^2.4.0",
    "craftcms/redactor": "^2.1",
    "craftcms/mailgun": "^1.3",
    "craftcms/contact-form": "^2.2",
    "indigoviking/liquid-letters": "^1.2",
    "lukeyouell/craft-contactformtemplates": "1.0.1",
    "doublesecretagency/craft-bootstrap": "4.1.1.2",
    "fatfish/navigation": "1.0.7",
    "superbig/craft3-templateselect": "^2.0",
    "craftcms/ckeditor": "1.0.0-beta.2",
    "verbb/navigation": "^1.0",
    "enupal/slider": "1.2.2",
    "studioespresso/craft-dumper": "^1.3",
    "topshelfcraft/wordsmith": "^3.0"
  },
  "autoload": {
    "psr-4": {
      "modules\\": "modules/"
    }
  },
  "config": {
    "optimize-autoloader": true,
    "platform": {
      "php": "7.0"
    }
  },
  "scripts": {
    "post-root-package-install": [
      "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
    ]
  }
}
  • Replacing vendor/craftcms I then get yii\base\ErrorException: include(C:\...\Craft\Projects\Untye\vendor\composer/../craftcms/redactor/src/Field.php): failed to open stream: No such file or directory in C:\...\Craft\Projects\Untye\vendor\composer\ClassLoader.phpyii – Rick Dec 12 '18 at 23:41
  • Can you add your composer file to your question? – Indigo Viking Dec 13 '18 at 1:04
  • Added in the composer.json code – Rick Dec 13 '18 at 2:27
  • Updated the json. give that a shot. – Indigo Viking Dec 13 '18 at 2:32
  • Thanks, get C:\Users\rickn\Documents\Craft\Projects\Untye> composer require craftcms/craft Using version ^1.0 for craftcms/craft ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Nothing to install or update Generating optimized autoload files Warning: Ambiguous class resolution, "modules\Module" was found in both "$baseDir . '/modules/Module.php" and "C:/Users/rickn/Documents/Craft/Projects/Untye/vendor/craftcms/craft/modules\Module.php", the first will be used. And no change to original error – Rick Dec 13 '18 at 2:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.