0

I am trying to get Craft running on the Digital Ocean/ Serverpilot combination I've seen recommended here. Serverpilot is installed on the droplet and running fine. I created an app, uploaded the most recent version of Craft and unzipped it on the server. I renamed htaccess to .htaccess and put the db credentials in db.php.

I get a white screen on example.com and example.com/admin.
So I tried the alternate URLs recommended in Crafts installation guide, still white screen.

I also tried playing around with the omitScriptNameInUrls setting. No luck.

I also tried adding RewriteBase / to my .htaccess file.

I get this in the Apache access log: 82.156.127.145 - - [03/Mar/2016:01:45:59 -0500] "GET /admin HTTP/1.0" 500 - 82.156.127.145 - - [03/Mar/2016:01:46:00 -0500] "GET /admin HTTP/1.0" 500 -

This is in the Nginx access log: 82.156.127.145 - - [03/Mar/2016:01:46:00 -0500] "GET /admin HTTP/1.1" 500 0 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_3) AppleWebKit/601.4.4 (KHTML, like Gecko) Version/9.0.3 Safari/601.4.4" "-" 1072 0.014 "0" "0.014" "museumrotterdam.nl"

This is in the PHP access log: 82.156.127.145 - [03/Mar/2016:01:45:59 -0500] "GET /index.php?p=admin" 500 0 - 14106 17679 0.013 3407872 154.23% 0.00% "/admin" 82.156.127.145 - [03/Mar/2016:01:46:00 -0500] "GET /index.php?p=admin" 500 0 - 14106 17679 0.012 3407872 82.35% 0.00% "/admin"

There's nothing in the server's error logs.

When I add 'devMode' => true, to the config Craft does not log any errors.

What else could I try?

  • Anything useful in your web server's errors logs? Or if you enable devMode in Craft's logs? – Brad Bell Mar 3 '16 at 6:41
  • I see a 500 error in the logs when trying to access /admin – Florian Mar 3 '16 at 6:42
  • Craft's logs or your web servers? Regardless, what's the error message being logged? – Brad Bell Mar 3 '16 at 6:43
  • Hrm... nothing in the Apache (or nginx) error logs (not the access log)? – Brad Bell Mar 3 '16 at 7:00
  • Nope, white as the driven snow. – Florian Mar 3 '16 at 7:01
3

Whenever I've had a completely white screen from Craft I've traced it to a syntax error in one of the files in craft/config, so I'd double-check your db.php and general.php if they've been edited.

|improve this answer|||||
  • 1
    I had looked at these files again and again, the syntax seemed completely correct. Until I noticed a single ' in my randomly generated database-password. Sigh. – Florian Mar 3 '16 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.