2

I was developing a site on my server. Craft was living at ~/mysite.com/craft/, the webroot was ~/mysite.com/www/, and the URL was dev.mysite.com.

Now I want to deploy the site to www.mysite.com, but the host (HostGator) requires that the hosting account's primary domain (www.mysite.com) point to ~/public_html/. Ok, fine. First, I changed the dev subdomain to point to ~/public_html/ instead of to ~/mysite.com/www/. Then I moved the index.php and .htaccess from ~/mysite.com/www/ to ~/public_html/ and updated the $craftPath variable to point to the proper directory, but now all I get is blank white pages, both on the frontend and the admin.

I deleted everything under the craft/storage/runtime/cache/ and craft/storage/runtime/logs/ directories, opened up an incognito Chrome window, and pointed it at dev.mysite.com/admin (which is now pointing and .htaccess-requesting ~/public_html/index.php?p=admin, I believe...). I get redirected to dev.mysite.com/admin/login, but still end up with only a blank white page there.

The only [error] appearing in the log file is related to testPathInfo:

2016/06/08 21:52:06 [error] [application] Unable to determine if PATH_INFO is enabled on the server: [curl] 6: Couldn't resolve host 'dev.mysite.com' [url] http://dev.mysite.com/index.php/testPathInfo

Halp?

  • If you enable devMode, do you get an error message instead of a blank, white page? – Brad Bell Jun 10 '16 at 19:15
  • This is with devMode... :-/ – Sandwich Jun 12 '16 at 18:56
  • If you can't get it sorted and want to send some credentials over to support@craftcms.com, we can take a stab at it from there and update here with any resolution. – Brad Bell Jun 18 '16 at 0:00
3

Not sure the underlying cause, but clearing the craft/storage/runtime/cache folder that both sites shared caused both sites to start working as expected.

| improve this answer | |
  • Your folder clearing skills are clearly superior to mine. ;) Thanks, Brad! – Sandwich Jun 20 '16 at 10:54
  • 1
    I've got a college degree in clearing folders! – Brad Bell Jun 20 '16 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.