5

I have tried everything to install Craft on my server, and I have not been able to do it. I have done this a few times before without any issues, but since version 2.3 was released, I can't access the admin panel to start the installation.

I have followed all the steps in the documentation, I have created new DB, new domains.... nothing! I get a 500 error every time I want to access the admin area.

What am I missing?


2014/12/15 19:21:19 [error] [exception.Craft\HttpException.404] exception     'Craft\HttpException' in       /home/content/33/10789233/html/links/craft/app/etc/web/WebApp.php:737
Stack trace:
#0 /home/content/33/10789233/html/links/craft/app/etc/web/WebApp.php(176): Craft\WebApp->_processInstallRequest()
#1 /home/content/33/10789233/html/links/craft/app/framework/base/CApplication.php(180): Craft\WebApp->processRequest()
#2 /home/content/33/10789233/html/links/craft/app/index.php(62): CApplication->run()
#3 /home/content/33/10789233/html/links/public/index.php(19):      require_once('/home/content/3...')
#4 {main}
REQUEST_URI=/
---
2014/12/15 19:21:19 [error] [application] 
2014/12/15 19:21:21 [error] [application] Unable to determine if a script name         redirect is in place on the server: Server error response
[status code] 500
[reason phrase] Internal Server Error
[url] http://website.com/testScriptNameRedirect

  • Is is a Craft styled 500 or an Apache styled one? If it's Craft and you check your craft/storage/runtime/logs files for [error], you can see what the underlying error message is. – Brad Bell Dec 15 '14 at 19:06
  • Apache styled one – Ricardo Henriquez Dec 15 '14 at 19:07
  • If you have a craft/storage/runtime/logs/phperrors.log file, the error might be in there. If not, you'll want to check your Apache error logs. – Brad Bell Dec 15 '14 at 19:09
  • Take a look at the error log in the original question – Ricardo Henriquez Dec 15 '14 at 19:28
  • Try setting buildwithcraft.com/docs/config-settings#omitScriptNameInUrls to true or false (instead of the default auto). – Brad Bell Dec 15 '14 at 22:24
14

I might be shooting in the sky, but make sure that in your in your .htaccess you have

RewriteBase /

after

RewriteEngine On

4

In case it helps someone, my issue was the permissions for the root index.php file...It was 666 (writeable by group) and when I switched that file permissions to 644, the installation was able to move forward.

  • This works in certain situations. – Ben Croker Jun 25 '18 at 13:47
1

I had the same problems after updates by a provider. The solution was add a setting called overridePhpSessionLocation and set it to auto. https://docs.craftcms.com/v2/config-settings.html#general

1

I had this error, except this solution didn't help. Did some digging and managed to fix using method below:

My setup: CRAFT CMS 3, WINDOWS, MAMP PRO 4.

In your craft folder you can find the error.

craft > storage > logs > web.log

cURL error 60 SSL certificate problem: unable to get local issuer certificate

Go to https://curl.haxx.se/docs/caextract.html and download cacert.pem

Edit MAMP PRO php ini file (file > edit template > php > current version your using

add this to the php.ini file

;;;;;;;
;CURL
;;;;;;;
curl.cainfo = "x:PATH TO YOUR FILE\WHERE YOU SAVED IT\cacert.pem"

Has to be an absolute file path.

Save, close and reload your server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.