2

Recently moved site to a new server.

Attempting to edit a post created before migration fails. The edit page reloads with the changes removed. Note: 1) this happens for only SOME, but not ALL of entries in the same channel. 2) the entries that fail and those that succeed are set to use the same templates.

Utilities - Logs shows this error message:

Level error

Category exception.Craft\HttpException.404

Message Craft\HttpException in /home/method/craft/app/controllers/TemplatesController.php:72

6
  • So you're getting a 404 when saving an entry, but it only happens on some entries in a particular section?
    – Brad Bell
    Commented Aug 22, 2017 at 19:00
  • Well, I don't ever see a 404...the entry page just refreshes. The log is what shows the 404. And yes, only some entries have this problem. Other ones act normally. I have only seen it in one section, but I haven't tested entry after entry in each one to try to find additional problems.
    – user7150
    Commented Aug 22, 2017 at 19:27
  • Note that the published entry can be viewed on the web. Craft is blocking me from editing it.
    – user7150
    Commented Aug 22, 2017 at 19:34
  • Do you have anything like Suhosin or mod_security installed on that box by chance?
    – Brad Bell
    Commented Aug 22, 2017 at 20:21
  • That's it. mod_security is on by default and a rule is getting triggered. Turned it off and now the entry can be modified and saved. Thank you Brad!
    – user7150
    Commented Aug 23, 2017 at 0:43

1 Answer 1

2

That's it. mod_security is on by default and a rule is getting triggered. Turned it off and now the entry can be modified and saved. Thank you Brad!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.