1

I tried to install "Field Manager" Plugin and get following error:

symfony/console v3.4.4 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.2.1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement.

Theres is no config.platform.php anywhere and i have PHP 7.2.1 installed. How can i fix that?

EDIT: Ok, config.platform.php refers to composer.json entry. I changed it to 7.2 and could install it via command line. Possibly worked via CP too.

0

Usually when you see that error, Craft was composer install/update'd on one environment with say, PHP 7.2. Composer then pulls in the highest supported dependencies for that environment.

The composer.lock file is pushed to a different environment with say, PHP 7.1, creating a conflict the next time Composer needs to run.

You can do this to force Composer to use the lowest common denominator for all of your environments: https://github.com/craftcms/craft/blob/master/composer.json#L34-L36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.