0

I'm trying to upgrade an Craft site from 1.3 to 2.3 and have gotten into a broken state.

The update button failed, so I tried a manual update. This noted that I needed at least version 2.1, which I then downloaded and tried. It throws the following error and reverts:

CDbCommand failed to execute the SQL statement: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'edition' in 'field list'

When I revert back to 1.3 the admin screen is now blank.

The relevant versions/schema info:

  • Version: 1.3, Build: 2486, Schema: 1.3.15 (blank login)
  • Version: 2.1, Build: 2570, Schema: 2.1.2 (SQL error)
  • Version: 2.3, Craft Build: 2635, Schema: 2.3.4 (desired version)

The craft_info table shows that I'm running 1.3. The site is up, but I can't access the backend.

Any help greatly appreciated!

0

In between borked update attempts, are you restoring the database to the pre-update state? By default, Craft will create a database backup and place it in the craft/storage/backups folder during an update that you can use.

If you look at your craft/storage/runtime/logs files you'll be able to 1) see the error that originally happened to cause the failed update and 2) see the error that's preventing the CP from loading.

  • Thanks Brad, I managed to get one of the old SQL files to work, then the auto-update did two separate upgrades and everything is groovy. – Judd Lyon Feb 23 '15 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.