1

I tried to upgrade a website that I have to the latest version 2.6.2930 from an older 2.6.2804 and for an unknown reason the upgrade failed. I couldn't log in the administration area but the front end was working.

Now I tried to roll back to an old backup that I had 20 days ago. So I restored mysql database askitis.gr_160813_184933_v2.6.2804.sql and I uploaded only the folder /craft/app from the older version of craft Craft-2.6.2804

Now when I get to the website administration panel I get the button to finish up the installation like I'm updating the website. Any ideas what's going on? According to everything I read in order to roll back you need the db and files to be of the same version. I check the craft_info and this is the case

2

Delete your craft/storage/runtime/cache and craft/storage/runtime/compiled_templates folder after doing this manual update.

Otherwise Craft still references the (now renamed) Garnish Javascript, and the UI for the AdminCP is not functional.

  • Probably that was the problem because the java scrips and the graphic interface wasn't working although i tried to clear the cache of the browser. But now I got another problem... I'm not getting /admin/ screen to load and I get HTTP ERROR 500 with devmode this: Fatal error: Call to a member function getTimeFormat() on null in /home/askitis/craft/app/etc/requirements/RequirementsChecker.php on line 103 – Dimitrios Vogiatzis Sep 5 '16 at 7:21
1

I found the source of the problem.

I had 2 custom locales and when I uploaded the new files for the manual update and I didn’t include those 2 locales.

When I copied those 2 files in the folder app/framework/i18n/data everything worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.