1

I haven't set any kind of character limit on my Redactor fields, but when I save a longer body of text, is always cuts it off at 252 characters. See screenshots:

Before save: Before save After save: After save

Here is my Redactor config:

{"buttons":["format","bold","italic","lists","link"],"plugins":["customstyles"],"formatting":["p","h3","h4","blockquote"],"linkNewTab":true,"toolbarFixed":true,"customStyles":{"style":{"dropdown":{"sourceCitation":{"args":"cite"},"strikethrough":{"args":"del"},"superscript":{"args":"sup"},"subscript":{"args":"sub"}}},"clearStyles":{"api":"module.inline.clearformat"}}}

EDIT: I have also noticed that if I save it with one spare character remaining, the WYSIWYG is inserting a symbol on save to fill the last spot?! Compare the previous screenshot with the next one and you'll notice i've just knocked off the final 't' and the space has been filled with a random symbol. This is sometimes an ampersand.

After save minus the last character: Added symbol at the end

Note that this is only happening on a production site and not locally.

1

The cause of this ended up being that the field_introduction column for the Redactor field in the craft_content table was set to varchar(255), which means it can only hold 255 characters.

No idea how it got that way. The Redactor field (under its advanced settings) has never had an option to be varchar(255), only text and mediumtext.

Regardless, going through all of the Redactor field settings and re-saving them correct adjusted the column data type back to text and resolved the issue.

| improve this answer | |
  • Thanks for the assist, Brad. – Jay May 29 '19 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.