2

How can I make the Redactor toolbar to not affix to the top of my viewport? I tried to modify the config files, but I had no luck!

  • I have the same issue. My config.json look like this { "buttons": ["format","bold","italic","lists","link","file","horizontalrule"], "plugins": ["source","fullscreen","pagebreak"], toolbarFixed: false } but the panel remains fixed. I'm running the latest version v2.6.3008 – Mark H. Feb 13 '18 at 23:05
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question. - From Review – Robin Schambach Feb 14 '18 at 17:30
3

The toolbar is now set to be fixed by default, even if you don't have that setting in your Redactor config file at all (this applies to all Craft installs before version 2.0.2527).

To make it scroll with you page again, edit you config file in craft/config/redactor/[config name].json and set or modify the following property to:

toolbarFixed: false

(This is not a typo! The property name changed from toolbarFixedBox to toolbarFixed with Redactor 10 / Craft 2.3. Craft's default configs will be updated with the next release got updated with today's release. Thanks to Brandon for the support!!)

| improve this answer | |
  • I added toolbarFixed: false to the .json file but it doesn't seem to be working. Running Craft 2.6.3012 – fodney Apr 19 '18 at 16:47
  • @fodney this is a very old answer, there was a bugs in latest Craft releases with the toolbar fixing, you might want to check out the issues on GitHub. – carlcs Apr 20 '18 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.