0

I'm very lost with the gateway. It seems that Authorize.net is highly supported with Craft Commerce but the gateway isn't working. I had the dummy gateway working perfectly fine so that when I'd go through the whole processes and the order would show up. I put in authorize.net AIM as a new gateway and now when I get to the payment it does nothing at all. I put in this code

{% if craft.config.devMode and (craft.session.hasFlash('notice') or craft.session.hasFlash('error')) %}

  {% set noticeFlash = craft.session.getFlash('notice')|join('|') %}
  {% set errorFlash = craft.session.getFlash('error')|join('|') %}

    Notice: [{{  noticeFlash }}]
    Error: [{{  errorFlash }}]

 {% endif %}

and I get back

Error: [Payment method does not exist or is not allowed.]

I've put in the API user and key and the link at the bottom. Am I supposed to set the gateway as default somewhere?

1

That error is from the cart service when trying to set the payment method ID on the cart during payment.

There are 2 possible reasons the error would appear:

1) The payment ID you are submitting is wrong

<input type="hidden" name="paymentMethodId" value="theIDhere"/>

2) In the settings (for a correctly submitted payment ID), the "Enabled to select on front-end" setting has been turned off. Screenshot: http://jmp.sh/AxoM1tI You need this on, to allow customers to use the method on checkout.

Hope that helps.

1
  • Oh, looks like we were typing at the same time. I JUST figured this out and thought I'd share. Thanks for the answer though!! – Darryl Hardin Aug 17 '17 at 4:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.