I've created all my Assets fields with 'Same as Source' selected in 'Target Locale'. When I create an entry in language A, all field content is copied over apart from the assets selections into language B/C/D.

If I change this and select a set Locale in 'Target Locale' what actually happens? (e.g. If I select language A, will it copy that asset into lang B/C/D's entry and can it be changed/updated by an admin who only has access to B?)

P.S. In this situation, all assets are remote on S3.


1 Answer 1


The "Target Locale" setting under the Asset field's settings is referring to which locale do you want to select assets in. When it's set to "Same as source", then, for example, if you're viewing an entry in German, the Asset selector modal will only display Assets assigned to the German locale. And if you were viewing the entry in Dutch, it would only show Assets assigned to the Dutch locale.

If you change the "Target Locale" from "Same as Source" to a specific local (i.e. German), then no matter what local you're viewing an entry in, only Assets assigned to the German locale would show.

When saving a new entry in locale 1, Craft "copies" content data (anything stored in the craft_content table in the database) over to the other locales for fields marked as translatable as a starting point for the other locales. All relational fields (Assets, Entries, Users, etc.) aren't "content" and they are stored in the craft_relations table and Craft currently doesn't copy that information over.

Ironically, if you uncheck the "This field is translatable?" checkbox in the Asset field settings, it would show up on the other locales, because in that context the Assets aren't stored on a per-locale basis.

  • OK, I just created a new category, in a group that had an assets and a text field. The assets field was set to 'Same as Source', but also set to Translatable. The text field was copied, the Asset field was not. If I set it to 'not translatable' I could see the Asset data just fine. (as expected!) These are S3 Assets btw!
    – Rob Hodges
    Jan 25, 2016 at 23:29
  • Updated the answer.
    – Brad Bell
    Jan 26, 2016 at 0:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.