Questions tagged [multi-site]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
16 views

Craft 3, Multi site setup - Update title for entry 1 site only

My setup: Craft 3 installation with a multi-site setup. 3 languages, all enabled. I have a custom plugin with a custom element type, FooBar that extends the Element class and a custom FooBar field ...
1 vote
1 answer
46 views

How to set up webhooks individually for each site in multi-site configuration with many customers?

The current issue is that I have multi-site setup, where are many different sites in a single Craft instance, e.g., I have 10 websites from 10 customers, when one customer updates his website I want ...
0 votes
1 answer
7 views

Sprout Reports settings template no longer functioning

I'm returning to a Sprout report on a project that was idle for a few years due to Covid. I was puzzled as to why both my settings and report templates were yielding nothing. The only change in the ...
  • 608
0 votes
0 answers
55 views

@web alias in multisite setup with different domains

We're working a multisite project where the individual sites have different domains. We want to have a simple setup where both sites share an asset folder (web/cms-assets). So far, we're looking at ...
  • 6,925
0 votes
0 answers
16 views

How to create an entry translated to multiple website in single save?

I'm creating a new entry from fetching values from existing entry. I have got all revision of existing entry in array. while creating a new entry with existing values I cant able to replicate the ...
0 votes
0 answers
15 views

Get previous site siteGroup

Is there a way to get the siteGroup of the previous url? I have a multiSite/multilanguage project. I want to be able to check the previous Url siteGroup and compare it with the current siteGroup
1 vote
1 answer
22 views

How to set environment variables based site

I've got a multiple sites setup in Craft, with Craft Commerce running on top. What I need to do is for one of the Payment Gateways, send a different API Key, based on the site that's being accessed. ...
  • 403
1 vote
1 answer
29 views

Is there a way to trigger a user account creation from a different CMS?

I'm a junior web developer working with Craft CMS. I was wondering if there was a way to trigger a controller I have for my Craft CMS from an outside CMS. We have more than one website that offers ...
2 votes
1 answer
28 views

Craft multi-site enable password protection

I have a multi-site Craft CMS set up with 6 sites. I am planning to live only 5 sites and I need to keep the 1 site in development phase. Also I want to enable fron-end password protection for the dev ...
  • 61
0 votes
0 answers
10 views

Behaviour of Social Poster in a multisite setup

A webdeveloper made us one new Craft multisite for 8 schools and added Social Poster. It is entirely unclear to me what will happen when we add the 8 Facebook pages as accounts to Social Poster and ...
0 votes
1 answer
37 views

Get the localized handle and slug for "current" section for constructing breadcrumbs

I'm trying to contruct breadcrumbs for entries under a specific section. This feels like such a "how-hard-could-it-possibly-be" type of question, but I've been at this for a lot more time ...
1 vote
2 answers
78 views

Globals disappeared/Queue Failed — Propagating global sets

In desperate need of some help! I noticed on one of my multi-sites, 5 out of 8 sites have items missing in the Globals sidebar.. When I manually type in the URL to view one of the global items I get: ...
  • 109
0 votes
0 answers
65 views

How to keep logged in User on 1 Craft Multi Site, but with different domains

I have one multisite craft installation, where the different languages for the sites use different domains: en -> domain.com de -> otherdomain.com .. Users can log in via frontend. Now if users ...
  • 319
1 vote
1 answer
133 views

user session for Multi Site

I have a multi-site and they are under 1 root domain and the default site is food.com and bread.food.com is the additional site. How can I share the user session data of food.com to bread.food.com. My ...
1 vote
1 answer
80 views

Moving a site to a new group

Got a question regarding site groups and more specifically about the possible data loss. Scenario is as follows: I have a site A and site B in the same group. Client now wants both sites available in ...
0 votes
0 answers
25 views

Unique uid across sites?

Are entries' uids unique across all sites in a multi-site setup? I use Craft CMS 3.7. I couldn't find anything about this question in the docs. Many thanks Christian
1 vote
0 answers
44 views

How to change the primary site on a multi-site setup?

We have a multisite setup. We're wanting to use the same codebase, but deploy to two different servers with some of the sites on server 1 and the rest on server 2. For example: Server 1 Site 1 [...
1 vote
1 answer
146 views

On a Craft 3 multi-site, how can I setup an Entries field to select entries from other sites?

On my primary site on a Craft 3 multi-site, I have an Entries field used to add links to other sites' entries. These entries are from Channels / Stuctures that are using the Only save entries to the ...
1 vote
1 answer
35 views

Wrong default site

I want to use the recaptcha plugin but I get a JS error because the script is looking at the wrong site. The plugin is using scoreRequest.open("POST", "/{{ craft.app.config.general....
1 vote
2 answers
43 views

Supertable bilingual (multi-site)

I want to save a supertable with different infos on two different siteId of an entry. It works fine with all the other fields i'm using: the value is saved separately to each different language. But ...
1 vote
1 answer
35 views

Block access to /admin on secondary sites

I'm not clear on how to block access to the control panel at: secondDomain.com/admin secondDomain.com/admin/login I can use .htaccess or Craft's config.php. I want folks to get an ugly 'access denied' ...
  • 608
0 votes
0 answers
140 views

Locale URL /en not working - No such file or directory (/public)

Some values have been anonimized and are marked with %value% I followed the steps for setting up a local Craft CMS using composer and have the default site running on %domain%.test. Now I've made a ...
1 vote
0 answers
38 views

Non-admin users cannot preview/view entries when site front end is disabled (multisite)

I am running a multisite setup on 3.6.11.2. We are attempting to generate a new site and while we work on the structure/content I have the 'Enable on the front end' setting switched off. As an admin, ...
1 vote
1 answer
63 views

How to add tags to an entry per site basis. And then only get the tags for that site in the frontend

I have craft pro and have one tagGroup called Tags Then I created a Tag field called newsTag like this: When I add a tag for german, the tag is also created in the database for dutch and english, so ...
1 vote
1 answer
76 views

GraphQL mutation or query, how to target specific site?

Is there a restriction on graphQL that only allows it to work on the primary site? My system has for unknown reason switched primary (and I can't change it back due to a bug), and ever since then my ...
  • 213
0 votes
0 answers
60 views

Entry URLs are not returning URL with locale in the path

I set up 2 sites (locally) running Craft 3.6.7: English (Handle: english, Base URL: '/en/') German (Handle: german, Base URL: '/de/') I've made a blog section that is enabled for both languages with ...
  • 1
1 vote
0 answers
104 views

Eager load entries from another site in a Matrix block

I'm having trouble to get Eager Loading to work with an entries field that can select entries from another site in a multi-site setup. We're using a Matrix content-builder setup. Different kinds of ...
  • 51
1 vote
1 answer
98 views

How do you insert the site name into a default asset path?

Multisite question.... how do I output the site into the assets path? currentSite won't work because its the admin panel, so the current site is always the default site. Using the below, I will always ...
1 vote
1 answer
39 views

Editing entries on multisite Craft CMS implementation

We have a Craft CMS implementation with 3 sites enabled (multi-site). When I create an entry, it populates the entry to all 3 sites, which is fine. However, I would like to modify a link or content ...
  • 11
1 vote
1 answer
42 views

Swapping currency when swapping languages

Folks: I have a multilingual and multicurrency site. All works fine when switching currencies or languages independent of one another. But is there a way to have the currency switch when the language ...
  • 471
2 votes
0 answers
76 views

Manipulating globals for multi-site?

I'm working on one Craft project with two sites (which have one shared page that is translated and possibly more in the future.) Is there a way to make the global header & footer for Site 2 ...
  • 21
1 vote
1 answer
318 views

Multi Site Multi Domain

Probably this one is repeated, but I couldn't find an answer for it yet. I have a multi-site in Craft CMS 3.15, one that is in English and another one in Japanese. So the English page, which is the ...
1 vote
1 answer
281 views

Maintaining and deploying many multi-site from a single codebase

We're developing an application that uses a multi-site Craft back-end with a JS front-end, making use of GraphQL. The intention is to maintain a single codebase that can be used to deploy new and ...
  • 571
1 vote
1 answer
142 views

Do the number of Sites in a Multi-Site have a practical limit?

My use case is creating microsites for hundreds to thousands of customers, allowing them to edit/create their own site. Currently it is set up with channels with auto-created entries for users and no ...
  • 13
1 vote
1 answer
120 views

Generate transforms only working on default install (multi-site)

I have a multi-site setup running within Craft 3. Everything seems to be working nicely, except for image transforms. For example: The following transform on the default site works correctly: https://...
1 vote
1 answer
41 views

Translate icon appears but no translations exist

I have a site in development that i replicated from another project. The other project was multi lingual and had some fields that were translated. This new site does not require any translations but ...
  • 1,900
1 vote
1 answer
166 views

How can I set an alias dynamically based on request?

I have a multi-domain setup where I run multiple one-pager sites from different domains. For development purposes, I have configured it to work like this: dev has: http://localhost/www.domain1.com ...
  • 213
1 vote
2 answers
251 views

How to temporarily disable entries of one site version within a site group?

A client asked me to temporarily disabled all of its entries of one of its Site in a specific language. This entries should not be accessible anymore from their URL. The quickest and cleanest way to ...
0 votes
1 answer
78 views

Inconsistent search results in multi-site setup (prod/stage)

I have set up a staging site alongside production just like the docs describe (Craft Solo 3.4.24). I have copied the "Site Settings" for all sections and set the "Propagation Method&...
1 vote
1 answer
178 views

How can I configure multi-site base URLs where the subdomains are static but the domain name is dynamic?

For example, let's say I have two sites: abc.example.com and xyz.example.com but I want to also host test versions of those sites at example-test.com. It'd be nice if I could set the baseURLs to http:/...
1 vote
1 answer
55 views

Can slug and title changes be propagated to multiple sites?

I'm noticing that if I change the title or the slug of an entry after creation, that change isn't propagated to my other Craft sites. Is there a way to propagate title and slug like other fields?
  • 155
0 votes
1 answer
124 views

Accessing global field values in site loop

I have a drop down select that I am populating with sites. I've added a lightswitch field (handle 'showInDropDown') to the global set 'siteInfo' with the hope of getting the lightswitch value per site ...
  • 1,900
0 votes
0 answers
240 views

Multisite with unique domains not working with Forge config

I have a live install with a primary domain of https://marketing.vessul.co/ which works great. When I've added another site to this install and it's location is another folder such as /extra-site it ...
1 vote
1 answer
142 views

What is the best way of managing multisite propagation post setup phase?

I have a multisite setup with a pages section. In the future we want to add additional sites but there seem to be some caveats. When we first setup pages we set the section propagation to 'all other ...
  • 1,900
1 vote
1 answer
60 views

Multiple Site Manager Homepages and Fields

Apologies if this is a simple question :/ I'm using Multiple Site Manager for the first time and although I get it in principle i'm struggling to understand how to setup homepages. Here's what I ...
  • 1,173
0 votes
0 answers
71 views

At what point is siteId set for orders?

I have an adjuster I am trying to get to work, but the order has to come from a specific site in order for the adjuster to be applied. The siteId is 2, but when I try to get the siteId from the Order ...
1 vote
1 answer
198 views

Possible bug when using Entries fieldtype with multi-site

Thought I'd run this by some people who know what they're doing before I report this as a bug. I have a multi-site configuration. One of the sites has a base URL of example.com and only contains one ...
  • 283
2 votes
1 answer
205 views

Is it possible to localize Freeform fields and labels?

Is it possible to localize labels and other params of Freeform form fields on the multilingual site? Thanks
  • 83
1 vote
1 answer
303 views

Implement hreflang with multi sites

I currently have multi site config. One site have 2 locales. My configuration like so: 'example.com' => array( 'siteUrl' => array( 'us_en' => 'https://www.example.com/', '...
1 vote
1 answer
203 views

Craft multisite site without www redirects unwanted to default site

I'm working on a multisite Craft CMS 3 website. When I'll go to www.site-a.com (default) and www.site-b.com this works fine. The correct sites and templates are displayed. But if I'll go to site-b.com ...