Questions tagged [localization]

Locales and multi-lingual translations.

Filter by
Sorted by
Tagged with
0
votes
0answers
32 views

Locale URL /en not working - No such file or directory (/public)

Some values have been anonimized and are marked with %value% I followed the steps for setting up a local Craft CMS using composer and have the default site running on %domain%.test. Now I've made a ...
0
votes
0answers
9 views

Echo locale title in controller (craft cms 2)

I want to echo the translated title of an entry in the controller of a plugin. How can i acces the locale data?
1
vote
1answer
34 views

How to add tags to an entry per site basis. And then only get the tags for that site in the frontend

I have craft pro and have one tagGroup called Tags Then I created a Tag field called newsTag like this: When I add a tag for german, the tag is also created in the database for dutch and english, so ...
0
votes
0answers
37 views

Entry URLs are not returning URL with locale in the path

I set up 2 sites (locally) running Craft 3.6.7: English (Handle: english, Base URL: '/en/') German (Handle: german, Base URL: '/de/') I've made a blog section that is enabled for both languages with ...
1
vote
1answer
132 views

How to programmatically translate an entry in craft 3

I'm trying to write a plugin that translate entries programmatically based on subsites that have different language setup. Normally what happens is this: you setup multi-site, set each sub-site as ...
1
vote
1answer
31 views

How to directly access translated variables by language

I have a localized, two language site (en and fr) that I have a translated global variable set for. My question is: is there a way on a Craft 3 template to directly access a translation of a variable ...
0
votes
1answer
44 views

404 Page for Multi-lingual Page

For my multi-lingual-Page (de + en) I've made a 404.html-File in my templates-Folder with a language-changer for html-content-output like {% if craft.app.language == 'de-CH' %}<p>Hallo</p> ...
1
vote
1answer
22 views

Display field content inside a matrix from a different locale

I am building a site with 2 different languages - English and Chinese. Is it possible to retrieve only one field inside a matrix in English while I am in Chinese site? But the rest of the matrix ...
1
vote
1answer
37 views

How to translate a structure url

I'm working on a multilingual website where I have one structure called Products. Currently, this structure's URI format is configured like this: {parent.uri ?? section.handle}/{slug} Which returns ...
0
votes
0answers
14 views

Force default site for a specific page / entry

I have a site site.com that has a french and english version. On one page / in one template I'm using a plugin that breaks when the site is switched to the french version site.com/fr/ To get around ...
2
votes
1answer
146 views

Site url is not generated correctly when using environment variables

I'm working on a multi-site setup (for a localized website). In my .env file, I have defined a SITE_BASE_URL variable. Then, in the control panel, I set up each site's base url with that environment ...
0
votes
0answers
44 views

Add new translation app.php file in Craft

I'm trying to add a new language file in Craft Control Panel admin site. I have created app.php inside translations/vi folder like this: -my app folder |-- translations |----- vi |-------- app.php ...
1
vote
1answer
25 views

Admin panel not working without language code

I've migrated a website with CraftCms 2 from local to a pre-production server. Everything is working fine but, I don't know why, I only can go to the admin panel with locale code before /admin. I mean,...
1
vote
1answer
33 views

localized site - except home, every page gives me a 404

I have a newly published site, where the localization does not work properly. https://www.nomadenschaetze.com/de/ When i switch to english, it shows the right englisch homoepage. Now, when i click ...
2
votes
1answer
71 views

How to configure the system messages <link> url?

we have got a multisite environment and have imported users with different preferred languages (de and en). Therefore we made a module, cause the feedme plugin doens't set the preferred language https:...
1
vote
1answer
30 views

Craft 2 new locale and dealing with root-relative links

Hi I am adding new locale which is jp and I have a huge problem with href tag. Our paragraph field have href links using relative link like this: <a href="/page_a"> page a</a> ...
1
vote
1answer
26 views

Translate icon appears but no translations exist

I have a site in development that i replicated from another project. The other project was multi lingual and had some fields that were translated. This new site does not require any translations but ...
1
vote
1answer
128 views

Propagate entries manually between sites

I have a client that wants to setup a multilingual site, but for the purpose of this site they only want certain entries to be translated. If I setup sites that use a section which is configured to ...
1
vote
1answer
40 views

Update entry title for all sites

I'm working on a Craft project that has 3 sites. The content for one section is pulled from an API using a console script which runs every 5 minutes. This has been working fine but I've discovered a ...
0
votes
0answers
62 views

Upgrading to 3.5 break multisite

Just upgraded to Craft 3.5+ and now all my non-primary site's pages are not found. All my english page (primary site is in french) returns a "Template not found". So "en/anypage" ...
1
vote
0answers
23 views

Translation filter in Sprout Email plugin

I would like to make a notification of Sprout Email plugin bilingual. However, in the body field, the translation filter does not work. The tag of {{ fieldname.label|t }} is not translated. How is it ...
1
vote
1answer
25 views

Use locale not included in Craft

I have to develop a website under Craft CMS 2 and going to Locale Options I see I can add a language, but I need to use a language that is not included in the official codes for the representation of ...
1
vote
1answer
31 views

Using static translations for the primary site / site.php being ignored

I'm having trouble outputting static translations for the primary site, and only the primary site. Translations structure: translations en-US site.php site.php <?php return [ '...
1
vote
1answer
122 views

Localization Section propagation settings, and related entry field setting “Manage relations on a per-site basis”

Craft 3.4.20. Site is running multiple localizations Sections: Blog Post Propagation method set to, "Save entries to all sites enabled for this section" Blog Category (Structure entry with ...
1
vote
1answer
20 views

Channgel entry to disabled

Is it possible that when my user adds a new entry in a channel on the English site, it gets copied to the channel of my Belgian site, but this entry is set automatically to disabled? So my English ...
1
vote
1answer
23 views

Multilingual google problems

I’ve set up a multilingual craft site. My primary site is BE and base Url is set to / The two other ones are NL which base Url is set to /nl and LU which is set to /lu All the three website have en-US ...
2
votes
1answer
150 views

Is it possible to localize Freeform fields and labels?

Is it possible to localize labels and other params of Freeform form fields on the multilingual site? Thanks
1
vote
1answer
63 views

Feed Me import from CSV ignores decimal point

I use Feed Me to import values from a .csv file into my entries. Since a day i have an issue i can't explain. I didn't change anything. Precisely, the issue concerns a number field. In the .csv file, ...
1
vote
1answer
160 views

Implement hreflang with multi sites

I currently have multi site config. One site have 2 locales. My configuration like so: 'example.com' => array( 'siteUrl' => array( 'us_en' => 'https://www.example.com/', '...
1
vote
1answer
89 views

Get all URLs from a multisite installation

I have an multisite installation like this: www.example.com/animal www.example.uk/animal Each site has a configuration like so: 'example.com' => array( 'siteUrl' => array( ...
0
votes
0answers
17 views

Automatically replace strings in different language

We have sites for Germany and Switzerland that are pretty much identical but would like to cater to the spelling differences in Switzerland (namely replacing "ß" with "ss"). Is there any way to run ...
1
vote
1answer
23 views

Identifying users and site permissions when logged in

If I'm logged in as a user in user Group A, how can I tell which site I am currently viewing? I want to be able to create a multilingual site switcher. But my setup is complex. I have Company A, ...
1
vote
1answer
26 views

How to create a new site (locale: de-AT) based on another site (de) within same installation?

I manage a website with multiple languages. Each language has its own site and domain. Think: website.de and website.co.uk I have to add another site with different locale (de-AT) to the Craft CMS ...
0
votes
0answers
115 views

How can i get the current applied route in CraftCMS?

I'm using a dynamic route that loads a template. I'm on a multisite setup with a language switch in the header menu. To be able to switch between sites or languages, the dynamic routes need to have ...
1
vote
2answers
249 views

Static translations not working on Craft 3 since upgrade from Craft 2

I have upgraded from Craft2 to Craft3 and static translations no longer seem to work. I have created a folder at the same level as the "vendor" folder called "translations" and have got a folder ...
1
vote
1answer
283 views

Craft 3 doesn't translate static strings

I am making a website with Craft 3 and I have some static text that needs to be translated. I followed Craft's documentation on it. I created my translations/fr/site.php file and use the {{ 'String'|...
2
votes
1answer
75 views

Multisite, second language Live Preview not working

I have an English site - https://dev.mysite.com and a Japanese site - https://dev.mysite.com/jp. Live preview works great for the English site, but the Japanese site has the following error: Mixed ...
1
vote
1answer
65 views

How to host a huge website on Craft (10k pages, over a dozen languages, 2GB database)

We have what appears to be a very large website. We have a strong content strategy which has led us to develop a huge number of pages (over 10k) for our website, as well as building out a significant ...
1
vote
1answer
80 views

How to handle a big amount of whitelabel sites (with multi-site)

For one of our clients we need to setup a whitelabel template. I was considering doing this with Craft's Multi site feature which works fine in that way Content management wise. But, it's probably ...
2
votes
1answer
156 views

How to get current site (locale) api / plugin

For my form plugin I'm using a global set of fields. These can be set in 2 languages default and en. Problem is whenever I try to output them I cant dynamically make them use the current site locale/...
0
votes
0answers
24 views

Character Limit incorrect for international characters

I've been running into errors importing specific entries in my custom module. Boils down to an issue with the Character Limit on the Plain Text fieldtype when importing international characters. It ...
0
votes
0answers
214 views

Feed me - Trouble importing table and matrix with translation

I'm trying to import entries to a chanell using Feed me but having some issues with table and with some multilingual texte in a matrix field. Craft edition & version Craft Pro 3.3.2 Feed Me 4....
0
votes
0answers
30 views

Craft 3 Multi-site with no “default” site AND where control panel login route remains intact and additional directories not necessary

Maybe one of you can help me out? I've tried setting up a multi-language site with no "default site" as per Craft 3 Multi-site with no "default" site. So far so good, except the control ...
1
vote
1answer
34 views

Route to entry in Arabic not working but category route is OK

I have successfully managed to route Arabic categories to a custom template. The Arabic URLs appear RTL which is strange (and correct?), but I cannot get the Arabic single entry to pick up the ...
0
votes
0answers
386 views

URI is not a valid URI error after recent update

Has this old issue recurred in a very recent update: URI is not a valid URI Just a few weeks ago I imported Korean content using FeedMe just fine, I have a setting 'limitAutoSlugsToAscii' => false, ...
1
vote
0answers
29 views

Incomplete localization of `{{ entry.postDate.diff(now)|duration }}`

In a Dutch site, when I output {{ entry.postDate.diff(now)|duration }}, the result is something like 5 dagen, 3 uren, 43 minuten, and 42 seconden. Why is the English "and" not localized? My ...
0
votes
0answers
41 views

How can I sync slugs within sites in the same Group?

I have a Craft site with approx. 13 Sites. They are grouped by language, e.g. German has Germany and Austria in it. Spanish has Spain and Mexico in it. I imported all content to the main groups ...
1
vote
0answers
21 views

Locales with independent language and country

How might we use Craft to manage our locales, keeping our language and country logic independent? The desired scenario: No duplicate language entries: Spanish in Spain would be the same as Spanish in ...
2
votes
2answers
77 views

Mutiple sites and locales

I'm trying to setup alternate locales for content across several sites. I have the following scenario: - Group siteA - siteA.com/product-1 - Group siteB - siteB.com/product-2 - siteB.com/fr/...
1
vote
1answer
161 views

Entry form with field translated accross multiple sites

I've got 2 sites, each with a locale (dutch - nl & french - fr). I've set up a frontend entry form that works nicely for all not translated fields, I am however struggling to get it to accept ...

1
2 3 4 5
8