3

Just tried updating craft from version 2.4.2669 to the latest version 2.4.2702 unfortunately it threw a fatal error with the following error message:

Status: OK

Response:
Fatal error: Out of memory (allocated 33030144) (tried to allocate 41 bytes) in /homepages/3/d272256762/htdocs/crafttest/craft/app/framework/db/CDbCommand.php on line 518

So I then tried to manually install it by uploading the app folder. Clicked through on the update databases it started working, but again threw the same error.

The site is on a shared server so I can not do much regarding memory limits.

So now I have no CMS and no frontend what can I do to rectify this problem to either rollback to the previous version or update to the newer one?

2

How big is your database? It could be that Craft is failing to backup your database as part of the update process because it is running out of memory.

Try setting the backupDbOnUpdate config setting to false and running the update again.

  • That's likely it, though regardless of database size, the current memory_limit is 32M, so I'd bump that up regardless. Once you start any image processing (transforms, etc.) you'll hit the same error. – Brad Bell Nov 4 '15 at 16:15
  • Cheers @steverowling that worked a treat. Yes database is pretty large so obviously what was causing the issue. – Lettie Nov 4 '15 at 16:15
  • @bradbell good point would do this with a non-shared server unfortunately hands are tied on this one. But it's only a play around test site so not an issue! – Lettie Nov 4 '15 at 16:18
  • @Lettie Ahh, missed that part in your original post. My bad. – Brad Bell Nov 4 '15 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.