1

I'm trying to update to Craft 3.5 from 3.4.3 but running into this error message:

Composer output: Package "craftcms/vue-asset" listed for update is not installed. Ignoring.
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: remove tcb13/substringy 1.0.0
- Conclusion: don't install tcb13/substringy 1.0.0
- Conclusion: remove danielstjules/stringy 3.1.0
- Installation request for tcb13/substringy (locked at 1.0.0) -> satisfiable by tcb13/substringy[1.0.0].
- Installation request for craftcms/cms 3.5.5 -> satisfiable by craftcms/cms[3.5.5].
- Conclusion: don't install voku/stringy 6.3.1
- craftcms/cms 3.5.5 requires voku/stringy ^6.2.2 -> satisfiable by voku/stringy[6.3.1, 6.3.0, 6.2.2].
- don't install voku/stringy 6.3.0|don't install danielstjules/stringy 3.1.0
- don't install voku/stringy 6.2.2|don't install danielstjules/stringy 3.1.0
- tcb13/substringy 1.0.0 requires danielstjules/stringy ^3.1 -> satisfiable by danielstjules/stringy[3.1.0].
- Conclusion: don't install danielstjules/stringy 3.1.0|install voku/stringy 6.3.1

I've uninstalled a bunch of plugins but still running into the issue. Uninstalling anything else may be problematic, so is there any way I can track down where the conflict is occurring?

For reference, this is my composer.json:

{
  "require": {
    "craftcms/cms": "3.4.30",
    "craftcms/element-api": "2.6.0",
    "craftcms/redactor": "2.6.1",
    "doublesecretagency/craft-cpcss": "2.2.1",
    "elivz/craft-single-cat": "1.2.1",
    "ether/tags": "1.0.7",
    "jungleminds/nethooks": "1.1.2",
    "venveo/craft-bulkedit": "2.0.5",
    "verbb/cp-nav": "3.0.13.1",
    "verbb/image-resizer": "2.0.10",
    "verbb/super-table": "2.5.4",
    "vlucas/phpdotenv": "^2.4.0"
  },
  "autoload": {
    "psr-4": {
      "modules\\": "modules/"
    }
  },
  "config": {
    "sort-packages": true,
    "optimize-autoloader": true,
    "platform": {
      "php": "7.0"
    }
  },
  "scripts": {
    "post-root-package-install": [
      "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
    ]
  }
}
  • 1
    Was one of the plugins you uninstalled Wordsmith? The composer conflict looks like one they had when updating to 3.5: github.com/TopShelfCraft/Wordsmith/issues/… Maybe there are some lingering files left behind? You could nuke vendor folder and composer.lock file, run composer clear-cache and composer update to make sure you've got everything fresh and see if that helps. – Brad Bell Aug 19 at 23:10
  • Unfortunately not, as far as I'm aware this install has never used Wordsmith. Will give the cache clear a go, but is there any way to do that without CLI access (just a bit of a pain with this host, though not impossible). – theAdhocracy Aug 20 at 15:27
  • Unfortunately not. :( – Brad Bell Aug 20 at 23:53
  • Well looks like I'm a bit stuck then, as I actually cannot get access to the CLI on the host. I've been trying to replicate the issue locally, but currently struggling to even get Craft to install on Windows, let alone duplicate the live setup. – theAdhocracy Aug 23 at 18:38
  • Nevermind! I deleted composer.lock on the server, installed and uninstalled an arbitrary plugin to get it to rerun dependency checks in the background, and then it updated without any issues. 🤷‍♂️ – theAdhocracy Aug 23 at 18:49
2

Not a true fix, but on the off chance this helps someone, here are the steps I took:

  • Create a local clone of the live Craft install with a dummy database, but the same composer.json and project.yaml files.
  • Delete the storage and vendor folders, and the composer.lock file.
  • Run composer update.
  • Install a plugin from the live admin panel.
  • Delete the vendor folder and composer.lock file on the server.
  • Upload the new local vendor folder to the server.
  • Uninstall the plugin again, causing composer to run.

Then when I went back to the updates panel and reran it, Craft upgraded without any issues.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.