0

When Craft is in headlessMode my URLS for admin actions (ex. /admin/set-password) are set to the frontend URL (SITE_URL) instead of the Admin URL (SITE_ADMIN_URL).

Is this behavior as expected?

As my Frontend is using angular I would need to add a redirect on the NGINX server to get the links to work which is kind of a strange workaround. Shouldn't the Action urls use the Admin URL by default instead?

Current behavior:

www.example.com/admin/set-password

Expected behavior:

cms.example.com/admin/set-password

1

ok, just received the answer from the support. will add it here for anyone who has the same issue:

setting the baseCpUrl in the config/general.php does the trick:

'baseCpUrl' => 'https://cms.example.com/',

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.