Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [craft-pro]

The tag has no usage guidance.

0
votes
0answers
13 views

Shopify plugin breaks after changing to Craft Pro [closed]

We are using this Shopify plugin: https://github.com/nmaier95/craft-shopify-product-fetcher As long as we keep using Craft on trial, it works perfectly. But when we change to Craft Pro, the plugin ...
1
vote
1answer
17 views

Set UserGroups for existing User

Using Craft::Pro Edition, I want to add a specific UserGroup to an existing User in my module. I tried it this way, but the group is not saved. $userGroup = Craft::$app->userGroups->...
2
votes
1answer
42 views

How can I show a list of product options as checkboxes in the cart?

In my cart (Craft3/Commerce2), I need to show a line item's possible options from a checkbox field called "productOptions", and allow the user to select the desired options. Based on the Craft Docs, ...
2
votes
1answer
29 views

Display Backend User Entries on Front end

I have the user submitting to a function that adds entries to a field called completed. It basically adds entries to each user showing the admin who has completed what. I'm trying to figure out how ...
3
votes
3answers
567 views

How do image focal points work in Craft 3?

How image focal point is working in Craft 3? I Just see the dot but unable to set focus.
1
vote
1answer
100 views

Image quality get low in Craft 3 after applying image transform

As of now I am using Craft's image transform to render images according to the size. If this still appears low quality even Image Transform setting with qulity "Maximum".
0
votes
0answers
22 views

Radactor editor is now saving video link in Craft 3 [duplicate]

I am pasting Video link on Textarea and it showing live preview and also in textarea, but when I save the post then It is removing automatically from editor. and not display on frontend as well.
0
votes
0answers
28 views

How can I set a custom error/exception handler in a custom plugin?

I thought about using set_error_handler()/set_exception_handler() but my problem is I don't know how to call these in plugin code execution to be working effectively. My goal is to catch all errors/...
1
vote
2answers
28 views

Craft 2: Exception: CException: Alias “ext.alpha” is invalid

Today I updated my craft to latest version Craft V 2.6.3015 by following this url. I got it updated successfully and now my Craft version is 2.6.3015 which is latest of Craft 2. After updating the ...
0
votes
1answer
49 views

Login Page Logo and Site Icon gives 404 in Craft 3 [closed]

I have update the craft version from 3.0.2 to 3.0.3.1, after that Login Page Logo and Site Icon gives 404 path error. I have checked file permissions also but it is not creating link in cpresources ...
1
vote
1answer
119 views

Client License Transition to Solo/Pro

I have a Craft site with a Client license. After the recent license transition to Solo/Pro, a red banner appears along the top that reads "You’re running Craft Client with a Craft Pro license. [...
1
vote
1answer
89 views

Looking for a simple way to add/update information records with CraftCMS

I'm looking for a simple way to save form data to a database and be able to access that information. I'm not sure if I should use the custom fields or an entry (or a custom table) and if creating a ...
0
votes
0answers
107 views

CSRF with a Load Balanceer

I have a website where I get the following error bad request: CSRF token could not be verified I have the config setting set to true as well as adding the token to all of my forms via the docs. My ...
1
vote
1answer
58 views

Using elements-api, how do i create a geojson structure with Features within a FeatureCollections

I am trying to output, from a single request, a geojson structure like so: "type": "FeatureCollection", "features": [ { "type": "Feature", "properties": {}, ...
3
votes
0answers
141 views

Mailer config in Craft 3 not getting merged

I have this custom config in config/app.php, but Craft seems to keep using the default Control panel Sendmail config. It seems this doesn't get merged in the main.php file. (as promised) return [ '...
1
vote
2answers
41 views

Event onPublishDraft not firing

We are still trying to make a custom mail plugin. We have one problem left. When someone makes a draft, and later publishes it, only the onSaveEntry fires but without NewEntry. So we were trying to ...
1
vote
1answer
25 views

Removing index.php causes Not Found error on secondary pages

I'm moving an existing site to the new server and spent a couple of days trying to make this work. Home page of the site loads just fine. Other pages load too if I add /index.php/ to the url. ...
1
vote
2answers
408 views

Parse error: syntax error, unexpected '['

I am having a syntax error on my craftCMS website. Hoping someone could help me. Parse error: syntax error, unexpected '[' in /home16/puresoci/public_html/dev/craft/plugins/charge/ChargePlugin.php ...
1
vote
1answer
156 views

Recoverable error Object of class Craft\ElementCriteriaModel could not be converted to string after Update

After running Craft update I'm getting error on the meta author, meta description and meta keywords fields. Any idea how to resolve issue? Recoverable error Object of class Craft\...
1
vote
1answer
183 views

Missing required param: card[exp_month] on Charge 2

I created fields using Charge 2 plugin and after creating a form I getting an error Missing required param: card[exp_month]. <div class=""> <div class="grp-form"> <...
0
votes
0answers
83 views

Craft/TemplateLoaderException Issue

I am currenly using a plugin on CraftCMS which is called Charge. The submission of the form succeeded however it returns be an error below. > >Craft\TemplateLoaderException Unable to find the ...
1
vote
1answer
130 views

“A non-numeric value encountered” reintroduced after version 2.6.2991

It seems that an issue that was solved in craftcms 2.6.2991 is reintroduced afterwards. I have just updated a site to version 2.6.2997 and the exactly the same error that was there prior to version 2....
1
vote
1answer
248 views

Craft CMS Backing React FE using the element API

I am hoping to create a React Site that uses Craft CMS and the Element API as a backend. However, I know I will need to authenticate users and be posting data back into Craft which I believe the ...
3
votes
1answer
69 views

How can I safely identify a single asset-folder?

Background I'm writing a plugin that will function as a document-archive with access-rights to different folders set based on user-groups. In addition to folders which are restricted, there is also ...
1
vote
1answer
68 views

Can't access Craft CMS admin in Chrome Canary 63.0.3233.0

I'm not able to login to my local craft cms in google chrome canary, version 63.0.3233.0. I've attached a screenshot of the error message I've received when trying to go to the standard login page. I ...
0
votes
0answers
84 views

Can't assign a permissions to a user

I've upgraded to Craft 2.6.2990 and now I'm unable to assign permissions to a newly created user. Steps to reproduce: Create new user Click checkboxes to assign to a user group Click Save Dialog ...
1
vote
1answer
63 views

Seeking information on the largest Craft sites built

We're writing an article on the largest Craft sites built and I'm having some challenges finding this information. Ideally, we want to compile a list of the top 20. "Largest" is determined by certain ...
1
vote
1answer
71 views

How to insert a Sprout Form into a new page in Craft CMS

I am a Wordpress guy, and I've been given the task of handling my companies Craft site. I have been at this for hours, and can't seem to figure out how to get the damn form to appear on the page I ...
1
vote
1answer
97 views

404 on localized entries - Nginx

I'm stucked with a 404 error on all my localized sub-directories. It works fine for the homepage ( es. domain.com/es, domain.com/it ). Also urls in the main directory are behaving correctly. Example: ...
2
votes
1answer
470 views

Craft with ElasticSearch as a backend

Hope this kind of question (a pointer request, actually) is alright with StackExchange guidelines. We're looking to store all our data in ES. Is this possible at the moment? Any plugin to do so? We're ...
1
vote
1answer
30 views

White pages on Frontend

I'm quite new to Craft. I was working on templates, then I logged in to create a new section and now any frontend route is returning a blank page. 500 Internal Server Error. I restarted, Nginx, ...
2
votes
1answer
137 views

How would I create unique fields for different user groups programmatically?

I understand this isn't possible from the Control Panel, I'm developing a custom plugin for this specific client project. Essentially these user groups won't need access to the Control Panelat all, ...
1
vote
1answer
334 views

Running into permission issues using Vagrant on Ubuntu

I am having issues running CraftCMS in a vagrant environment. For reference: I am using ubuntu 17.04 Vagrant version 1.9.5 ubuntu/xenial64 (virtualbox, 20170525.0.0) Relevant initial ...
1
vote
1answer
167 views

File upload error in MS Azure after custom domain was pointed to Azure server

I am facing an issue with file uploads. I installed a new installation of Craft CMS on Microsoft Azure server. MS Azure assigns a default domain to your webapp like example.azurewebsites.net. So ...
2
votes
2answers
171 views

How can I import users from WordPress to Craft CMS?

I want to import users from WordPress to Craft CMS. How can I do that?
1
vote
1answer
262 views

How to change the Entry status to enabled from Disabled

I have created a page where user creates an entry but its status is disabled. This page then redirects to a page where the user gets to see a preview of his entry. On this preview page there are two ...
1
vote
0answers
90 views

Cannot upload files to server

I have a strange issue, I can't upload files to the server. The error message is Error uploading the file: The folder craft/storage/runtime/assets/tempuploads/user_7/field_101 does not exist The ...
0
votes
1answer
196 views

Website not indexing

Not sure what is going on but my website is not getting indexed by google (went live last week). Robots is correct. What am I missing here? I'm using the plugin seomatic for the SEO, Site robots meta ...
1
vote
1answer
165 views

Why do I get 'Could not resolve the subpath “{slug}” after trying to add a category select to a Neo field?

I tried to add a Category Select field into a Neoblock but when i first saved the entry I received the following error: Internal Server Error Could not resolve the subpath “{slug}”. I ...
-1
votes
2answers
190 views

What if I continue my website using Craft CMS Pro trial?

What would happen if I never buy Craft license and continue working in Craft CMS Pro trial ? Would the CMS be locked after some day or a error will show up on my website frontend ?
0
votes
1answer
237 views

SQLSTATE[42S02]: Base table or view not found

I am developing my Craft site locally with MAMP. Today when starting my site on localhost, I got this error: CDbCommand failed to execute the SQL statement: SQLSTATE[42S02]: Base table or view not ...
2
votes
4answers
146 views

Excluding an include template

is there a simple way to exclude an 'include' for specific pages? For instance I have an include {% include "_globals/_footer" %} but I don't want it to appear on my contact and 404 pages. How ...
3
votes
2answers
3k views

Passing JSON to Twig

I'm creating a multilingual site and I'm looking to pass some additional configuration data to Twig so I can use it in my template. For example, suppose I have a configuration like this: { "...
3
votes
1answer
893 views

Migrating from WordPress to Craft CMS

I am trying to migrate blog posts from WordPress to Craft CMS through the Feed Me plugin. First, I export posts in .xml file from Wordpress. Then, I import in Craft CMS. All things are good except ...
3
votes
0answers
220 views

Task “Resaving all localizable elements” is stuck when adding new new locale

I'm trying to add a new locale, but the task "Resaving all localizable elements" is stuck and the new locale is not being added to content. Even after restarting the task. There are no errors in the ...
1
vote
1answer
78 views

Display only entries relevant to users' country

I'm really struggling with displaying news entry that are only relevant to the users' location. Here is my structure: User Country - > is a dropdown with a single value (lets say UK) Regions is a ...
0
votes
1answer
101 views

Assets Uploader Just Spins and Does Nothing Else

I am using Craft locally, at localhost:8888 with free MAMP. I am unable to upload images using the Assets uploader. The images in Assets were dropped in manually in their directory. Permissions for ...
1
vote
1answer
89 views

Help needed with 2 node setup

I am setting up 2 node cluster with GlusterFS for shared file system. I have mounted the shared mount on each of the nodes but when I try to access login page I get this /data/websites/websiteapp/...
1
vote
1answer
131 views

Members' site in Craft possible out of the box?

I built a site in another CMS with an add-on which allows entries to be converted to member bios, and another add-on which makes sure all files uploaded by different members are viewable to that ...
1
vote
1answer
2k views

After upgrading to PHP 7 I started getting “storage folder isn't writable by PHP” errors

I just recently upgraded to PHP 7. The browser is now showing following error /home/xxx/craft/storage isn't writable by PHP. Please fix that Have not changed any permissions on any of the folders. ...