2

Issue:

craftcms/cms 3.3.9 requires ext-zip * -> the requested PHP extension zip is missing from your system.

Details:

I am running on MAMP Pro 5.3. Currently using PHP 7.3.3 (but previous versions had the same issue). Mac OS Catalina. I do not seem to be able to get ext-zip on my machine, and thusly not use many of the updated craft installs.

Attempted Solutions:

Install for macOS

https://stackoverflow.com/a/58300437

Install in MAMP

https://stackoverflow.com/a/59293432

cd /{php ext path}
pecl install zip
php --re zip | grep zip // version 1.15.4

(terminal php is set to mamp version)

# php7.3.3.ini (I also tried extension=zip.so)
; If you wish to have an extension loaded automatically, use the following
; syntax:
;
;   extension=modulename
    extension="/Applications/MAMP/bin/php/php7.3.3/lib/php/extensions/no-debug-non-zts-20180731/zip.so"

4

None of various attempts to get ext-zip going under Catalina had worked for me, including the above, but here’s what did, with thanks to Chad for showing the essence of the issue:

“the Craft system report is looking at MAMP's php info, whereas composer is looking at the system php info, which didn't have zip installed.”

…and then Brian for what worked for me:

“run composer on the command line specifically against the MAMP version of PHP”

Like this:

/Applications/MAMP/bin/php/<phpX.X>/bin/php </path/to/composer> create-project craftcms/craft </path/to/project-folder>

In my case:

  • <phpX.X> is php7.3.3
  • </path/to/composer> is /usr/local/bin/composer
1

The issue was due to a path problem. Path was set to

/Applications/MAMP/bin/php/php7.3.3/lib/php

but should have been

/Applications/MAMP/bin/php/php7.3.3/bin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.