1

I have the correct image asset source for S3 and also a local folder. Neither folder contents show (they were previously) and I see an "unknown error occurred" popup. I've tried turning off image transforms, increasing my PHP memory limit and simplifying my templates but I haven't had any luck

  • The underlying error message for "unknown error occurred" will be in your craft/storage/runtime/logs files. You can start there to help debug this. – Brad Bell Nov 15 '17 at 19:00
  • Hi Brad, this one didn't actually have any errors shown in the log files, see answer below – user2315552 Nov 16 '17 at 20:31
2

For anyone else experiencing this issue, there wasn't actually any error shown in the Craft log file. Craft was trying to index the S3 access log files on the bucket and treating them as image files. Reindexing images didn't solve the issue either but I got my images back by deleting all entries from the craft_assetfiles table for files have the dateModified field set to NULL (these were not image files but Craft had added them to the table). [Solved by Craft Support]

| improve this answer | |
1

Check your craft.log and phperrors for clues, wild guess is that you're running out of memory.

If that is the case you should increase memory_limit in PHP.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.