2

I can’t for the life of me get images to upload. Neither on my local server or on the live server. The progress bar goes to the end, and then … nothing. From what I can see online, I’m not the only one, but I can’t find any remedy.

  • I’ve gotten Imagemagick installed (locally, at least), but no change (GD is installed in both environments)
  • I’ve tried several types of image formats (seems some people have problems with JPEG)
  • I’ve tried relative asset paths and set through environmental variables

Nothing seems to work.

In the error logs, the only error I can find is: Undefined index: singleUploadLocationSource ([correct path]/craft/app/models/AssetFileModel.php:171)

I just realised that the files do get uploaded to the storage/runtime/assets/tempUploads folder. So seems it fails to completing the copy to the final assets folder. Permissions should be correct, from what I can understand (I'm no expert on these things).

Does anyone have any ideas what can be the cause? I’ve been scratching my head here for weeks, and it still itches like crazy.

2

My own fault – I had set a subpath in the field type, so it tried to save to a folder that didn't exist.

I had first thought it was here the asset path was set, and when I figured out I needed asset types, I forgot to delete the subpath.

Now it works! Both with Imagemagick (local) and GD (live server).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.