0

When we're adding a "link > link to an entry" to a rich text field, this will result in a link to https://www.site.com/page#entry:3962:url and we understand what the purpose is of this additional #entry:3962:url, but is there a way to disable this?

The multi-domain setup we created is not compatible with this feature, so it will create links that are broken. The easiest fix for our customer is to disable this feature all together. Is that possible and how?

  • You can disable the link function in your redactor by removing the option... In your backend field settings you'll have a field configuration in your rich text field and you can create your own redactor with custom options. So you can copy the options from craft and remove the link – Robin Schambach Nov 9 '17 at 9:04
  • @RobinSchambach Yeah, but we still want the ability to easily add links to entries, just not with the #entry:3962:url part. – Youniteus Nov 9 '17 at 10:36
1

and we understand what the purpose is of this additional #entry:3962:url, but is there a way to disable this?

Currently not. You'd need to write a Craft/Redactor plugin that used the addRichTextLinkOptions hook to do something similar to what the default "Link to an Entry" does, but with your own custom logic.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.