1

I setup an Assets field called Images. My Default Upload Location is set as {parent.uri}/{slug}

My File System Path for that folder is img/

The directory structure that is generated is correct and in this format: img/artists/artist_name/category_name/project_name

But the images are being saved in the root img/ directory.

What am I missing?

  • 1
    Assuming this field lives in a structured section, did you add it to the "My Default Upload Location" setting, which only applies to files drag-and-dropped onto the field? Or did you check the "Restrict uploads to a single folder" setting and add it to the "Upload Location" setting? The latter is the one you probably want to do. – Brad Bell Aug 9 '17 at 21:51
  • Can you add what the solution you ended up using as an official answer in case it helps someone in the future? – Brad Bell Aug 10 '17 at 17:04
1

I got the images to upload into correct folders by switching Image field to "Restrict uploads to a single folder" option. I also had to fix the File System Path in Settings>Assets>Asset Sources to the full file system path.

|improve this answer|||||
  • If you got it to work, you can accept your own answer – then others with the same problem can see there is a solution to find here :) – KSP Aug 14 '17 at 23:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.