1

I have completed a website for a school who can't upload files when in school. When they upload a file the status bar loads the full way across the screen but at the top right it just keeps spinning. Nothing more happens - the files doesn't become available. I can upload fine from home and the staff can upload fine at home as well. What is the likely cause of this issue - I have log files to check if need be - I deleted the log files then asked them to try and upload a file - then I took a copy of the log files with Dev Mode on.

Is this likely to be a Firewall Issue in the school? I did a website for another local school who would have the same IT provider but have no issues there.

  • the log files would be a good place to start. Writing Permission seems a probable cause. It could also be that the files they try to upload exceeds the max upload limit or the file is corrupted. – Jan_dh Jan 30 '17 at 16:38
  • I can upload files no problem here. The files they have tried to upload have worked ok when they have taken them home so I assume permissions is ok and the files they are uploading are ok. – mmc501 Jan 30 '17 at 16:49
  • Checking craft/storage/runtime/logs for upload related errors as well as your web server's error logs is a good place to start. I'd also recommend checking the response for the upload request in your browser's console. If you're not getting a response body, then the response status code is a good clue to start with. – Brad Bell Jan 31 '17 at 5:01
  • I know this is a super old post, but I'm having the same exact issue with an installation of craft that I'm working on. Were you able to resolve this issue? Oddly enough, whenever I open the network tab and refresh to see the responses, everything uploads as expected. – Frank A. Apr 4 at 22:37
  • In my case it was an issue with the school. I asked them to report the issue to their IT Provider so must have been something on their firewall blocking it. – mmc501 Apr 4 at 22:40
1

I'm glad you identified and resolved the issue!

I stumbled across this post because I had the same GUI response/result in Craft CMS and want to share how I resolved it for others that may have the same issue without being a firewall problem.

See my answer here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.