0

I try to upload a file larger than the 16 MB Craft limit. The file I try to upload is 61 MB.

I have set the maxUploadFileSize to 256000000. My hosting company changes the server PhP settings to this:

max_file_uploads = 20
upload_max_filesize = 256M
max_input_time = 180
memory_limit = 256M
post_max_size = 256M

The file starts to upload but when the progress bar is at 50%, it just stops. It keeps "uploading" (wheel keeps spinning in the top right corner) but nothing happens anymore.

I don't get a front-end error either. But in my browser console it says: ERR_CONNECTION_RESET

Anyone who can help me find a solution?

UPDATE

So, my hosting company made the time-out longer and the error dissapeared. But I still can't upload the file as I get this error in the console window now:

POST http://krycer.be/index.php/admin/actions/assets/uploadFile 502 (Proxy Error ( The specified network name is no longer available.  ))

When I diasble my proxy I get this error:

POST http://krycer.be/index.php/admin/actions/assets/uploadFile 500 (( The specified network name is no longer available.  ))

The file upload completes, but the status bar remains visible, allthough full, and the file is not visible in the assets folder.

  • Is it working with smaller images? Do you have access to setting the upload size on the server level? – Mark Busnelli Jr Dec 8 '14 at 15:00
  • It is working with smaller files. I don't have access to the server php settings but previously I got an error saying the file was to big. That's why I mailed the hosting company to adjust the PhP settings and I added the file setting in my general.php So the issue must be something else. – Tom De Smet Dec 8 '14 at 15:03
  • Do you know if the web server is Apache or Nginx? I ask because I know Nginx has quite a keen timeout default which I usually have to increase. – Steve Abraham Dec 8 '14 at 15:12
  • Also ask if they have Suhosin or mod_security installed/enabled. They have their own additional settings in addition to the standard php.ini ones. – Brad Bell Dec 8 '14 at 18:15
  • They told me that they adjusted the suhosin settings already. – Tom De Smet Dec 8 '14 at 18:24
1

It would be worth checking craft/storage/runtime/logs/craft.log, it's very likely there's a clue in there.

| improve this answer | |
  • I don't see any error logs dating to the file upload issue. I asked my hosting if it's apache or nginx. They do both. So awaiting an answer from them. – Tom De Smet Dec 8 '14 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.