3

A forbidden error appears and can't get it to disappear. I've gone through the installation process several times and everything else works.

When I load the URL "test.craft.dev", I get back "Forbidden: You don't have permission to access / on this server."

Things I've tried:

1) db.php

$craftPath = '../craft';

2) folder structure

/craft/..
/public/index.php

Any help would be greatly appreciated.

3

When I get this error it is usually because the top craft directory isn't readable. When you unzip the original craft zip file, you get something like this:

drwx------@ 5 m  staff       170 Jul  8 14:47 Craft-2.1.2563

And that top directory (the one that contains craft and public) needs to be readable by apache.

| improve this answer | |
2

I'm not quite sure I understand your folder structure, but as long as the craft/ folder is exactly one level above your public/index.php file, then the $craftPath setting you currently have will work.

The specific error message you are getting isn't coming from Craft... it's coming from Apache and will be related to how your server environment is currently setup.

There are some great threads here and here that should get you going in the right direction on how to resolve it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.