I'm trying to update Craft to 4.5.10 which requires PHP 8.0.2+ but I have Feed Me plugin installed, which is using Cakephp 3.10.5, which requires PHP >=5.6.0,<8.0.0.

Is it possible to update Craft to 4.5.10 without removing FeedMe plugin?


1 Answer 1


There are versions of cakephp/utility 3.3 that didn’t strictly require a PHP version. Component will figure that out and pull in the latest compatible version automatically when you run composer update.

(There aren’t any known PHP 8 conflicts with cakephp/utility which affect Feed Me.)

  • I tried it and I got the same response: Problem 1 - cakephp/utility 3.10.5 requires php >=5.6.0,<8.0.0 -> your php version (8.2.0; overridden via config.platform, same as actual) does not satisfy that requirement. - craftcms/feed-me 5.2.0 requires cakephp/utility ^3.3.12 -> satisfiable by cakephp/utility[3.10.5]. - craftcms/feed-me is locked to version 5.2.0 and an update of this package was not requested. Commented Nov 14, 2023 at 9:55
  • I tried to remove the Feed Me plugin and then I was able to update Craft to 4.5.10. After the Craft upgrade, I was able to install the Feed Me plugin. Thanks Brandon. Commented Nov 14, 2023 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.