1

Cross-posting from here, as I'm not sure if this is a Craft issue or specific to the cache-clear plugin.

Intermittently (twice in a day now), I've seen templates being cached with Craft URLs outputting as either /index.php/my-page/ or /index.php?p=my-page

Once this happens, clearing cache via the plugin url (http://domain.com/actions/cacheClear/clear?key=myKey) doesn't seem to fix anything, but clearing cache in the control panel does.

Any ideas?

2

There is an explanation of why this can occur on the Craft help section here: http://buildwithcraft.com/help/why-index.php

4
  • Grah! I knew I saw something about that somewhere. Thanks. – Tim Kelty Sep 18 '14 at 22:21
  • Based on the comments in /craft/app/etc/config/defaults/general.php, it looks like I don't also have to set usePathInfo if I set 'omitScriptNameInUrls' => true Wonderful! – Tim Kelty Sep 18 '14 at 22:26
  • I've added that in my general.php, yet index.php?p=my-page remains. Its only on production, not dev or local. Any ideas? example.com/my-page works on all environments. – Doug Feb 27 '15 at 17:02
  • update: I am using a 'maintenance mode' that blocks access based on IP address on production. That has a setting in the index.php file and if on uses another file to check access by IP. That process may affect removing index.php. I disabled that, cleared Craft caches, and URLs no longer have index.php. – Doug Feb 27 '15 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.