2

I'm trying to upload a 40MB video through the assets tab in the admin panel, but I get an error saying "The file "x.mp4" could not be uploaded, because it exceeds the maximum upload size of 8.0 MB." In my php.ini file it looks like I've got it set to 265MB and i'm not sure where else to check. Here's what my php.ini file looks like:

allow_url_fopen = Off
allow_url_include = Off
display_errors = Off
enable_dl = Off
file_uploads = On
max_execution_time = 30
max_input_time = 60
max_input_vars = 1000
memory_limit = 128M
session.gc_maxlifetime = 1440
session.save_path = "/var/cpanel/php/sessions/ea-php71"
upload_max_filesize = 256M
1

Craft has a maxUploadFileSize config setting, but it is set to 16MB by default. Maybe someone has changed it to 8MB for your install, though. It would be in craft/config/general.php.

  • i didn't see a maxUploadFileSize in my general.php but i added it and set it to 200MB and it's still giving me the same error. – DZIEY3 Sep 19 '17 at 20:45
  • There's nothing else in Craft that would be limiting file upload sizes, so it must be something environmental. Does your box have anything like Suhosin or mod_security installed? They provide their own additional settings. – Brad Bell Sep 19 '17 at 21:15
  • 1
    it was an option in my cpanel php settings, post_max_size was what was limiting it to 8MB – DZIEY3 Sep 22 '17 at 23:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.