12

I can't seem to edit entry details all of a sudden: in this Products section (and only this one section), the page title and "Current Version" button will render, but the rest of the page is missing.

enter image description here

The only clue is this line from Craft's log:

[31-Jul-2014 19:07:36 UTC] PHP Fatal error: Maximum function nesting level of '100' reached, aborting! in /Users/gob/projects/gobias/craft/app/vendor/twig/twig/lib/Twig/Node.php on line 140

I've loaded earlier MySQL backups, restarted MAMP Pro (PHP 5.5.10), cleared Craft's caches, tried different browsers and machines, and the problem persists.

| improve this question | | | | |
  • 1
    Have you filed a bug through the dashboard widget? Looks like a bug to me... – Marion Newlevant Jul 31 '14 at 20:43
  • Thanks @Marion—yes I did, and I'm actually asking here since Brad said it's come up before. Answer's on the way! – Matt Stein Jul 31 '14 at 20:44
25

That error isn't a Craft or PHP error, it's coming from older versions of xDebug.

It can happen on more complicated pages (lots of fields, tabs, etc.), but you can get around it by adjusting the xdebug.max_nesting_level to something higher than the default 100 or to upgrade xDebug to 2.3+, which has changed to the default value to 256.

Note that you don't have to have an active debug session going on in order to run into this, you just have to have the xDebug extension installed.

| improve this answer | | | | |
  • Thanks Brad. I set it to 250 on a whim, and all's well again. – Matt Stein Jul 31 '14 at 20:45
  • 5
    WHO DEBUGS THE DEBUGGERS?! – Brad Bell Jul 31 '14 at 20:54
  • 5
    Philosophy majors. – Matt Stein Jul 31 '14 at 20:55
  • 1
    programmer psychologists – Luke Holder Aug 4 '14 at 4:03
  • I am having the same issue but I don't know where to edit the "debug.max_nesting_level" setting. Can someone point me in the right direction? – user3818623 Jan 17 '16 at 15:07
-1

Simplest solution is just to deactivate all debugger stuff in mamp's PHP settings -> Uncheck: Debugger Activate Xdebug.

| improve this answer | | | | |
  • 2
    That's the simplest solution provided that you're not using the debugger and/or never plan to. – Matt Stein Feb 27 '16 at 23:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.