3

It works for me, just changing the config file: { "buttons": ["html", "bold", "italic"], "plugins": ["fullscreen", "**limiter**", "counter"], "linkNewTab": true, "toolbarFixed": true, **"limiter": 235** }


3

The redactor configs are stored inside the config/redactor directory. Make sure you're editing the right config that your field uses (eg Standard) and add: "minHeight":"500px", ... to that file. The configs use JSON so when you see a Redactor configuration, that's how Craft is going to initialize it. To answer your other question, ...


2

At the moment, your are overriding $event->linkOptions which contains an array with all options to an empty array with $event->linkOptions = []. First, add the below to your module and refresh any page on your site so you see what you are working with: Event::on( RedactorField::class, RedactorField::EVENT_REGISTER_LINK_OPTIONS, function(...


2

If you just want to add YouTube or Vimeo videos to your page, you'd be better off using a dedicated plugin such as Embedded assets. It allows you to treat videos as regular assets.


2

Since the video button is supplied by a plugin, it should go under the plugins key rather than the buttons key. Your config would end up something like: { "buttons": ["html", "format", "bold", "italic", "lists", "link", "file"], "plugins": ["video"] }


2

Make sure that you checked Use this field’s values as search keywords under Settings → Fields → Your field With that in place, run ./craft resave/entries --update-search-index (docs) and your entries should start showing up in your search results.


2

Inside the buttons array, you should only mention formatting. The actual styles you want to put inside an array with key "formatting". { "buttons": [ "html", "formatting", "bold", "italic", "unorderedlist", "orderedlist", "link", "...


1

So thanks to @Dajo on the Craft Discord channel for any other folk out there experiencing similar turns out there was a config set-up for the site wasn't aware of that had set the dataDelimiter parameter to , which was exploding the HTML content into an array. Changing this has sorted the problem!


1

"repositories": [ { "type": "path", "url": "plugins/redactor" } ] With that in your composer.json file, you're telling Composer to look in a plugins/redactor folder from the root of your project and use that to satisfy the "craftcms/redactor" dependency (instead of pulling it ...


1

Redactor is perfectly capable of rendering an unordered list, so perhaps your question is a little unclear. If you mean that there's no formatting button to format an unordered list, check that you're using an appropriate redactor config which allows the use of 'unorderedlist' in your field definition: More instructions about how to configure Redactor in ...


1

Rename your file to the default.


1

It's probably not the answer you want to hear, but the best way to avoid these kind of problems is to modernise your content model so that videos are stored in their own dedicated section, and then allow authors to create relationships to those video entries via a dedicated 'video' block type in a content matrix. Similar for images really (though it is ...


1

You can simply use striptags filter which removes all HTML tags. But if you want an html tag to be not removed by striptags so you can pass it as argument, then It removes other tags except the ones you pass in. In other words, if you don’t  want to remove tag, just use it in this way: {{entry.content|striptags('<strong>') | raw }}


1

You should first go to the Settings > Fields Then click on the particular field in which you have selected the Redactor as a field type. Then you can see Advanced option at the end of the page and Uncheck "Remove inline styles" options there. So Redactor Editor will not remove inline CSS from your added html content.


1

The unfortunate answer here is you can't add classes to ul or ol elements using formattingAdd, at least that's the way I interpret the documentation. See: https://imperavi.com/redactor/docs/settings/formatting/#s-formattingadd It states: formattingAdd can only be applied to block tags (p, pre, blockquote, div, heading, etc). I suspect the etc there also ...


1

In case anyone runs into this issue and finds the Redactor-Extras plugin isn't working, this plugin by Doug Thwaites worked for me: https://github.com/DougThwaites/CraftRedactorFontAlignment


Only top voted, non community-wiki answers of a minimum length are eligible