3

I'm sure the documentation could be better, but this has nothing to do with Duct Video, it's simply a user error. Although a common one, when accessing things inside a matrix, assets field, or similar. When you do: {% for video in entry.videos %} video is a matrix block. Not the field you've created inside that matrix blocktype. When accessing video....


3

@crawf was right with his answer, but I recently saw the preview release for Craft 3, so Placid 2 is going to wait and be written for that. So I thought I should fix the current version of Placid to work with the latest version of OAuth (currently 0.9.71) and as a brucie bonus you can now connect to more than just the twitter api :) You can get the latest ...


2

Are you using the 0.9.60 version of OAuth? There are some issues with Placid and the latest OAuth version, which will be fixed in Placid 2.


1

You didn't mention in the post, but you tagged the question with Dukt oAuth. If you're trying to connect with that, Channel Advisor isn't a 1st or 3rd party Dukt oAuth provider. You can see a list of the available ones here: https://dukt.net/oauth/providers You'd need to right an oAuth Channel Advisor Craft plugin in order for it to work.


1

Not really Craft related, but that cURL error is because you're trying to connect to an https endpoint, but your local server doesn't have a matching certificate to verify against. You can see here for some solutions across different environments: https://stackoverflow.com/questions/29822686/curl-error-60-ssl-certificate-unable-to-get-local-issuer-...


1

You can set usePathInfo = true in your Craft general settings to force Craft to use PATH_INFO to generate URLs. https://craftcms.com/docs/config-settings#usePathInfo Dukt OAuth should now show you a redirect URI without a query string (Facebook doesn’t like slashes in the query string and automatically encodes them) and you should be able to make the URIs ...


1

It was indeed missing files, as suggested by Alec and Benjamin. All down to some non-specific .gitignore rules that meant it was ignoring all "src" folders - which is one of the folders created by the composer install Thanks for your help guys!


Only top voted, non community-wiki answers of a minimum length are eligible