Hot answers tagged

14

These days I just use Mandrill. It's simple to set up, free unless you're sending tens of thousands of emails, and you can continue to use it on any development (or production) machine without any configuration changes. Just set the Mandrill SMTP settings in the Craft admin area, and you're done.


13

I had this same issue and resolved it (at the suggestion of Craft CMS support) by enabling ImageMagick in the php.ini and restarting MAMP PRO. Per the MAMP PRO 3.0 user guide: The ImageMagick PHP module is included by default, but you must enable it inside the php.ini template file. Remove the ‘;’ from the following line. ;extension=imagick.so


8

I had the same issue and solved it. This seems to be an issue with the exif lib. Try to disable mbstring overloading by setting mbstring.func_overload = 0 to your php.ini or php_admin_value mbstring.func_overload 0 in your apache virtual host configuration. Hope that helps -Oliver


5

Try going to yoursite.com/index.php/(pagename). If that works, check out this article on how to remove it: https://craftcms.com/support/remove-index.php


5

I found the answer: in the main window of MAMP Pro there's a sidebar with a sub heading Languages > PHP. When you click that and check the option under Extensions: Imagick / ImageMagick, all my problems disappear and I can upload JPG and PNG.


5

When I'm trying to get past my initial errors, here are some of the things I try. This is assuming you have the usual directory setup, with the webroot public on the same level as craft Create foo.html in public, and visit yourdomain.com/foo.html. Good for mamp problems, virtual host problems, permissions problems. edit public\index.php and add die('made it ...


4

I kept bumping into the same kind of issue. Even when I applied a fix mentioned here or in another topic. After a while the same issue would arise again. What finally did the trick for me - in MAMP, was to add additional parameters to the host-file. In MAMP, select the desired host. On the right side choose the Extended tab. Where it says 'Additional ...


4

I'd highly recommend you check out Laravel Valet. Here's an article on it that may be useful to you as well: Running Craft CMS 3 on Laravel Valet


4

If you've seeing any install screen instead of an update screen, that means that Craft can connect to the database server specified in craft/config/db.php file, but it either can't find the database you've specified or it can't find the craft_info table. A common cause of this is the tablePrefix database config setting changed, for example.


4

None of various attempts to get ext-zip going under Catalina had worked for me, including the above, but here’s what did, with thanks to Chad for showing the essence of the issue: “the Craft system report is looking at MAMP's php info, whereas composer is looking at the system php info, which didn't have zip installed.” …and then Brian for what worked ...


3

I would try and put the port in your siteUrl config param: 'siteUrl' => 'http://localhost:8888', Alternatively you might be able to use this though haven't tested it (I believe the php server variable uses the server name & port number): 'localhost' => array( 'siteUrl' => 'http://'.$_SERVER['HTTP_HOST'], 'devMode' => true, '...


3

It's been a while since I was in Craft 2, but I'd suggest checking out this page in the docs: https://craftcms.com/docs/2.x/folder-structure.html Do all of the directories mentioned on that page exist on your site? Specifically, I'd confirm that you have the craft/storage folder created in your installation. If it's not there, make it and try to load the ...


2

If you install a secondary app within your Craft directory, you have to tell Craft to ignore all these requests. Just edit your .htaccess file accordingly. See my answer here on how you can do this: "Is it possible to tell Craft to ignore requests to under a certain path?"


2

siteUrl works with an array of locales if you're using the actual siteUrl config setting. What you're currently doing is creating a separate 'siteUrl' environment variable, which places in the control panel aren't expecting to be in array format. More good info on the different ways to set siteUrl here.


2

Here is how I have set things up in the past using a similar workflow. When you get Craft out of the box (for lack of better words) as you said there is a craft folder and a public folder. Generally you want your craft folder above/out of your web root. That would look something like this: craft/ |- app |- config ... public/ |- index.php |- ...


2

Are you required to run port 8888? If not, you can set the port to 80 in MAMP and this would resolve the issue. I know this is not really a fix for your problem but it might be a potential work-around.


2

In this case, it was just human error and ignorance of how hidden template files work through the CMS. I believed that I should be able to call the hidden file in the browser, via something like "base_url/subfolder/_hiddenfile.html" and partially I was able. For whatever reason, using this primitive test method, I was able to see the header and footer, but ...


2

I have just run into a similar problem. I'm not sure if this is what fixed it but try creating an Envvars file as per jonlivingstone's comment here https://github.com/craftcms/cms/issues/2364 Once I had done that my backup ran. I then had to switch MAMP out of FastCGI mode otherwise I got a 500 error at the end of the update process.


2

Include this if statement at the bottom of your config/db.php file // If a local config file exists, merge if (is_array($localConfig = @include(CRAFT_CONFIG_PATH . 'local/db.php'))) { // does our default config already have a local key? if(array_key_exists('local', $config)) { // If so, merge what's in our local/db.php $config['...


2

Craft 3 does not come up with templates or default entries like Craft 2 so your templates directory is probably empty. As soon as you create some files there and link them to your entries you won't see the error when you enter your home url


2

After some searching, I decided to move my src/ folder into the web/ folder, since Craft seems to be looking only there and not at anything above that directory. Then, my CSS links were updated to relative paths like this: src/css/typeplate.css. And that worked.


2

I have run the following on my computer in order to allow Mac OS's terminal to speak to MAMP's MySQL. I have not done the steps outlined in your linked article. Craft's built-in backup tool works fine for me so perhaps this will help you too. sudo ln -s /Applications/MAMP/Library/bin/mysqldump /usr/local/bin/mysqldump Here's a github issue on the matter ...


2

Per my earlier comment, the convert_encoding filter is causing this, I think only in newer versions of Twig than what my live site running Craft 2 uses. I guess that probably somewhere in my site content, one of our content managers somehow inserted a character that convert_encoding is choking on. Rather than figure out where that is, and know that the ...


1

There was a rule in my .htaccess to remove www that was redirecting to the live production site. Once I removed that I needed to delete my browser cache.


1

It's not a server sided issue you are running into. Best guess is that you deleted some of the original code in either the _layout.html or your new template file. When you first setup the environment did the basic Craft site which is set in the standard files show up? Make sure you layout.html got the {% block content %} {% endblock %} Aswell or else it ...


1

Why not use MAMP Pro to define seperate local url's for your projects? Or use something like Virtual Host X. This way you can define some made up url like: yourporoject.dev and point that url to the public folder of your project.


1

I am answering this to report that I did get it working and to collect the links describing edits needed in the my.cnf and httpd.conf files in one place. I got it working earlier today by starting over completely with a new server in MAMP Pro, a new db created in PHPMyAdmin, and a freshly downloaded set of files from craftcms.com I made the file ...


1

The answer is now included in the question. Don't be a dingbat and make sure MAMP or Apache (or whatever webserver you're using) is configured properly.


1

Apparently what I did was correct, because now it works. I had some EE files right next to the index.php files and these messed things up for some reason. Probably the admin.php file. At least now I know it's easy to deploy Craft with the three steps I mentioned above


1

So Brad, this: 'pazzo.dev' => array( 'devMode' => true, 'environmentVariables' => array( 'fileSystemPath' => '/Applications/MAMP/htdocs/pazzo/', ), 'siteUrl' => array( 'en' => 'http://pazzo.dev:8888/en/', 'fr' => 'http://pazzo.dev:8888/fr/', 'nl' => 'http://...


Only top voted, non community-wiki answers of a minimum length are eligible